Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка непустых столбцов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка непустых столбцов (Формулы/Formulas)
Выборка непустых столбцов
Poligraf510 Дата: Понедельник, 13.01.2020, 10:08 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день, из таблицы необходимо перенести в новую только те столбцы, где есть данные. Заранее благодарен!
К сообщению приложен файл: 2018687.xlsx(9.9 Kb)
 
Ответить
СообщениеДобрый день, из таблицы необходимо перенести в новую только те столбцы, где есть данные. Заранее благодарен!

Автор - Poligraf510
Дата добавления - 13.01.2020 в 10:08
bmv98rus Дата: Понедельник, 13.01.2020, 12:07 | Сообщение № 2
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2897
Репутация: 501 ±
Замечаний: 0% ±

Excel 2013/2016
В чем вопрос? Как убедится что в столбце есть данные или как скопировать быстро те что нужно?


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеВ чем вопрос? Как убедится что в столбце есть данные или как скопировать быстро те что нужно?

Автор - bmv98rus
Дата добавления - 13.01.2020 в 12:07
Poligraf510 Дата: Понедельник, 13.01.2020, 12:11 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Нет, просто на втором листе отобразить только непустые столбцы, через формулы.


Сообщение отредактировал Poligraf510 - Понедельник, 13.01.2020, 12:12
 
Ответить
СообщениеНет, просто на втором листе отобразить только непустые столбцы, через формулы.

Автор - Poligraf510
Дата добавления - 13.01.2020 в 12:11
Nic70y Дата: Понедельник, 13.01.2020, 12:17 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5824
Репутация: 1274 ±
Замечаний: 0% ±

ru13;10;03
заголовок, массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС('Исходные данные'!$A1:$F1;НАИМЕНЬШИЙ(ЕСЛИ('Исходные данные'!$A2:$F2<>"";СТОЛБЕЦ('Исходные данные'!$A2:$F2));СТОЛБЕЦ()));"")
остальное, обычная
Код
=ЕСЛИОШИБКА(--(ГПР(A$1;'Исходные данные'!$A:$F;СТРОКА();)&"");"")
К сообщению приложен файл: 0081598.xlsx(10.9 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениезаголовок, массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС('Исходные данные'!$A1:$F1;НАИМЕНЬШИЙ(ЕСЛИ('Исходные данные'!$A2:$F2<>"";СТОЛБЕЦ('Исходные данные'!$A2:$F2));СТОЛБЕЦ()));"")
остальное, обычная
Код
=ЕСЛИОШИБКА(--(ГПР(A$1;'Исходные данные'!$A:$F;СТРОКА();)&"");"")

Автор - Nic70y
Дата добавления - 13.01.2020 в 12:17
Poligraf510 Дата: Понедельник, 13.01.2020, 12:23 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Огромное Спасибо Nic70y, это то что было нужно.
 
Ответить
СообщениеОгромное Спасибо Nic70y, это то что было нужно.

Автор - Poligraf510
Дата добавления - 13.01.2020 в 12:23
bmv98rus Дата: Понедельник, 13.01.2020, 12:47 | Сообщение № 6
Группа: Проверенные
Ранг: Участник клуба
Сообщений: 2897
Репутация: 501 ±
Замечаний: 0% ±

Excel 2013/2016
Nic70y, Понимаю что сейчас будет ответ, мол, каков пример таков и ответ, но а вдруг во второй строке будет пусто, а в 3 значение будет?

Вторым вариантом, без промежуточной таблички пользоваться не рекомендую, это так, для устрашения.
К сообщению приложен файл: Copy_of_1406.xlsx(21.5 Kb)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Понедельник, 13.01.2020, 12:48
 
Ответить
СообщениеNic70y, Понимаю что сейчас будет ответ, мол, каков пример таков и ответ, но а вдруг во второй строке будет пусто, а в 3 значение будет?

Вторым вариантом, без промежуточной таблички пользоваться не рекомендую, это так, для устрашения.

Автор - bmv98rus
Дата добавления - 13.01.2020 в 12:47
Poligraf510 Дата: Понедельник, 13.01.2020, 16:14 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Пусто не будет, так совпало видимо.. Но спасибо и bmv98rus, за потраченное время. Ваш вариант тоже попробую покрутить...
 
Ответить
СообщениеПусто не будет, так совпало видимо.. Но спасибо и bmv98rus, за потраченное время. Ваш вариант тоже попробую покрутить...

Автор - Poligraf510
Дата добавления - 13.01.2020 в 16:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка непустых столбцов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!