Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск и подстановка данных с другого листа/книги - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и подстановка данных с другого листа/книги (Формулы/Formulas)
Поиск и подстановка данных с другого листа/книги
seva_compani Дата: Среда, 15.01.2020, 16:15 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго дня уважаемые форумчане !
Прошу помочь в решении простенькой задачки. Есть огромный список фамилий на листе 1, а на другом листе заполненная таблица с важными данными, необходимо найти фамилии с листа 1 и вписать их в соседнюю колонку, если фамилии на листе 1 нет, соответственно ничего не вписываем в соседнюю колонку.
Желательно обойтись не макросом, а формулой.
Спасибо Вам большое.
 
Ответить
СообщениеДоброго дня уважаемые форумчане !
Прошу помочь в решении простенькой задачки. Есть огромный список фамилий на листе 1, а на другом листе заполненная таблица с важными данными, необходимо найти фамилии с листа 1 и вписать их в соседнюю колонку, если фамилии на листе 1 нет, соответственно ничего не вписываем в соседнюю колонку.
Желательно обойтись не макросом, а формулой.
Спасибо Вам большое.

Автор - seva_compani
Дата добавления - 15.01.2020 в 16:15
seva_compani Дата: Среда, 15.01.2020, 16:15 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
вот пример.
К сообщению приложен файл: 8577406.xls(56.0 Kb)
 
Ответить
Сообщениевот пример.

Автор - seva_compani
Дата добавления - 15.01.2020 в 16:15
Pelena Дата: Среда, 15.01.2020, 16:29 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15032
Репутация: 3284 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=ЕСЛИОШИБКА(ВПР(СЖПРОБЕЛЫ(K3)&"*";Лист1!$A$2:$A$418;1;0);"")

СЖПРОБЕЛЫ и "*" пришлось добавить, т.к. есть лишние пробелы в начале и в конце значений как на первом листе так и на втором
Есть ещё лишнее слово Бронь. Если его убрать, то Жеребцов Юрий Валентинович тоже найдётся
К сообщению приложен файл: 1940148.xls(76.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ЕСЛИОШИБКА(ВПР(СЖПРОБЕЛЫ(K3)&"*";Лист1!$A$2:$A$418;1;0);"")

СЖПРОБЕЛЫ и "*" пришлось добавить, т.к. есть лишние пробелы в начале и в конце значений как на первом листе так и на втором
Есть ещё лишнее слово Бронь. Если его убрать, то Жеребцов Юрий Валентинович тоже найдётся

Автор - Pelena
Дата добавления - 15.01.2020 в 16:29
seva_compani Дата: Среда, 15.01.2020, 16:48 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Прошу прощения, изначально не все данные скопировал на лист 1.
помимо ФИО необходимо скопировать и номер полиса с датой оформления. на примере как у клиента Жеребцов Юрий Валентинович
К сообщению приложен файл: 2101867.xls(89.5 Kb)


Сообщение отредактировал seva_compani - Среда, 15.01.2020, 16:49
 
Ответить
СообщениеПрошу прощения, изначально не все данные скопировал на лист 1.
помимо ФИО необходимо скопировать и номер полиса с датой оформления. на примере как у клиента Жеребцов Юрий Валентинович

Автор - seva_compani
Дата добавления - 15.01.2020 в 16:48
Pelena Дата: Среда, 15.01.2020, 16:59 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 15032
Репутация: 3284 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Ну, Вы бы почитали справку по функции ВПР и дальше уже сами...
К сообщению приложен файл: 0942560.xls(99.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеНу, Вы бы почитали справку по функции ВПР и дальше уже сами...

Автор - Pelena
Дата добавления - 15.01.2020 в 16:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и подстановка данных с другого листа/книги (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!