Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных с одного листа на другой - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных с одного листа на другой (Формулы/Formulas)
Перенос данных с одного листа на другой
ZigZagRuka Дата: Понедельник, 20.01.2020, 11:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день.
Помогите, пожалуйста, с формулой. Пытался сам сделать, но видимо моих знаний недостаточно.
Надо чтобы при внесении данных в лист "Список" (в зеленые ячейки), они автоматически формировали список с этими данными в листе "Накладная". Во вложении пример как должно быть. Заранее спасибо.
К сообщению приложен файл: 1._.xlsx(43.2 Kb)
 
Ответить
СообщениеДобрый день.
Помогите, пожалуйста, с формулой. Пытался сам сделать, но видимо моих знаний недостаточно.
Надо чтобы при внесении данных в лист "Список" (в зеленые ячейки), они автоматически формировали список с этими данными в листе "Накладная". Во вложении пример как должно быть. Заранее спасибо.

Автор - ZigZagRuka
Дата добавления - 20.01.2020 в 11:04
китин Дата: Понедельник, 20.01.2020, 11:12 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Добрый!
так надо?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Список!$C$9:$C$75;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Список!$F$9:$F$75);СТРОКА($F$9:$F$75)-8);СТРОКА(A1)));"")

формула массива
К сообщению приложен файл: 1-.xlsx(46.2 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеДобрый!
так надо?
Код
=ЕСЛИОШИБКА(ИНДЕКС(Список!$C$9:$C$75;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Список!$F$9:$F$75);СТРОКА($F$9:$F$75)-8);СТРОКА(A1)));"")

формула массива

Автор - китин
Дата добавления - 20.01.2020 в 11:12
YouGreed Дата: Понедельник, 20.01.2020, 11:33 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 589
Репутация: 123 ±
Замечаний: 0% ±

Excel 2010
китин, Допилил форму для ТС:

Код
=ЕСЛИ($C9="";"";ЕСЛИ(ВПР($C9;Список!$C$9:$F$75;СТОЛБЕЦ(B1);0)=0;"";ВПР($C9;Список!$C$9:$F$75;СТОЛБЕЦ(B1);0)))
со второго столбца, протягиваем. Для заполнения по другим столбцам.

И ладно уж:

Код
=ЕСЛИОШИБКА(ИНДЕКС(Список!C$9:C$75;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Список!$F$9:$F$75);СТРОКА($F$9:$F$75)-8);СТРОКА(A1)));"")


Массив, но протягиваемая, для заполнения одной формулой.

[offtop]Простите Игорь, за плагиат.
К сообщению приложен файл: 2363031.xlsx(46.9 Kb)


Сообщение отредактировал YouGreed - Понедельник, 20.01.2020, 11:41
 
Ответить
Сообщениекитин, Допилил форму для ТС:

Код
=ЕСЛИ($C9="";"";ЕСЛИ(ВПР($C9;Список!$C$9:$F$75;СТОЛБЕЦ(B1);0)=0;"";ВПР($C9;Список!$C$9:$F$75;СТОЛБЕЦ(B1);0)))
со второго столбца, протягиваем. Для заполнения по другим столбцам.

И ладно уж:

Код
=ЕСЛИОШИБКА(ИНДЕКС(Список!C$9:C$75;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Список!$F$9:$F$75);СТРОКА($F$9:$F$75)-8);СТРОКА(A1)));"")


Массив, но протягиваемая, для заполнения одной формулой.

[offtop]Простите Игорь, за плагиат.

Автор - YouGreed
Дата добавления - 20.01.2020 в 11:33
jakim Дата: Понедельник, 20.01.2020, 11:53 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1116
Репутация: 295 ±
Замечаний: 0% ±

Excel 2010
Предлагаю такой вариант без массивного ввода

Код
=IFERROR(INDEX(Список!C$9:C$200;AGGREGATE(15;6;ROW($1:$200)/ISNUMBER(Список!$E$9:$E$200);ROWS($9:9)));"")
К сообщению приложен файл: 8866966.xlsx(42.8 Kb)
 
Ответить
Сообщение
Предлагаю такой вариант без массивного ввода

Код
=IFERROR(INDEX(Список!C$9:C$200;AGGREGATE(15;6;ROW($1:$200)/ISNUMBER(Список!$E$9:$E$200);ROWS($9:9)));"")

Автор - jakim
Дата добавления - 20.01.2020 в 11:53
ZigZagRuka Дата: Понедельник, 20.01.2020, 12:41 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем огромное, человеческое спасибо) Все как доктор прописал
 
Ответить
СообщениеВсем огромное, человеческое спасибо) Все как доктор прописал

Автор - ZigZagRuka
Дата добавления - 20.01.2020 в 12:41
ZigZagRuka Дата: Пятница, 28.02.2020, 13:08 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Номенклатур оказалось больше чем ожидал. Попытался увеличить диапазон самостоятельно, но как писал ранее: видимо моих знаний недостаточно. Увеличьте, пожалуйста, диапазон переносимых данных в лист Накладная с листа Список, до 142 строки, сейчас он заканчивается на 75. Заранее спасибо
К сообщению приложен файл: 4264983.xlsx(46.2 Kb)
 
Ответить
СообщениеДобрый день. Номенклатур оказалось больше чем ожидал. Попытался увеличить диапазон самостоятельно, но как писал ранее: видимо моих знаний недостаточно. Увеличьте, пожалуйста, диапазон переносимых данных в лист Накладная с листа Список, до 142 строки, сейчас он заканчивается на 75. Заранее спасибо

Автор - ZigZagRuka
Дата добавления - 28.02.2020 в 13:08
YouGreed Дата: Пятница, 28.02.2020, 13:52 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 589
Репутация: 123 ±
Замечаний: 0% ±

Excel 2010
ZigZagRuka,

Код
=ЕСЛИ($C9="";"";ЕСЛИ(ВПР($C9;Список!$C$9:$F$175;СТОЛБЕЦ(B1);0)=0;"";ВПР($C9;Список!$C$9:$F$175;СТОЛБЕЦ(B1);0)))


Код
=ЕСЛИОШИБКА(ИНДЕКС(Список!C$9:C$175;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Список!$F$9:$F$175);СТРОКА($F$9:$F$175)-8);СТРОКА(A1)));"")

Формула массивна, вводите нажатием Ctrl+Shift+Enter

[p.s.]Добавил "1" перед 75, Вы можете также попробовать сделать хоть 1175, хоть 11175.


Сообщение отредактировал YouGreed - Пятница, 28.02.2020, 13:52
 
Ответить
СообщениеZigZagRuka,

Код
=ЕСЛИ($C9="";"";ЕСЛИ(ВПР($C9;Список!$C$9:$F$175;СТОЛБЕЦ(B1);0)=0;"";ВПР($C9;Список!$C$9:$F$175;СТОЛБЕЦ(B1);0)))


Код
=ЕСЛИОШИБКА(ИНДЕКС(Список!C$9:C$175;НАИМЕНЬШИЙ(ЕСЛИ(ЕЧИСЛО(Список!$F$9:$F$175);СТРОКА($F$9:$F$175)-8);СТРОКА(A1)));"")

Формула массивна, вводите нажатием Ctrl+Shift+Enter

[p.s.]Добавил "1" перед 75, Вы можете также попробовать сделать хоть 1175, хоть 11175.

Автор - YouGreed
Дата добавления - 28.02.2020 в 13:52
ZigZagRuka Дата: Пятница, 28.02.2020, 15:18 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое) hands теперь понял, справился.
 
Ответить
СообщениеСпасибо большое) hands теперь понял, справился.

Автор - ZigZagRuka
Дата добавления - 28.02.2020 в 15:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных с одного листа на другой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!