Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных из одного документа в другой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из одного документа в другой (Формулы/Formulas)
Перенос данных из одного документа в другой
BetWinner Дата: Суббота, 01.02.2020, 11:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Доброго времени суток, Прошу вашей помощи ГУРУ! Имеются два отдельных файла Excel (Оперативка1 и oper по сырью2),эти два файлы связаны между собой, т.е. второй файл вытягивает данные с первого. При добавлении строки (наименования сырья) в первый файл нижние строки соответственно съезжают и второй файл начинает вытягивать не те данные, каким образом можно решить эту проблему? А то в ручную всё перебивать с ума сойдешь! Заранее огромное спасибо
К сообщению приложен файл: 5721409.xls(49.0 Kb) · oper__2.xls(80.5 Kb)
 
Ответить
СообщениеДоброго времени суток, Прошу вашей помощи ГУРУ! Имеются два отдельных файла Excel (Оперативка1 и oper по сырью2),эти два файлы связаны между собой, т.е. второй файл вытягивает данные с первого. При добавлении строки (наименования сырья) в первый файл нижние строки соответственно съезжают и второй файл начинает вытягивать не те данные, каким образом можно решить эту проблему? А то в ручную всё перебивать с ума сойдешь! Заранее огромное спасибо

Автор - BetWinner
Дата добавления - 01.02.2020 в 11:12
Hugo Дата: Суббота, 01.02.2020, 17:35 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2890
Репутация: 644 ±
Замечаний: 0% ±

Добрый день.
Похоже что можно использовать ВПР(), если привести названия в соответствие.
Ну или если не приводить (да и там есть суммы) - прописывайте нужные названия прямо в формуле.
P.S. Формулы не могут делать переносов, они могут только отображать результат вычислений, ну или копировать!


excel@nxt.ru
webmoney: E265281470651 R418926282008 Z422237915069


Сообщение отредактировал Hugo - Суббота, 01.02.2020, 17:39
 
Ответить
СообщениеДобрый день.
Похоже что можно использовать ВПР(), если привести названия в соответствие.
Ну или если не приводить (да и там есть суммы) - прописывайте нужные названия прямо в формуле.
P.S. Формулы не могут делать переносов, они могут только отображать результат вычислений, ну или копировать!

Автор - Hugo
Дата добавления - 01.02.2020 в 17:35
BetWinner Дата: Суббота, 01.02.2020, 21:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Hugo, а как мне прописать правильно название в формуле, если можно с примером из таблиц, а то я чайник в этом деле, спасибо! Может =ДВССЫЛ () поможет?


Сообщение отредактировал BetWinner - Суббота, 01.02.2020, 22:13
 
Ответить
СообщениеHugo, а как мне прописать правильно название в формуле, если можно с примером из таблиц, а то я чайник в этом деле, спасибо! Может =ДВССЫЛ () поможет?

Автор - BetWinner
Дата добавления - 01.02.2020 в 21:57
Hugo Дата: Суббота, 01.02.2020, 22:51 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2890
Репутация: 644 ±
Замечаний: 0% ±

Не нужно ничего усложнять - открываете оба файла и ставите формулу используя диалог, почти исключительно мышью.
Название продукта пишите в поле где нужно указать источник для поиска (лучше копипастом) - это правда придётся набрать, иначе если будете указывать мышью в том втором файле, то при добавлении строк оно поплывёт...
Никакая ДВССЫЛ не нужна, да она и не работает с закрытыми файлами.


excel@nxt.ru
webmoney: E265281470651 R418926282008 Z422237915069


Сообщение отредактировал Hugo - Суббота, 01.02.2020, 22:55
 
Ответить
СообщениеНе нужно ничего усложнять - открываете оба файла и ставите формулу используя диалог, почти исключительно мышью.
Название продукта пишите в поле где нужно указать источник для поиска (лучше копипастом) - это правда придётся набрать, иначе если будете указывать мышью в том втором файле, то при добавлении строк оно поплывёт...
Никакая ДВССЫЛ не нужна, да она и не работает с закрытыми файлами.

Автор - Hugo
Дата добавления - 01.02.2020 в 22:51
BetWinner Дата: Воскресенье, 02.02.2020, 06:28 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Hugo, А можно еще образец тут написать :shy:
 
Ответить
СообщениеHugo, А можно еще образец тут написать :shy:

Автор - BetWinner
Дата добавления - 02.02.2020 в 06:28
Hugo Дата: Воскресенье, 02.02.2020, 14:23 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2890
Репутация: 644 ±
Замечаний: 0% ±

Ну например для руда сафьяновская в B6:
Код
=ВПР("РУДА САФЬЯНОВС";'C:\Downloads\[5721409.xls]Лист1'!$A$1:$B$65536;2;0)

Путь конечно желательно поменять на свой :)


excel@nxt.ru
webmoney: E265281470651 R418926282008 Z422237915069


Сообщение отредактировал Hugo - Воскресенье, 02.02.2020, 14:23
 
Ответить
СообщениеНу например для руда сафьяновская в B6:
Код
=ВПР("РУДА САФЬЯНОВС";'C:\Downloads\[5721409.xls]Лист1'!$A$1:$B$65536;2;0)

Путь конечно желательно поменять на свой :)

Автор - Hugo
Дата добавления - 02.02.2020 в 14:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных из одного документа в другой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!