Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/перевести данные в 1 строку с уникальным значением по столбц - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перевести данные в 1 строку с уникальным значением по столбц (Формулы/Formulas)
перевести данные в 1 строку с уникальным значением по столбц
Жюля Дата: Понедельник, 03.02.2020, 22:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Прошу помочь, есть ли возможность перевести данные из вертикального формата в горизонтальный, при этом сделав один первый столбец уникальным, а остальные значения расположить горизонтально, каждое в отдельной ячейке, последовательно
Значение в исходной таблице повторяется не более 7 раз, всего около 30000 строк, возможно нужно перевести в строку не по два значения с разными данными, а по три.
Пример в прикрепленном файле.

Простите, изменили формат файла на .xls
К сообщению приложен файл: 23.xlsx(12.4 Kb) · 23.xls(33.5 Kb)


Жюлянция

Сообщение отредактировал Жюля - Понедельник, 03.02.2020, 22:12
 
Ответить
СообщениеПрошу помочь, есть ли возможность перевести данные из вертикального формата в горизонтальный, при этом сделав один первый столбец уникальным, а остальные значения расположить горизонтально, каждое в отдельной ячейке, последовательно
Значение в исходной таблице повторяется не более 7 раз, всего около 30000 строк, возможно нужно перевести в строку не по два значения с разными данными, а по три.
Пример в прикрепленном файле.

Простите, изменили формат файла на .xls

Автор - Жюля
Дата добавления - 03.02.2020 в 22:04
Светлый Дата: Вторник, 04.02.2020, 06:26 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1474
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010, 2013
И Вам, здравствуйте!
Если будете в старом формате работать, то ЕСЛИОШИБКА не будет работать. Формулу придётся усложнять.
*Исправил формулу для старого формата. Формула массивная:
Код
=ЕСЛИ($G2="";"";ЕСЛИ(СЧЁТЕСЛИ($A$2:$A$21;$G2)>=ОТБР(СТОЛБЕЦ(B2)/2);ИНДЕКС($B$1:$C$21;НАИМЕНЬШИЙ(ЕСЛИ($A$2:$A$21=$G2;СТРОКА($2:$21));ОТБР(СТОЛБЕЦ(B2)/2));ОСТАТ(СТОЛБЕЦ(B2);2)+1);""))
Формула одинаковая для всех ячеек, но копировать надо только формулу без форматов.
К сообщению приложен файл: 23-1.xls(45.5 Kb) · 23-2.xls(48.0 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 04.02.2020, 07:13
 
Ответить
СообщениеИ Вам, здравствуйте!
Если будете в старом формате работать, то ЕСЛИОШИБКА не будет работать. Формулу придётся усложнять.
*Исправил формулу для старого формата. Формула массивная:
Код
=ЕСЛИ($G2="";"";ЕСЛИ(СЧЁТЕСЛИ($A$2:$A$21;$G2)>=ОТБР(СТОЛБЕЦ(B2)/2);ИНДЕКС($B$1:$C$21;НАИМЕНЬШИЙ(ЕСЛИ($A$2:$A$21=$G2;СТРОКА($2:$21));ОТБР(СТОЛБЕЦ(B2)/2));ОСТАТ(СТОЛБЕЦ(B2);2)+1);""))
Формула одинаковая для всех ячеек, но копировать надо только формулу без форматов.

Автор - Светлый
Дата добавления - 04.02.2020 в 06:26
Жюля Дата: Вторник, 04.02.2020, 17:17 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Когда меняю имя, данные в исходном таблице, количество строк в формуле, помещаю таблицу на отдельный лист, то в столбце имя в каждую строку прописывает слово "ИМЯ", а остальные столбцы пусты.
Для трех столбцов пытаясь изменить формулу, опять выдает пустые ячейки.
К сообщению приложен файл: 3576219.xls(49.0 Kb)


Жюлянция
 
Ответить
СообщениеКогда меняю имя, данные в исходном таблице, количество строк в формуле, помещаю таблицу на отдельный лист, то в столбце имя в каждую строку прописывает слово "ИМЯ", а остальные столбцы пусты.
Для трех столбцов пытаясь изменить формулу, опять выдает пустые ячейки.

Автор - Жюля
Дата добавления - 04.02.2020 в 17:17
jakim Дата: Вторник, 04.02.2020, 19:15 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 956
Репутация: 250 ±
Замечаний: 0% ±

Excel 2010
Если для Excel2010+, то предлагаю такую формулу

Код
=IFERROR(INDEX($B$2:$D$200;AGGREGATE(15;6;ROW($1:$200)/($A$2:$A$200=$G2);CEILING(COLUMNS($I:I)/3;1));MOD(COLUMNS($H:H)-1;3)+1);"")

Нулевые зачения спрятаны условным форматированием.
К сообщению приложен файл: transpose_4.xlsx(14.8 Kb)
 
Ответить
Сообщение
Если для Excel2010+, то предлагаю такую формулу

Код
=IFERROR(INDEX($B$2:$D$200;AGGREGATE(15;6;ROW($1:$200)/($A$2:$A$200=$G2);CEILING(COLUMNS($I:I)/3;1));MOD(COLUMNS($H:H)-1;3)+1);"")

Нулевые зачения спрятаны условным форматированием.

Автор - jakim
Дата добавления - 04.02.2020 в 19:15
Светлый Дата: Вторник, 04.02.2020, 22:48 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1474
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010, 2013
Так теперь с шагом 3, а не 2. Массивная:
Код
=ЕСЛИ($G2="";"";ЕСЛИ(СЧЁТЕСЛИ($A$2:$A$21;$G2)>=ОТБР(СТОЛБЕЦ(C2)/3);ИНДЕКС($B$1:$D$21;НАИМЕНЬШИЙ(ЕСЛИ($A$2:$A$21=$G2;СТРОКА($2:$21));ОТБР(СТОЛБЕЦ(C2)/3));ОСТАТ(СТОЛБЕЦ(C2);3)+1);""))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеТак теперь с шагом 3, а не 2. Массивная:
Код
=ЕСЛИ($G2="";"";ЕСЛИ(СЧЁТЕСЛИ($A$2:$A$21;$G2)>=ОТБР(СТОЛБЕЦ(C2)/3);ИНДЕКС($B$1:$D$21;НАИМЕНЬШИЙ(ЕСЛИ($A$2:$A$21=$G2;СТРОКА($2:$21));ОТБР(СТОЛБЕЦ(C2)/3));ОСТАТ(СТОЛБЕЦ(C2);3)+1);""))

Автор - Светлый
Дата добавления - 04.02.2020 в 22:48
Nic70y Дата: Среда, 05.02.2020, 08:37 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 6455
Репутация: 1421 ±
Замечаний: 0% ±

ru13;10;03
вариант с доп.столбцами и
Код
=ВПР()
К сообщению приложен файл: 6454723.xls(41.0 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщениевариант с доп.столбцами и
Код
=ВПР()

Автор - Nic70y
Дата добавления - 05.02.2020 в 08:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » перевести данные в 1 строку с уникальным значением по столбц (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!