Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автозамена в формулах данными из ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозамена в формулах данными из ячейки (Формулы/Formulas)
Автозамена в формулах данными из ячейки
mongol81 Дата: Вторник, 11.02.2020, 15:36 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день.
  • Возникла необходимость сбора данных за каждый месяц по определенным позициям. Есть статьи расхода (" зарплата бухгалтера", "зарплата менеджера", "реклама" и .п. Окончательная формула имеет вид
    Код
    =СУММЕСЛИ($B$3:$B$12;("Реклама");$C$3:$C$12)
    - в этом случае, все статьи расходов с названием "реклама" собираются вместе в одну сумму за 1 месяц.
  • Какого вида должна быть формула, чтобы при изменении названия статьи расхода ( например " реклама" на " сборы"), данная информация автоматически отразилась во всех формулах и в итоге стала
    Код
    =СУММЕСЛИ($B$3:$B$12;("сборы");$C$3:$C$12)
    .
  • Так как данные формулы повторяются каждый месяц- менять статью расхода, а потом руками во всех формулах менять данные - тяжело %) . Спасибо
  • К сообщению приложен файл: 9869401.xls(32.0 Kb)


    учиться, учиться и еще раз учиться...

    Сообщение отредактировал mongol81 - Вторник, 11.02.2020, 15:48
     
    Ответить
    СообщениеДобрый день.
  • Возникла необходимость сбора данных за каждый месяц по определенным позициям. Есть статьи расхода (" зарплата бухгалтера", "зарплата менеджера", "реклама" и .п. Окончательная формула имеет вид
    Код
    =СУММЕСЛИ($B$3:$B$12;("Реклама");$C$3:$C$12)
    - в этом случае, все статьи расходов с названием "реклама" собираются вместе в одну сумму за 1 месяц.
  • Какого вида должна быть формула, чтобы при изменении названия статьи расхода ( например " реклама" на " сборы"), данная информация автоматически отразилась во всех формулах и в итоге стала
    Код
    =СУММЕСЛИ($B$3:$B$12;("сборы");$C$3:$C$12)
    .
  • Так как данные формулы повторяются каждый месяц- менять статью расхода, а потом руками во всех формулах менять данные - тяжело %) . Спасибо

  • Автор - mongol81
    Дата добавления - 11.02.2020 в 15:36
    китин Дата: Вторник, 11.02.2020, 15:43 | Сообщение № 2
    Группа: Модераторы
    Ранг: Экселист
    Сообщений: 6122
    Репутация: 947 ±
    Замечаний: 0% ±

    Excel 2007;Excel 2010
    mongol81, - Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


    Не судите строго:я пытаюсь научиться
    ЯД 41001877306852/WM R249698041931; Z239672726538
     
    Ответить
    Сообщениеmongol81, - Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

    Автор - китин
    Дата добавления - 11.02.2020 в 15:43
    mongol81 Дата: Вторник, 11.02.2020, 15:48 | Сообщение № 3
    Группа: Пользователи
    Ранг: Прохожий
    Сообщений: 4
    Репутация: 0 ±
    Замечаний: 0% ±

    Excel 2019
    китин, сделано


    учиться, учиться и еще раз учиться...
     
    Ответить
    Сообщениекитин, сделано

    Автор - mongol81
    Дата добавления - 11.02.2020 в 15:48
    китин Дата: Вторник, 11.02.2020, 15:59 | Сообщение № 4
    Группа: Модераторы
    Ранг: Экселист
    Сообщений: 6122
    Репутация: 947 ±
    Замечаний: 0% ±

    Excel 2007;Excel 2010
    дык сделайте просто ссылку на ячейку
    Код
    =СУММЕСЛИ($B$3:$B$12;$A15;$C$3:$C$12)


    Не судите строго:я пытаюсь научиться
    ЯД 41001877306852/WM R249698041931; Z239672726538
     
    Ответить
    Сообщениедык сделайте просто ссылку на ячейку
    Код
    =СУММЕСЛИ($B$3:$B$12;$A15;$C$3:$C$12)

    Автор - китин
    Дата добавления - 11.02.2020 в 15:59
    Pelena Дата: Вторник, 11.02.2020, 16:09 | Сообщение № 5
    Группа: Админы
    Ранг: Местный житель
    Сообщений: 15238
    Репутация: 3340 ±
    Замечаний: ±

    Excel 2010, 2016 & Mac Excel
    mongol81, такие данные лучше структурировать немного по-другому (см. Лист2). Тогда можно без формул сводной таблицей получить результат. А при добавлении новых данных просто обновить сводную (правой кнопкой мыши по сводной -- обновить)
    К сообщению приложен файл: 9869401-1-.xls(44.5 Kb)


    "Черт возьми, Холмс! Но как??!!"
    ЯД 41001765434816
     
    Ответить
    Сообщениеmongol81, такие данные лучше структурировать немного по-другому (см. Лист2). Тогда можно без формул сводной таблицей получить результат. А при добавлении новых данных просто обновить сводную (правой кнопкой мыши по сводной -- обновить)

    Автор - Pelena
    Дата добавления - 11.02.2020 в 16:09
    Zarabet Дата: Вторник, 11.02.2020, 16:11 | Сообщение № 6
    Группа: Пользователи
    Ранг: Прохожий
    Сообщений: 2
    Репутация: 0 ±
    Замечаний: 0% ±

    Excel 2016
    а ячейку А15 сделать равной =А3, тогда если в диапазоне А3:А12 будут добавляться новые статьи расходов, они автоматом упадут в нижнюю таблицу
     
    Ответить
    Сообщениеа ячейку А15 сделать равной =А3, тогда если в диапазоне А3:А12 будут добавляться новые статьи расходов, они автоматом упадут в нижнюю таблицу

    Автор - Zarabet
    Дата добавления - 11.02.2020 в 16:11
    mongol81 Дата: Среда, 12.02.2020, 13:25 | Сообщение № 7
    Группа: Пользователи
    Ранг: Прохожий
    Сообщений: 4
    Репутация: 0 ±
    Замечаний: 0% ±

    Excel 2019
    Pelena, добрый день. Очень интересное решение. Сейчас будем пробовать и внедрять.


    учиться, учиться и еще раз учиться...
     
    Ответить
    СообщениеPelena, добрый день. Очень интересное решение. Сейчас будем пробовать и внедрять.

    Автор - mongol81
    Дата добавления - 12.02.2020 в 13:25
    mongol81 Дата: Пятница, 14.02.2020, 10:50 | Сообщение № 8
    Группа: Пользователи
    Ранг: Прохожий
    Сообщений: 4
    Репутация: 0 ±
    Замечаний: 0% ±

    Excel 2019
    Pelena, всё получилось. Огромное спасибо всем. yes :flower:


    учиться, учиться и еще раз учиться...
     
    Ответить
    СообщениеPelena, всё получилось. Огромное спасибо всем. yes :flower:

    Автор - mongol81
    Дата добавления - 14.02.2020 в 10:50
    Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозамена в формулах данными из ячейки (Формулы/Formulas)
    • Страница 1 из 1
    • 1
    Поиск:

    Яндекс цитирования
    © 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!