Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Рандомная рокировка ячеек - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Рандомная рокировка ячеек (Формулы/Formulas)
Рандомная рокировка ячеек
pain2430 Дата: Вторник, 18.02.2020, 01:22 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте! Прошу помощи вот в таком вот задании:
Каждое имя привязано к ID в соседней ячейке, как в примере "Андрей = ID1"
На против "Андрей ID1" - "Вероника ID2", которая привязана к Андрею.
Нужно столбцы B,C и E,F рокировать местами рандомно, как это сделать?
Можно любым способом, ВБА, формулы... Спасибо!
К сообщению приложен файл: Forum.xlsx(9.5 Kb)
 
Ответить
СообщениеЗдравствуйте! Прошу помощи вот в таком вот задании:
Каждое имя привязано к ID в соседней ячейке, как в примере "Андрей = ID1"
На против "Андрей ID1" - "Вероника ID2", которая привязана к Андрею.
Нужно столбцы B,C и E,F рокировать местами рандомно, как это сделать?
Можно любым способом, ВБА, формулы... Спасибо!

Автор - pain2430
Дата добавления - 18.02.2020 в 01:22
YouGreed Дата: Вторник, 18.02.2020, 09:13 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 589
Репутация: 123 ±
Замечаний: 0% ±

Excel 2010
pain2430, Попробуем так

Код
=ИНДЕКС(B$1:B$22;СЛУЧМЕЖДУ(1;22);СТОЛБЕЦ($A$1);1)

в связке с
Код
=ВПР($J1;$B$1:$F$11;СТОЛБЕЦ(B1);0)
К сообщению приложен файл: 1581268.xlsx(11.2 Kb)


Сообщение отредактировал YouGreed - Вторник, 18.02.2020, 09:17
 
Ответить
Сообщениеpain2430, Попробуем так

Код
=ИНДЕКС(B$1:B$22;СЛУЧМЕЖДУ(1;22);СТОЛБЕЦ($A$1);1)

в связке с
Код
=ВПР($J1;$B$1:$F$11;СТОЛБЕЦ(B1);0)

Автор - YouGreed
Дата добавления - 18.02.2020 в 09:13
pain2430 Дата: Вторник, 18.02.2020, 20:07 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
YouGreed, здравствуйте! Спасибо за то что отозвались, но это не совсем то что нужно.
Вот сделал пример проще, с двумя столбцами. Вот в первой строке, ячейка B должна стать ячейкой C, а ячейка C стать ячейкой B.
И так со всеми остальными, и в рандомном порядке. Уже весь интернет перерыл, не могу найти решение(
К сообщению приложен файл: 0644282.xlsx(9.3 Kb)
 
Ответить
СообщениеYouGreed, здравствуйте! Спасибо за то что отозвались, но это не совсем то что нужно.
Вот сделал пример проще, с двумя столбцами. Вот в первой строке, ячейка B должна стать ячейкой C, а ячейка C стать ячейкой B.
И так со всеми остальными, и в рандомном порядке. Уже весь интернет перерыл, не могу найти решение(

Автор - pain2430
Дата добавления - 18.02.2020 в 20:07
jakim Дата: Вторник, 18.02.2020, 21:11 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1116
Репутация: 295 ±
Замечаний: 0% ±

Excel 2010
Формула для столбца G

Код
=INDEX(B$1:C$11;;RANDBETWEEN(1;2))

для столбца H

Код
=IF(J1=B1;C1;B1)
К сообщению приложен файл: 7629832.xlsx(10.4 Kb)
 
Ответить
Сообщение
Формула для столбца G

Код
=INDEX(B$1:C$11;;RANDBETWEEN(1;2))

для столбца H

Код
=IF(J1=B1;C1;B1)

Автор - jakim
Дата добавления - 18.02.2020 в 21:11
pain2430 Дата: Среда, 19.02.2020, 18:05 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 63
Репутация: 11 ±
Замечаний: 0% ±

Excel 2010
jakim, спасибо огромное, то что нужно!
 
Ответить
Сообщениеjakim, спасибо огромное, то что нужно!

Автор - pain2430
Дата добавления - 19.02.2020 в 18:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Рандомная рокировка ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!