Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Агрегирование данных по заданным условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Агрегирование данных по заданным условиям (Формулы/Formulas)
Агрегирование данных по заданным условиям
cants Дата: Вторник, 18.02.2020, 15:37 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день, уважаемые участники форума.

Требуется формула, которая будет, ориентируясь на данные листа2, где содержится детализированная информация, формировать сводные данные на листе1 по сумме просроченной задолженности и max кол-ву дней просрочки с привязкой к названию поставщика и покупателя:

1. На листе1 в колонке C по связке поставщик-покупатель должна отображаться общая сумма просроченной задолженности, ориентируясь на кол-во дней просрочки в колонке D на листе2 и сумму поставки. В том случае, если кол-во дней просрочки равна 0, то формула не должна учитывать сумму поставки в колонке С на листе1 как просроченную
2. На листе1 в колонке D по связке поставщик-покупатель должно отображаться max значение кол-ва дней просрочки, исходя из данных, которые содержаться на листе 2 в колонке D.

Пример во вложении
К сообщению приложен файл: _18.02.xlsx(10.7 Kb)
 
Ответить
СообщениеДобрый день, уважаемые участники форума.

Требуется формула, которая будет, ориентируясь на данные листа2, где содержится детализированная информация, формировать сводные данные на листе1 по сумме просроченной задолженности и max кол-ву дней просрочки с привязкой к названию поставщика и покупателя:

1. На листе1 в колонке C по связке поставщик-покупатель должна отображаться общая сумма просроченной задолженности, ориентируясь на кол-во дней просрочки в колонке D на листе2 и сумму поставки. В том случае, если кол-во дней просрочки равна 0, то формула не должна учитывать сумму поставки в колонке С на листе1 как просроченную
2. На листе1 в колонке D по связке поставщик-покупатель должно отображаться max значение кол-ва дней просрочки, исходя из данных, которые содержаться на листе 2 в колонке D.

Пример во вложении

Автор - cants
Дата добавления - 18.02.2020 в 15:37
YouGreed Дата: Вторник, 18.02.2020, 15:47 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 589
Репутация: 123 ±
Замечаний: 0% ±

Excel 2010
cants, все просто, сводной

Код
=СУММЕСЛИМН(лист2!C:C;лист2!A:A;лист1!A8;лист2!B:B;лист1!B:B;лист2!D:D;">0")


Суммируем формулой
К сообщению приложен файл: 0369411.xlsx(15.5 Kb)


Сообщение отредактировал YouGreed - Вторник, 18.02.2020, 15:48
 
Ответить
Сообщениеcants, все просто, сводной

Код
=СУММЕСЛИМН(лист2!C:C;лист2!A:A;лист1!A8;лист2!B:B;лист1!B:B;лист2!D:D;">0")


Суммируем формулой

Автор - YouGreed
Дата добавления - 18.02.2020 в 15:47
cants Дата: Вторник, 18.02.2020, 16:11 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 58
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо Вам за решение! В части использования формулы СУММЕСЛИМН для п.1 - все работает
Но вопрос по п.2 остается открытым. Вариант формирования сводной таблицы, к сожалению, не подходит. Нужна именно формула, которая будет определять максимальное значение просрочки из диапазона
 
Ответить
СообщениеСпасибо Вам за решение! В части использования формулы СУММЕСЛИМН для п.1 - все работает
Но вопрос по п.2 остается открытым. Вариант формирования сводной таблицы, к сожалению, не подходит. Нужна именно формула, которая будет определять максимальное значение просрочки из диапазона

Автор - cants
Дата добавления - 18.02.2020 в 16:11
YouGreed Дата: Вторник, 18.02.2020, 17:39 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 589
Репутация: 123 ±
Замечаний: 0% ±

Excel 2010
cants, Ну тогда Так)))

Код
=ЕСЛИОШИБКА(ИНДЕКС(лист2!A$2:A$32;НАИБОЛЬШИЙ(ЕСЛИ(ПОИСКПОЗ(лист2!$B$2:$B$32&лист2!$A$2:$A$32;лист2!$B$2:$B$32&лист2!$A$2:$A$32;0)=СТРОКА(лист2!$A$1:$A$31);СТРОКА(лист2!$A$1:$A$31));СТРОКА($A1)));"")

Формула массива вводится одновременным нажатием Ctrl+Shift+Enter
Код
=СУММЕСЛИМН(лист2!C:C;лист2!A:A;лист1!A7;лист2!B:B;лист1!B7;лист2!D:D;">0")
Суммируем просрок
Код
=НАИБОЛЬШИЙ((лист2!$A$2:$A$32=лист1!A7)*(лист2!$B$2:$B$32=лист1!B7)*(лист2!$D$2:$D$32>0)*лист2!$D$2:$D$32;1)
Выводим дни просрока.
Формула также Массивна!
К сообщению приложен файл: 0778495.xlsx(12.5 Kb)
 
Ответить
Сообщениеcants, Ну тогда Так)))

Код
=ЕСЛИОШИБКА(ИНДЕКС(лист2!A$2:A$32;НАИБОЛЬШИЙ(ЕСЛИ(ПОИСКПОЗ(лист2!$B$2:$B$32&лист2!$A$2:$A$32;лист2!$B$2:$B$32&лист2!$A$2:$A$32;0)=СТРОКА(лист2!$A$1:$A$31);СТРОКА(лист2!$A$1:$A$31));СТРОКА($A1)));"")

Формула массива вводится одновременным нажатием Ctrl+Shift+Enter
Код
=СУММЕСЛИМН(лист2!C:C;лист2!A:A;лист1!A7;лист2!B:B;лист1!B7;лист2!D:D;">0")
Суммируем просрок
Код
=НАИБОЛЬШИЙ((лист2!$A$2:$A$32=лист1!A7)*(лист2!$B$2:$B$32=лист1!B7)*(лист2!$D$2:$D$32>0)*лист2!$D$2:$D$32;1)
Выводим дни просрока.
Формула также Массивна!

Автор - YouGreed
Дата добавления - 18.02.2020 в 17:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Агрегирование данных по заданным условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!