Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формирование таблицы по заданному условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование таблицы по заданному условию (Формулы/Formulas)
Формирование таблицы по заданному условию
Kasper89 Дата: Четверг, 20.02.2020, 15:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день,
Пожалуйста помогите,
Необходимо сформировать пять таблиц (по комплектам оборудования) из общей таблицы))
Что бы не было пустых ячеек, должно получится как на картинке.
За ранее спасибо!!
К сообщению приложен файл: 6733615.png(239.9 Kb) · 4880669.xlsx(11.9 Kb)


Сообщение отредактировал Kasper89 - Четверг, 20.02.2020, 16:07
 
Ответить
СообщениеДобрый день,
Пожалуйста помогите,
Необходимо сформировать пять таблиц (по комплектам оборудования) из общей таблицы))
Что бы не было пустых ячеек, должно получится как на картинке.
За ранее спасибо!!

Автор - Kasper89
Дата добавления - 20.02.2020 в 15:07
YouGreed Дата: Четверг, 20.02.2020, 15:55 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 589
Репутация: 123 ±
Замечаний: 0% ±

Excel 2010
Kasper89,
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$3:$P$40;ПОИСКПОЗ($A43;$A$3:$A$40;0);НАИМЕНЬШИЙ(ЕСЛИ((($B3:$P3>0)*СТОЛБЕЦ($A:$O))<>0;($B3:$P3>0)*СТОЛБЕЦ($A:$O);"");СТОЛБЕЦ(A$1)));"")

Формула массива вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: _-_.xlsx(17.5 Kb)


Сообщение отредактировал YouGreed - Четверг, 20.02.2020, 15:58
 
Ответить
СообщениеKasper89,
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$3:$P$40;ПОИСКПОЗ($A43;$A$3:$A$40;0);НАИМЕНЬШИЙ(ЕСЛИ((($B3:$P3>0)*СТОЛБЕЦ($A:$O))<>0;($B3:$P3>0)*СТОЛБЕЦ($A:$O);"");СТОЛБЕЦ(A$1)));"")

Формула массива вводится одновременным нажатием Ctrl+Shift+Enter

Автор - YouGreed
Дата добавления - 20.02.2020 в 15:55
Kasper89 Дата: Четверг, 20.02.2020, 15:59 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
YouGreed, Спасибо! пять таблиц нужно:
Комплект №1 - адреса с датами
Комплект №2 - адреса с датами
и тд.

и что бы не было пустых строк напротив адреса.
формировал таблицу потребности оборудования по адресам


Сообщение отредактировал Kasper89 - Четверг, 20.02.2020, 16:04
 
Ответить
СообщениеYouGreed, Спасибо! пять таблиц нужно:
Комплект №1 - адреса с датами
Комплект №2 - адреса с датами
и тд.

и что бы не было пустых строк напротив адреса.
формировал таблицу потребности оборудования по адресам

Автор - Kasper89
Дата добавления - 20.02.2020 в 15:59
YouGreed Дата: Четверг, 20.02.2020, 17:00 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 589
Репутация: 123 ±
Замечаний: 0% ±

Excel 2010
Kasper89, такс
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$3:$P$40;НАИМЕНЬШИЙ(ЕСЛИ((($B$3:$B$40>0)*СТРОКА($1:$38))<>0;($B$3:$B$40>0)*СТРОКА($1:$38);"");СТРОКА($A1));2);"")

Все также массивная

[p.s.]Прошу обратить внимание, что формула не универсальная, т.е. я применял ее для построения всех данных, но постоянно менял
Код
Столбец()
и диапазон данных для формулы
Код
Наименьший()
К сообщению приложен файл: 7059075.xlsx(16.5 Kb)


Сообщение отредактировал YouGreed - Четверг, 20.02.2020, 17:31
 
Ответить
СообщениеKasper89, такс
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$3:$P$40;НАИМЕНЬШИЙ(ЕСЛИ((($B$3:$B$40>0)*СТРОКА($1:$38))<>0;($B$3:$B$40>0)*СТРОКА($1:$38);"");СТРОКА($A1));2);"")

Все также массивная

[p.s.]Прошу обратить внимание, что формула не универсальная, т.е. я применял ее для построения всех данных, но постоянно менял
Код
Столбец()
и диапазон данных для формулы
Код
Наименьший()

Автор - YouGreed
Дата добавления - 20.02.2020 в 17:00
Kasper89 Дата: Четверг, 20.02.2020, 17:08 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
YouGreed, огонь! спасибо!
 
Ответить
СообщениеYouGreed, огонь! спасибо!

Автор - Kasper89
Дата добавления - 20.02.2020 в 17:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование таблицы по заданному условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!