Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формирование заказа товара на основе матрицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование заказа товара на основе матрицы (Формулы/Formulas)
Формирование заказа товара на основе матрицы
Alex_spb Дата: Среда, 04.03.2020, 17:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Доброго дня, прошу помочь в следующей ситуации:
- есть матрица заказа товаров, в ней проставлены цены и есть пустые графы с количеством, когда заполняют количество - автоматически считается сумма.
НУжно что бы на втором листе формировался заказ только из тех позиций, по которым в матрице проставлено количество. Но заказ должен формироваться в разрезе контрагентов у которых делается заказ, так же нужна итоговая сумма по заказу.
Этот 2-й лист должен быть доступен только по паролю для снабженцев, что бы заказывающие в него не влезали.

Такое возможно сделать? В поиске не нашел решения ...
К сообщению приложен файл: ____04.03.xlsx(19.0 Kb)
 
Ответить
СообщениеДоброго дня, прошу помочь в следующей ситуации:
- есть матрица заказа товаров, в ней проставлены цены и есть пустые графы с количеством, когда заполняют количество - автоматически считается сумма.
НУжно что бы на втором листе формировался заказ только из тех позиций, по которым в матрице проставлено количество. Но заказ должен формироваться в разрезе контрагентов у которых делается заказ, так же нужна итоговая сумма по заказу.
Этот 2-й лист должен быть доступен только по паролю для снабженцев, что бы заказывающие в него не влезали.

Такое возможно сделать? В поиске не нашел решения ...

Автор - Alex_spb
Дата добавления - 04.03.2020 в 17:12
AlexM Дата: Среда, 04.03.2020, 17:38 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4011
Репутация: 1006 ±
Замечаний: 0% ±

Excel 2003
Так нужно?
Без пароля.
К сообщению приложен файл: _04.03_01.xlsx(16.7 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 04.03.2020, 17:39
 
Ответить
СообщениеТак нужно?
Без пароля.

Автор - AlexM
Дата добавления - 04.03.2020 в 17:38
YouGreed Дата: Среда, 04.03.2020, 17:53 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 553
Репутация: 116 ±
Замечаний: 0% ±

Excel 2010
Alex_spb,
Код
=ЕСЛИОШИБКА(ИНДЕКС(поставщики!B$5:B$41;НАИМЕНЬШИЙ(ЕСЛИ(((поставщики!$F$5:$F$42>0)*СТРОКА($1:$38))<>0;(поставщики!$F$5:$F$42>0)*СТРОКА($1:$38);"");СТРОКА($A1));1);"")
как то так) формула массива, вводится одновременным нажатием ctrl+shift+enter
 
Ответить
СообщениеAlex_spb,
Код
=ЕСЛИОШИБКА(ИНДЕКС(поставщики!B$5:B$41;НАИМЕНЬШИЙ(ЕСЛИ(((поставщики!$F$5:$F$42>0)*СТРОКА($1:$38))<>0;(поставщики!$F$5:$F$42>0)*СТРОКА($1:$38);"");СТРОКА($A1));1);"")
как то так) формула массива, вводится одновременным нажатием ctrl+shift+enter

Автор - YouGreed
Дата добавления - 04.03.2020 в 17:53
Alex_spb Дата: Четверг, 05.03.2020, 12:09 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Огромное спасибо, а возможно что бы заказ на втором листе формировался самостоятельно, т/е что бы строки появлялись и добавлялись по мере заполнения матрицы, а если какой то товар отминусуют что бы пропадали. Иначе получается что накладная (заказ) должна быть равна матрице в идеале
 
Ответить
СообщениеОгромное спасибо, а возможно что бы заказ на втором листе формировался самостоятельно, т/е что бы строки появлялись и добавлялись по мере заполнения матрицы, а если какой то товар отминусуют что бы пропадали. Иначе получается что накладная (заказ) должна быть равна матрице в идеале

Автор - Alex_spb
Дата добавления - 05.03.2020 в 12:09
AlexM Дата: Четверг, 05.03.2020, 12:39 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4011
Репутация: 1006 ±
Замечаний: 0% ±

Excel 2003
Alex_spb, А сейчас разве не так?



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеAlex_spb, А сейчас разве не так?

Автор - AlexM
Дата добавления - 05.03.2020 в 12:39
Alex_spb Дата: Пятница, 06.03.2020, 17:40 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Нет AlexM, сейчас заполняет только в рамках накладной которая на второй странице - под поля выделено 10 строк , вот в них и добавляет , если количество выбранных в матрице заказов позиций больше , строки не добавляются , просто эти данные не отображаются , можно расширить в ручную, но тогда накладная должна быть размером с матрицу (в случае выбора всех позиций)
 
Ответить
СообщениеНет AlexM, сейчас заполняет только в рамках накладной которая на второй странице - под поля выделено 10 строк , вот в них и добавляет , если количество выбранных в матрице заказов позиций больше , строки не добавляются , просто эти данные не отображаются , можно расширить в ручную, но тогда накладная должна быть размером с матрицу (в случае выбора всех позиций)

Автор - Alex_spb
Дата добавления - 06.03.2020 в 17:40
Pelena Дата: Пятница, 06.03.2020, 19:15 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 15451
Репутация: 3381 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
строки не добавляются
формулы не умеют добавлять строки. Делайте с запасом, потом лишние скрывайте.
Или, как альтернатива, писать макрос


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
строки не добавляются
формулы не умеют добавлять строки. Делайте с запасом, потом лишние скрывайте.
Или, как альтернатива, писать макрос

Автор - Pelena
Дата добавления - 06.03.2020 в 19:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование заказа товара на основе матрицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!