Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование в группированной таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование в группированной таблицы (Формулы/Formulas)
Суммирование в группированной таблицы
1ager Дата: Воскресенье, 26.04.2020, 10:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Доброго времени суток!
Как произвести суммирование для столбца "сумма" (Также отдельно по столбцу "кол.") для структурированной таблицы, чтобы в итоге подсчитывался каждая подгруппа и в целом группа? В таблице много тыс строк.
Нашел здесь на сайте похожую тему , вставил формулу, но все равно общая сумма не подсчитывается, не пойму почему.
К сообщению приложен файл: 2125277.xlsx(13.4 Kb)
 
Ответить
СообщениеДоброго времени суток!
Как произвести суммирование для столбца "сумма" (Также отдельно по столбцу "кол.") для структурированной таблицы, чтобы в итоге подсчитывался каждая подгруппа и в целом группа? В таблице много тыс строк.
Нашел здесь на сайте похожую тему , вставил формулу, но все равно общая сумма не подсчитывается, не пойму почему.

Автор - 1ager
Дата добавления - 26.04.2020 в 10:49
_Boroda_ Дата: Воскресенье, 26.04.2020, 12:52 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Наверное потому, что в примере Вашем не видно, что написано в столбце А, а в формуле на него ссылка
Это у Вас выгрузка из 1С, правильно? Тогда, для того, чтобф написать формулу, нам нужно полностью заполнение всех строк. Причем именно так, как они у Вас в реальном файле - с отступами, пробелами вначале и прочим

Можно и так написать, но это будет или макросом, или довольно сложная формула


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНаверное потому, что в примере Вашем не видно, что написано в столбце А, а в формуле на него ссылка
Это у Вас выгрузка из 1С, правильно? Тогда, для того, чтобф написать формулу, нам нужно полностью заполнение всех строк. Причем именно так, как они у Вас в реальном файле - с отступами, пробелами вначале и прочим

Можно и так написать, но это будет или макросом, или довольно сложная формула

Автор - _Boroda_
Дата добавления - 26.04.2020 в 12:52
1ager Дата: Воскресенье, 26.04.2020, 14:03 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добавил столбцы, как должно быть заполнено.
Но я не пойму, какое это отношение имеет. Разве excel никак не может понять, где начинается и кончается группа, для подсчета?
К сообщению приложен файл: 4314380.xlsx(13.9 Kb)
 
Ответить
СообщениеДобавил столбцы, как должно быть заполнено.
Но я не пойму, какое это отношение имеет. Разве excel никак не может понять, где начинается и кончается группа, для подсчета?

Автор - 1ager
Дата добавления - 26.04.2020 в 14:03
_Boroda_ Дата: Воскресенье, 26.04.2020, 14:10 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
В таком виде, как вы добавили - никакого. Я ж писал
именно так, как они у Вас в реальном файле - с отступами, пробелами вначале и прочим

У вас что, наименования там и написаны - одинаково в ячейках Д6 и Д7?

Для понимания - формуле нужно за что-то зацепиться, нужен алгоритм определения тех строк, которые нужно суммировать


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВ таком виде, как вы добавили - никакого. Я ж писал
именно так, как они у Вас в реальном файле - с отступами, пробелами вначале и прочим

У вас что, наименования там и написаны - одинаково в ячейках Д6 и Д7?

Для понимания - формуле нужно за что-то зацепиться, нужен алгоритм определения тех строк, которые нужно суммировать

Автор - _Boroda_
Дата добавления - 26.04.2020 в 14:10
_Boroda_ Дата: Воскресенье, 26.04.2020, 15:15 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Впрочем, как я уже писал ранее, можно и так посчитать
Код
=ЕСЛИ(O5;O5*F5;СУММ(P6:ИНДЕКС(P6:P$36;ПОИСКПОЗ(ПОВТОР("_";ПОИСКПОЗ("?*";O6:O$36&"";))&"*";O6:O$36&"_"&O7:O$37&"_"&O8:O$38&"_";)-1))/ПОИСКПОЗ("?*";O6:O$36&"";))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 4314380_1.xlsx(14.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВпрочем, как я уже писал ранее, можно и так посчитать
Код
=ЕСЛИ(O5;O5*F5;СУММ(P6:ИНДЕКС(P6:P$36;ПОИСКПОЗ(ПОВТОР("_";ПОИСКПОЗ("?*";O6:O$36&"";))&"*";O6:O$36&"_"&O7:O$37&"_"&O8:O$38&"_";)-1))/ПОИСКПОЗ("?*";O6:O$36&"";))

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - _Boroda_
Дата добавления - 26.04.2020 в 15:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование в группированной таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!