Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Если в ячейке перед числом знак < то итог 0 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если в ячейке перед числом знак < то итог 0 (Формулы/Formulas)
Если в ячейке перед числом знак < то итог 0
DrMini Дата: Среда, 29.04.2020, 11:59 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 559
Репутация: 16 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
Доброго времени суток форумчане и гости форума.
Если в ячейке перед числом стоит знак < то в итоге должен для счёта использоваться 0(ноль).
Если > то знак не учитывается и берётся для счёта только число после знака.
Если никакого знака нет то счёт ведётся, как обычно.
Прикрепил пример.
В ячейках C2;C3;C4 вписал что должно получиться.
К сообщению приложен файл: 20042901.xlsx(9.6 Kb)


Сообщение отредактировал DrMini - Среда, 29.04.2020, 11:59
 
Ответить
СообщениеДоброго времени суток форумчане и гости форума.
Если в ячейке перед числом стоит знак < то в итоге должен для счёта использоваться 0(ноль).
Если > то знак не учитывается и берётся для счёта только число после знака.
Если никакого знака нет то счёт ведётся, как обычно.
Прикрепил пример.
В ячейках C2;C3;C4 вписал что должно получиться.

Автор - DrMini
Дата добавления - 29.04.2020 в 11:59
_Boroda_ Дата: Среда, 29.04.2020, 12:14 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15978
Репутация: 6209 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Можно через ЕСЛИ, но это не интересно. Да и для кучи столбцов (а вдруг их не два) заманаешься писать
Вот такой вариант для любого кол-ва столбцов
Код
=СУММПРОИЗВ(--ТЕКСТ(ПСТР(A2:B2;1+(ЛЕВБ(A2:B2)=">")+9*(ЛЕВБ(A2:B2)="<");9);"Основной;;;\0"))

А с Если примерно так можно
Код
=ЕСЛИ(ЛЕВБ(A2)="<";;ЕСЛИ(ЛЕВБ(A2)=">";ПСТР(A2;2;9);A2))+ЕСЛИ(ЛЕВБ(B2)="<";;ЕСЛИ(ЛЕВБ(B2)=">";ПСТР(B2;2;9);B2))

Хотя здесь вариантов масса
Еще вариант формулой массива
Код
=СУММ(--ЕСЛИ(ЛЕВБ(A2:B2)="<";;ЕСЛИ(ЛЕВБ(A2:B2)=">";ПСТР(A2:B2;2;9);A2:B2)))

И еще
Код
=СУММ(A2:B2;--ЕСЛИ(ЛЕВБ(A2:B2)=">";ПСТР(A2:B2;2;9)))

Код
=СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(A2:B2;">";);))

И еще немассивный
Код
=СУММПРОИЗВ(--ТЕКСТ(ПОДСТАВИТЬ(A2:B2;">";);"Основной;;;\0"))
К сообщению приложен файл: 20042901_3.xlsx(10.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеМожно через ЕСЛИ, но это не интересно. Да и для кучи столбцов (а вдруг их не два) заманаешься писать
Вот такой вариант для любого кол-ва столбцов
Код
=СУММПРОИЗВ(--ТЕКСТ(ПСТР(A2:B2;1+(ЛЕВБ(A2:B2)=">")+9*(ЛЕВБ(A2:B2)="<");9);"Основной;;;\0"))

А с Если примерно так можно
Код
=ЕСЛИ(ЛЕВБ(A2)="<";;ЕСЛИ(ЛЕВБ(A2)=">";ПСТР(A2;2;9);A2))+ЕСЛИ(ЛЕВБ(B2)="<";;ЕСЛИ(ЛЕВБ(B2)=">";ПСТР(B2;2;9);B2))

Хотя здесь вариантов масса
Еще вариант формулой массива
Код
=СУММ(--ЕСЛИ(ЛЕВБ(A2:B2)="<";;ЕСЛИ(ЛЕВБ(A2:B2)=">";ПСТР(A2:B2;2;9);A2:B2)))

И еще
Код
=СУММ(A2:B2;--ЕСЛИ(ЛЕВБ(A2:B2)=">";ПСТР(A2:B2;2;9)))

Код
=СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(A2:B2;">";);))

И еще немассивный
Код
=СУММПРОИЗВ(--ТЕКСТ(ПОДСТАВИТЬ(A2:B2;">";);"Основной;;;\0"))

Автор - _Boroda_
Дата добавления - 29.04.2020 в 12:14
DrMini Дата: Среда, 29.04.2020, 12:24 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 559
Репутация: 16 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
Александр
БОЛЬШУЩЕЕ СПАСИБО!
[offtop]Не успел до дома на обед дойти, а тут уже есть решение.
Проверю, как только приду на работу.
Спасибо.[/offtop]
 
Ответить
СообщениеАлександр
БОЛЬШУЩЕЕ СПАСИБО!
[offtop]Не успел до дома на обед дойти, а тут уже есть решение.
Проверю, как только приду на работу.
Спасибо.[/offtop]

Автор - DrMini
Дата добавления - 29.04.2020 в 12:24
DrMini Дата: Среда, 29.04.2020, 13:48 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 559
Репутация: 16 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
здесь вариантов масса

Спасибо. Всё работает.
Оставил себе массивный вариант:
Код
=СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(A2:B2;">";);))

Он подошёл и для нахождения среднего значения:
Код
=СРЗНАЧ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(A2:B2;">";);))
 
Ответить
Сообщение
здесь вариантов масса

Спасибо. Всё работает.
Оставил себе массивный вариант:
Код
=СУММ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(A2:B2;">";);))

Он подошёл и для нахождения среднего значения:
Код
=СРЗНАЧ(ЕСЛИОШИБКА(--ПОДСТАВИТЬ(A2:B2;">";);))

Автор - DrMini
Дата добавления - 29.04.2020 в 13:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Если в ячейке перед числом знак < то итог 0 (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!