Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод данных каждый понедельник список автоматом - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод данных каждый понедельник список автоматом (Формулы/Formulas)
Вывод данных каждый понедельник список автоматом
Stefani Дата: Вторник, 12.05.2020, 16:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
есть списки. текущая дата, каждый понедельник нужно вывести список в зависимости от какой понедельник 1-6, чтоб список менялся сам от даты. Пример приложила. Как реализовать вывод списков к дате %)
К сообщению приложен файл: 2998072.xlsx(9.8 Kb)


Сообщение отредактировал Stefani - Вторник, 12.05.2020, 16:45
 
Ответить
Сообщениеесть списки. текущая дата, каждый понедельник нужно вывести список в зависимости от какой понедельник 1-6, чтоб список менялся сам от даты. Пример приложила. Как реализовать вывод списков к дате %)

Автор - Stefani
Дата добавления - 12.05.2020 в 16:44
AlexM Дата: Вторник, 12.05.2020, 17:07 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4161
Репутация: 1023 ±
Замечаний: 0% ±

Excel 2003
Так нужно?
Код
=ГПР(A$11;B$2:G$6;СТРОКА(A2))
К сообщению приложен файл: 2998072_01.xlsx(8.9 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеТак нужно?
Код
=ГПР(A$11;B$2:G$6;СТРОКА(A2))

Автор - AlexM
Дата добавления - 12.05.2020 в 17:07
Stefani Дата: Вторник, 12.05.2020, 18:09 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Так нужно?

почти, но цикл не повторяется. то есть прошли 6 понедельников и должно опять начаться с пн 1 и так по кругу просто подставила за место сегодня даты 30.07.2020 и все он оставил только 6 пн а не вернул цикл
 
Ответить
Сообщение
Так нужно?

почти, но цикл не повторяется. то есть прошли 6 понедельников и должно опять начаться с пн 1 и так по кругу просто подставила за место сегодня даты 30.07.2020 и все он оставил только 6 пн а не вернул цикл

Автор - Stefani
Дата добавления - 12.05.2020 в 18:09
AlexM Дата: Вторник, 12.05.2020, 18:54 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4161
Репутация: 1023 ±
Замечаний: 0% ±

Excel 2003
Так нужно?
К сообщению приложен файл: 2998072_02.xlsx(9.1 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеТак нужно?

Автор - AlexM
Дата добавления - 12.05.2020 в 18:54
Stefani Дата: Вторник, 12.05.2020, 19:45 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Так нужно?

Вы просто гений дат hands угу именно так супер yes большое спасибо! хорошо что есть такие умные люди в этом мире. Здоровья вам и светлых мыслей :-*
 
Ответить
Сообщение
Так нужно?

Вы просто гений дат hands угу именно так супер yes большое спасибо! хорошо что есть такие умные люди в этом мире. Здоровья вам и светлых мыслей :-*

Автор - Stefani
Дата добавления - 12.05.2020 в 19:45
Stefani Дата: Вторник, 12.05.2020, 19:49 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
а можно вопрос. я смотрела формулу
Код
=ИНДЕКС(B$3:G$6;СТРОКА(A3);ОСТАТ(ОТБР((A$11-A$2)/7);6)+1)

что означает A3 просто в других строках оно тоже пустое или это нужно для корректной работы всей формулы?
а в
Код
=ИНДЕКС(B$3:G$6;СТРОКА(A2);ОСТАТ(ОТБР((A$11-A$2)/7);6)+1)
она приходится на стартовую дату. в чем разница?
 
Ответить
Сообщениеа можно вопрос. я смотрела формулу
Код
=ИНДЕКС(B$3:G$6;СТРОКА(A3);ОСТАТ(ОТБР((A$11-A$2)/7);6)+1)

что означает A3 просто в других строках оно тоже пустое или это нужно для корректной работы всей формулы?
а в
Код
=ИНДЕКС(B$3:G$6;СТРОКА(A2);ОСТАТ(ОТБР((A$11-A$2)/7);6)+1)
она приходится на стартовую дату. в чем разница?

Автор - Stefani
Дата добавления - 12.05.2020 в 19:49
AlexM Дата: Вторник, 12.05.2020, 20:22 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4161
Репутация: 1023 ±
Замечаний: 0% ±

Excel 2003
Если аргумент функции СТРОКА() отсутствует, то функция возвращает номер строки в которой она используется.
СТРОКА(A1) - возвращает число 1, СТРОКА(A4) - возвращает число 4
Определяет номер строки в диапазоне B$3:G$6
ОСТАТ(ОТБР((A$11-A$2)/7);6)+1 - определяет столбец в диапазоне B$3:G$6



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеЕсли аргумент функции СТРОКА() отсутствует, то функция возвращает номер строки в которой она используется.
СТРОКА(A1) - возвращает число 1, СТРОКА(A4) - возвращает число 4
Определяет номер строки в диапазоне B$3:G$6
ОСТАТ(ОТБР((A$11-A$2)/7);6)+1 - определяет столбец в диапазоне B$3:G$6

Автор - AlexM
Дата добавления - 12.05.2020 в 20:22
Stefani Дата: Вторник, 12.05.2020, 21:15 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
спасибо большое ))) пошла расширять сковородку свою ))) мозг не совсем осознает написанное буду по шагам разбирать ))
 
Ответить
Сообщениеспасибо большое ))) пошла расширять сковородку свою ))) мозг не совсем осознает написанное буду по шагам разбирать ))

Автор - Stefani
Дата добавления - 12.05.2020 в 21:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод данных каждый понедельник список автоматом (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!