Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Случайные числа с заданной суммой - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Случайные числа с заданной суммой (Формулы/Formulas)
Случайные числа с заданной суммой
Gopronotmore Дата: Суббота, 16.05.2020, 20:58 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 136
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Коллеги, помогите решить задачку на ночь.

есть параметр с минимальным и максимальным значением. Мне нужно что бы сумма всех случайных чисел n=10 строк были равны заданной сумме сверху.
К сообщению приложен файл: example.xlsx(10.6 Kb)
 
Ответить
СообщениеКоллеги, помогите решить задачку на ночь.

есть параметр с минимальным и максимальным значением. Мне нужно что бы сумма всех случайных чисел n=10 строк были равны заданной сумме сверху.

Автор - Gopronotmore
Дата добавления - 16.05.2020 в 20:58
Gopronotmore Дата: Воскресенье, 17.05.2020, 00:28 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 136
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Пошаманил, нашел на форуме подсказку, сделал, но теперь вопрос почему в ячейке выдает #ЧИСЛО. Как сделать так что бы формула работала?

Подскажите пожалуйста
К сообщению приложен файл: example2.xlsx(10.8 Kb)
 
Ответить
СообщениеПошаманил, нашел на форуме подсказку, сделал, но теперь вопрос почему в ячейке выдает #ЧИСЛО. Как сделать так что бы формула работала?

Подскажите пожалуйста

Автор - Gopronotmore
Дата добавления - 17.05.2020 в 00:28
gling Дата: Воскресенье, 17.05.2020, 02:05 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 2074
Репутация: 523 ±
Замечаний: 0% ±

2010
почему в ячейке выдает #ЧИСЛО
Иногда в расчетах получается что в формуле СЛУЧМЕЖДУ() первый аргумент больше второго.
Пошаманил
Загнал формулы в диспетчер имен. Можно конечно оставить в ячейке, но больно длинная получается. А через диспетчера имен так
Код
=ЕСЛИ($A9="";"";СЛУЧМЕЖДУ(Minim;Maks))
К сообщению приложен файл: 9941660.xlsx(13.1 Kb)


ЯД-41001506838083
 
Ответить
Сообщение
почему в ячейке выдает #ЧИСЛО
Иногда в расчетах получается что в формуле СЛУЧМЕЖДУ() первый аргумент больше второго.
Пошаманил
Загнал формулы в диспетчер имен. Можно конечно оставить в ячейке, но больно длинная получается. А через диспетчера имен так
Код
=ЕСЛИ($A9="";"";СЛУЧМЕЖДУ(Minim;Maks))

Автор - gling
Дата добавления - 17.05.2020 в 02:05
Gopronotmore Дата: Воскресенье, 17.05.2020, 12:18 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 136
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
gling, спасибо большое, вроде не вылетают значения, но заметил одну особенность если взять диапазон рассчитываемый получается не всегда заданной сумме.

А с чем это связано? Если часто обновлять таблицу, то иногда сумма значений может быть не равна, тем которые были заданы.

Это можно как-то поправить? Или это особенность?

И если начать менять минимальные значения, то,числа становятся отрицательными? Как такое возможно?
К сообщению приложен файл: example_3.xlsx(11.9 Kb)


Сообщение отредактировал Gopronotmore - Воскресенье, 17.05.2020, 17:14
 
Ответить
Сообщениеgling, спасибо большое, вроде не вылетают значения, но заметил одну особенность если взять диапазон рассчитываемый получается не всегда заданной сумме.

А с чем это связано? Если часто обновлять таблицу, то иногда сумма значений может быть не равна, тем которые были заданы.

Это можно как-то поправить? Или это особенность?

И если начать менять минимальные значения, то,числа становятся отрицательными? Как такое возможно?

Автор - Gopronotmore
Дата добавления - 17.05.2020 в 12:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Случайные числа с заданной суммой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!