Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Замена первых цифр в числе - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена первых цифр в числе (Формулы/Formulas)
Замена первых цифр в числе
DimaSh Дата: Воскресенье, 17.05.2020, 19:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день, нужна помощь.

Допустим есть огромное множество чисел, которые начинаются либо с цифры 4, или с 6, или с 7, или с 8. Нужно, чтобы числа, начинающиеся с цифры 4 - начинались с цифры 8, а числа, начинающиеся с цифры 6 - 7. При этом, в числах, которые начинаются с цифры 7 или 8 не должны подвергаться каким-либо изменениям.

Приложил пример с попытками создания формулы. Получилось создать формулу для замены числа, если он только начинается с цифры 4. А надо, чтобы при двух условиях и на соответствующие цифры: 4->8, 6->7

Буду очень благодарен, если подскажете.
К сообщению приложен файл: 2686615.xlsx(8.0 Kb)
 
Ответить
СообщениеДобрый день, нужна помощь.

Допустим есть огромное множество чисел, которые начинаются либо с цифры 4, или с 6, или с 7, или с 8. Нужно, чтобы числа, начинающиеся с цифры 4 - начинались с цифры 8, а числа, начинающиеся с цифры 6 - 7. При этом, в числах, которые начинаются с цифры 7 или 8 не должны подвергаться каким-либо изменениям.

Приложил пример с попытками создания формулы. Получилось создать формулу для замены числа, если он только начинается с цифры 4. А надо, чтобы при двух условиях и на соответствующие цифры: 4->8, 6->7

Буду очень благодарен, если подскажете.

Автор - DimaSh
Дата добавления - 17.05.2020 в 19:57
bigor Дата: Воскресенье, 17.05.2020, 20:27 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 180
Репутация: 32 ±
Замечаний: 0% ±

Excel 2016
Если просто расширить Вашу формулу, то так
Код
=IF(LEFT(A1;1)="4";REPLACE(A1;1;1;"8");IF(LEFT(A1;1)="6";REPLACE(A1;1;1;"7");A1))
 
Ответить
СообщениеЕсли просто расширить Вашу формулу, то так
Код
=IF(LEFT(A1;1)="4";REPLACE(A1;1;1;"8");IF(LEFT(A1;1)="6";REPLACE(A1;1;1;"7");A1))

Автор - bigor
Дата добавления - 17.05.2020 в 20:27
Che79 Дата: Воскресенье, 17.05.2020, 20:34 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1452
Репутация: 263 ±
Замечаний: 0% ±

Excel 2013
Не думая, не подсматривая, поэтому с доп столбцом и массивная
Код
=ЕСЛИ(ИЛИ(--ЛЕВБ(A1)=$E$2:$E$3);ВПР(--ЛЕВБ(A1);$E$2:$F$3;2;);--ЛЕВБ(A1))&ПСТР(A1;2;99)
(вводится одновременным нажатием Кнтрл+Шифт+Энтер)

*допы заменяем массивами констант
Код
=ЕСЛИ(ИЛИ(--ЛЕВБ(A1)={4:6});ВПР(--ЛЕВБ(A1);{4;8:6;7};2;);--ЛЕВБ(A1))&ПСТР(A1;2;99)
CSE
К сообщению приложен файл: 2686615_1.xlsx(9.3 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Воскресенье, 17.05.2020, 20:42
 
Ответить
СообщениеНе думая, не подсматривая, поэтому с доп столбцом и массивная
Код
=ЕСЛИ(ИЛИ(--ЛЕВБ(A1)=$E$2:$E$3);ВПР(--ЛЕВБ(A1);$E$2:$F$3;2;);--ЛЕВБ(A1))&ПСТР(A1;2;99)
(вводится одновременным нажатием Кнтрл+Шифт+Энтер)

*допы заменяем массивами констант
Код
=ЕСЛИ(ИЛИ(--ЛЕВБ(A1)={4:6});ВПР(--ЛЕВБ(A1);{4;8:6;7};2;);--ЛЕВБ(A1))&ПСТР(A1;2;99)
CSE

Автор - Che79
Дата добавления - 17.05.2020 в 20:34
AlexM Дата: Понедельник, 18.05.2020, 08:12 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4163
Репутация: 1024 ±
Замечаний: 0% ±

Excel 2003
Код
=--(ТЕКСТ(ЛЕВБ(A1);"[=4]8;[=6]7;0")&ПСТР(A1;2;19))
и покороче
Код
=--(ПСТР(123857789;ЛЕВБ(A1);1)&ПСТР(A1;2;19))
Если число всегда 5-и значное
Код
=--(ПСТР(123857789;A1%%;1)&ПСТР(A1;2;19))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Понедельник, 18.05.2020, 12:17
 
Ответить
Сообщение
Код
=--(ТЕКСТ(ЛЕВБ(A1);"[=4]8;[=6]7;0")&ПСТР(A1;2;19))
и покороче
Код
=--(ПСТР(123857789;ЛЕВБ(A1);1)&ПСТР(A1;2;19))
Если число всегда 5-и значное
Код
=--(ПСТР(123857789;A1%%;1)&ПСТР(A1;2;19))

Автор - AlexM
Дата добавления - 18.05.2020 в 08:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Замена первых цифр в числе (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!