Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Принцип работы формулы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Принцип работы формулы (Формулы/Formulas)
Принцип работы формулы
Янек Дата: Суббота, 06.06.2020, 11:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
Добрый день, добрые люди. Не мог бы кто-нибудь пояснить на человеческом языке, почему в одном случае формула работает, а в другом - только частично.
Суть: есть список фамилий с указанием возраста. Есть справочник категорий для возрастов с минимальным и максимальным возрастом для каждой категории. Задача: проставить категорию для каждой фамилии, опираясь на этот справочник. Так вот формула вида:
{
Код
=МАКС(ЕСЛИ((B2>=$H$3:$H$9)*(B2<=$I$3:$I$9);$J$3:$J$9))
} - работает.
А формула вида
{
Код
=(ЕСЛИ((B2>=$H$3:$H$9)*(B2<=$I$3:$I$9);$J$3:$J$9))
} работает только для возраста из первой категории.

Поясните, пожалуйста, почему так. Как, в переводе на человеческий язык, excel видит первую и вторую формулу. Второй день не могу понять.
Спасибо большое.
К сообщению приложен файл: 123.xlsx(11.6 Kb)
 
Ответить
СообщениеДобрый день, добрые люди. Не мог бы кто-нибудь пояснить на человеческом языке, почему в одном случае формула работает, а в другом - только частично.
Суть: есть список фамилий с указанием возраста. Есть справочник категорий для возрастов с минимальным и максимальным возрастом для каждой категории. Задача: проставить категорию для каждой фамилии, опираясь на этот справочник. Так вот формула вида:
{
Код
=МАКС(ЕСЛИ((B2>=$H$3:$H$9)*(B2<=$I$3:$I$9);$J$3:$J$9))
} - работает.
А формула вида
{
Код
=(ЕСЛИ((B2>=$H$3:$H$9)*(B2<=$I$3:$I$9);$J$3:$J$9))
} работает только для возраста из первой категории.

Поясните, пожалуйста, почему так. Как, в переводе на человеческий язык, excel видит первую и вторую формулу. Второй день не могу понять.
Спасибо большое.

Автор - Янек
Дата добавления - 06.06.2020 в 11:17
китин Дата: Суббота, 06.06.2020, 11:20 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6313
Репутация: 969 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Янек, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеЯнек, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 06.06.2020 в 11:20
китин Дата: Суббота, 06.06.2020, 11:28 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6313
Репутация: 969 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Да все элементарно: если в первой формуле вы задаете условие нахождения максимального числа из столбца J при соблюдении двух условий, то во второй вы просто спрашиваете формулой соблюдаются эти условия или нет. и формула выдает вам истина или ложь


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДа все элементарно: если в первой формуле вы задаете условие нахождения максимального числа из столбца J при соблюдении двух условий, то во второй вы просто спрашиваете формулой соблюдаются эти условия или нет. и формула выдает вам истина или ложь

Автор - китин
Дата добавления - 06.06.2020 в 11:28
Che79 Дата: Суббота, 06.06.2020, 11:36 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1637
Репутация: 302 ±
Замечаний: 0% ±

2013 Win, 365 Mac
[offtop] А по части альтернативного решения задачи, можно и не заморачиваться на массивы, а просто
Код
=ВПР(B2;$H$3:$J$9;3)
тут как кому привычнее.


Делай нормально и будет нормально!
 
Ответить
Сообщение[offtop] А по части альтернативного решения задачи, можно и не заморачиваться на массивы, а просто
Код
=ВПР(B2;$H$3:$J$9;3)
тут как кому привычнее.

Автор - Che79
Дата добавления - 06.06.2020 в 11:36
Янек Дата: Суббота, 06.06.2020, 12:20 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 1 ±
Замечаний: 0% ±

Excel 2016
Излишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Так ведь впр будет искать точное совпадение, а задача стоит определить, к какому диапазону относится искомое значение


Сообщение отредактировал китин - Суббота, 06.06.2020, 12:40
 
Ответить
СообщениеИзлишнее цитирование удалено администрацией - это нарушение п.5j Правил форума

Так ведь впр будет искать точное совпадение, а задача стоит определить, к какому диапазону относится искомое значение

Автор - Янек
Дата добавления - 06.06.2020 в 12:20
Nic70y Дата: Суббота, 06.06.2020, 12:22 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 6584
Репутация: 1449 ±
Замечаний: 0% ±

ru13;10;03
точное совпадение
Код
=ВПР(B2;$H$3:$J$9;3;)
неточное
Код
=ВПР(B2;$H$3:$J$9;3)
и для разнообразия
Код
=СУММЕСЛИМН(J$3:J$9;H$3:H$9;"<="&B2;I$3:I$9;">="&B2)


Яндекс Деньги 41001841029809

Сообщение отредактировал Nic70y - Суббота, 06.06.2020, 12:35
 
Ответить
Сообщение
точное совпадение
Код
=ВПР(B2;$H$3:$J$9;3;)
неточное
Код
=ВПР(B2;$H$3:$J$9;3)
и для разнообразия
Код
=СУММЕСЛИМН(J$3:J$9;H$3:H$9;"<="&B2;I$3:I$9;">="&B2)

Автор - Nic70y
Дата добавления - 06.06.2020 в 12:22
Che79 Дата: Суббота, 06.06.2020, 13:45 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1637
Репутация: 302 ±
Замечаний: 0% ±

2013 Win, 365 Mac
и для разнообразия
Код
=ИНДЕКС(J:J;ПОИСКПОЗ(B2;H:H))
и массивная, по аналогии с Вашим вариантом
Код
=МАКС((B2>=$H$3:$H$9)*(B2<=$I$3:$I$9)*$J$3:$J$9)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Суббота, 06.06.2020, 14:02
 
Ответить
Сообщение
и для разнообразия
Код
=ИНДЕКС(J:J;ПОИСКПОЗ(B2;H:H))
и массивная, по аналогии с Вашим вариантом
Код
=МАКС((B2>=$H$3:$H$9)*(B2<=$I$3:$I$9)*$J$3:$J$9)

Автор - Che79
Дата добавления - 06.06.2020 в 13:45
gling Дата: Суббота, 06.06.2020, 14:04 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 2194
Репутация: 545 ±
Замечаний: 0% ±

2010
Как, в переводе на человеческий язык, excel видит первую и вторую формулу.
Активируйте ячейку с формулой - Откройте вкладку "Формулы" - Вычислить формулу - Вычислить. Смотрите и читайте что там пишется в пояснениях. Лучше в формуле ограничиться маленьким диапазоном, иначе будет много лишней информации и сложно будет понять объяснение Excel на "человеческий язык".


ЯД-41001506838083
 
Ответить
Сообщение
Как, в переводе на человеческий язык, excel видит первую и вторую формулу.
Активируйте ячейку с формулой - Откройте вкладку "Формулы" - Вычислить формулу - Вычислить. Смотрите и читайте что там пишется в пояснениях. Лучше в формуле ограничиться маленьким диапазоном, иначе будет много лишней информации и сложно будет понять объяснение Excel на "человеческий язык".

Автор - gling
Дата добавления - 06.06.2020 в 14:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Принцип работы формулы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!