Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенести данные массива - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенести данные массива (Формулы/Formulas)
Перенести данные массива
semenizer87 Дата: Среда, 10.06.2020, 14:04 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 365
Доброго дня, уважаемые форумчане. Прошерстил весь форум, но не нашел искомого ответа. В прикрепленном файле имеется формула для переноса данных двумерного массива, которая почему-то в некоторых ячейках дает сбой (выделил желтым цветом). Не могу разобраться, где именно возникает ошибка.
Если совсем обнаглеть, то хотелось бы в столбце А видеть данные за исключением "ID().value"

Буду премного благодарен за помощь.
 
Ответить
СообщениеДоброго дня, уважаемые форумчане. Прошерстил весь форум, но не нашел искомого ответа. В прикрепленном файле имеется формула для переноса данных двумерного массива, которая почему-то в некоторых ячейках дает сбой (выделил желтым цветом). Не могу разобраться, где именно возникает ошибка.
Если совсем обнаглеть, то хотелось бы в столбце А видеть данные за исключением "ID().value"

Буду премного благодарен за помощь.

Автор - semenizer87
Дата добавления - 10.06.2020 в 14:04
Che79 Дата: Среда, 10.06.2020, 14:16 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1611
Репутация: 299 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Добрый. А у Вас ус отклеился файл-пример не прикрепился. Продублируйте, пож-та


Делай нормально и будет нормально!
 
Ответить
СообщениеДобрый. А у Вас ус отклеился файл-пример не прикрепился. Продублируйте, пож-та

Автор - Che79
Дата добавления - 10.06.2020 в 14:16
semenizer87 Дата: Среда, 10.06.2020, 14:18 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 365
Che79,
К сообщению приложен файл: Map.xlsx(27.3 Kb)
 
Ответить
СообщениеChe79,

Автор - semenizer87
Дата добавления - 10.06.2020 в 14:18
Nic70y Дата: Среда, 10.06.2020, 14:57 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6460
Репутация: 1422 ±
Замечаний: 0% ±

ru13;10;03
Код
=ИНДЕКС(E:N;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ((E$1:N$99<>"")*(E$1:N$99<>"ID().value");СТРОКА(E$1:N$99)/1000+СТОЛБЕЦ(E$1:N$99));СТРОКА(A1));1)*1000;);НАИМЕНЬШИЙ(ЕСЛИ((E$1:N$99<>"")*(E$1:N$99<>"ID().value");СТРОКА(E$1:N$99)/1000+СТОЛБЕЦ(E$1:N$99));СТРОКА(A1))-4)
К сообщению приложен файл: 6611540.xlsx(23.4 Kb)


Яндекс Деньги 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(E:N;ОКРУГЛ(ОСТАТ(НАИМЕНЬШИЙ(ЕСЛИ((E$1:N$99<>"")*(E$1:N$99<>"ID().value");СТРОКА(E$1:N$99)/1000+СТОЛБЕЦ(E$1:N$99));СТРОКА(A1));1)*1000;);НАИМЕНЬШИЙ(ЕСЛИ((E$1:N$99<>"")*(E$1:N$99<>"ID().value");СТРОКА(E$1:N$99)/1000+СТОЛБЕЦ(E$1:N$99));СТРОКА(A1))-4)

Автор - Nic70y
Дата добавления - 10.06.2020 в 14:57
semenizer87 Дата: Среда, 10.06.2020, 15:17 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 18
Репутация: 0 ±
Замечаний: 0% ±

Excel 365
Nic70y, огромной спасибо!!! Все работает
 
Ответить
СообщениеNic70y, огромной спасибо!!! Все работает

Автор - semenizer87
Дата добавления - 10.06.2020 в 15:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенести данные массива (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!