Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор формулой уникальных по условиям, находящимся в списке - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор формулой уникальных по условиям, находящимся в списке (Формулы/Formulas)
Выбор формулой уникальных по условиям, находящимся в списке
Артемий2 Дата: Среда, 17.06.2020, 06:26 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!
Прошу помочь дописать формулу.
Суть: из таблицы сформировать список уникальных значений по критериям, которые находятся в списке.
Частично работа уже сделана, осталось "вписать" в формулу условие выбора по критерию из списка.
И тут что-то совсем, всё заглохло ...
К сожалению, решение нужно строго формулой (ну, собственно, выше я и написал...).
В файле, я надеюсь, понятнее будет.
кросс: https://www.planetaexcel.ru/forum....B=&vba=
К сообщению приложен файл: 5584189.xlsx(22.2 Kb)


Сообщение отредактировал Артемий2 - Среда, 17.06.2020, 12:43
 
Ответить
СообщениеЗдравствуйте!
Прошу помочь дописать формулу.
Суть: из таблицы сформировать список уникальных значений по критериям, которые находятся в списке.
Частично работа уже сделана, осталось "вписать" в формулу условие выбора по критерию из списка.
И тут что-то совсем, всё заглохло ...
К сожалению, решение нужно строго формулой (ну, собственно, выше я и написал...).
В файле, я надеюсь, понятнее будет.
кросс: https://www.planetaexcel.ru/forum....B=&vba=

Автор - Артемий2
Дата добавления - 17.06.2020 в 06:26
amfor Дата: Среда, 17.06.2020, 07:47 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 56 ±
Замечаний: 0% ±

Excel 2016
Добрый день. Как понял. С доп.столбцом(можно скрыть)
К сообщению приложен файл: 8459928.xlsx(24.3 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеДобрый день. Как понял. С доп.столбцом(можно скрыть)

Автор - amfor
Дата добавления - 17.06.2020 в 07:47
Артемий2 Дата: Среда, 17.06.2020, 09:47 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
amfor, спасибо. Буду думать ))
Единственно, хотелось отбирать чтобы машина была столько раз. сколько разных людей на ней было. То есть если был один человек - то один раз.
 
Ответить
Сообщениеamfor, спасибо. Буду думать ))
Единственно, хотелось отбирать чтобы машина была столько раз. сколько разных людей на ней было. То есть если был один человек - то один раз.

Автор - Артемий2
Дата добавления - 17.06.2020 в 09:47
AlexM Дата: Среда, 17.06.2020, 10:11 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4231
Репутация: 1043 ±
Замечаний: 0% ±

Excel 2003
Артемий2, В исходной таблице нет данных о самосвал или другой. Как отбирать?



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеАртемий2, В исходной таблице нет данных о самосвал или другой. Как отбирать?

Автор - AlexM
Дата добавления - 17.06.2020 в 10:11
Pelena Дата: Среда, 17.06.2020, 11:35 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16061
Репутация: 3491 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Вариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$5:D$44;НАИМЕНЬШИЙ(ЕСЛИ((ПОИСКПОЗ($C$5:$C$44&$D$5:$D$44;$C$5:$C$44&$D$5:$D$44;0)=СТРОКА($C$5:$C$44)-4)*ЕЧИСЛО(ПОИСКПОЗ($C$5:$C$44;$P$22:$P$64;0));СТРОКА($C$5:$C$44)-4);СТРОКА(A1));1);"")
К сообщению приложен файл: 5758510.xlsx(22.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВариант
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$5:D$44;НАИМЕНЬШИЙ(ЕСЛИ((ПОИСКПОЗ($C$5:$C$44&$D$5:$D$44;$C$5:$C$44&$D$5:$D$44;0)=СТРОКА($C$5:$C$44)-4)*ЕЧИСЛО(ПОИСКПОЗ($C$5:$C$44;$P$22:$P$64;0));СТРОКА($C$5:$C$44)-4);СТРОКА(A1));1);"")

Автор - Pelena
Дата добавления - 17.06.2020 в 11:35
AlexM Дата: Среда, 17.06.2020, 12:41 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4231
Репутация: 1043 ±
Замечаний: 0% ±

Excel 2003
На Лист2 мой вариант без функции ЕСЛИОШИБКА()
Формула массива для номера авто
Код
=ИНДЕКС(C$5:C$44;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(C$5:C$44&D$5:D$44;C$5:C$44&D$5:D$44;0)*СЧЁТЕСЛИ(U$4:U$48;C$5:C$44)=СТРОКА(B$1:B$40);СТРОКА(B$1:B$40));СТРОКА(A1)))
К сообщению приложен файл: 6873788_01.xlsx(29.5 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 17.06.2020, 12:47
 
Ответить
СообщениеНа Лист2 мой вариант без функции ЕСЛИОШИБКА()
Формула массива для номера авто
Код
=ИНДЕКС(C$5:C$44;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ(C$5:C$44&D$5:D$44;C$5:C$44&D$5:D$44;0)*СЧЁТЕСЛИ(U$4:U$48;C$5:C$44)=СТРОКА(B$1:B$40);СТРОКА(B$1:B$40));СТРОКА(A1)))

Автор - AlexM
Дата добавления - 17.06.2020 в 12:41
Артемий2 Дата: Среда, 17.06.2020, 13:02 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Очень благодарю! Pelena, , AlexM, - здорово, конечно.
Чё-то я был далёк от результата )
Большое спасибо!
 
Ответить
СообщениеОчень благодарю! Pelena, , AlexM, - здорово, конечно.
Чё-то я был далёк от результата )
Большое спасибо!

Автор - Артемий2
Дата добавления - 17.06.2020 в 13:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор формулой уникальных по условиям, находящимся в списке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!