Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формирование таблицы_2 по условию на основе таблицы_1 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование таблицы_2 по условию на основе таблицы_1 (Формулы/Formulas)
Формирование таблицы_2 по условию на основе таблицы_1
russcand Дата: Среда, 17.06.2020, 18:55 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Друзья , решил прибраться у себя в хранилище презренного металла.
В течение 11 дней Друзья ( с большой буквы ) приносили разное количество слитков , сгружая их в разные ячейки , которых было 11 ( чисто случайно ). Учет велся в таблице №1.
Ячейка считается заполненной , если в ней больше или равно 15 слитков.
Надо , чтобы автоматом строилась таблица с теми же столбцами , но с выборкой по столбцу "к-во слитков" ( от 15 и больше ) в порядке убывания по столбцу "Номера ячеек".
Учет нужен по требованию инспекторов ФРС ( скоро придутЬ ).
Решение в Экселе.
Спасибо.
К сообщению приложен файл: 2031842.xlsx(11.0 Kb)


Сообщение отредактировал russcand - Среда, 17.06.2020, 19:05
 
Ответить
СообщениеДрузья , решил прибраться у себя в хранилище презренного металла.
В течение 11 дней Друзья ( с большой буквы ) приносили разное количество слитков , сгружая их в разные ячейки , которых было 11 ( чисто случайно ). Учет велся в таблице №1.
Ячейка считается заполненной , если в ней больше или равно 15 слитков.
Надо , чтобы автоматом строилась таблица с теми же столбцами , но с выборкой по столбцу "к-во слитков" ( от 15 и больше ) в порядке убывания по столбцу "Номера ячеек".
Учет нужен по требованию инспекторов ФРС ( скоро придутЬ ).
Решение в Экселе.
Спасибо.

Автор - russcand
Дата добавления - 17.06.2020 в 18:55
Pelena Дата: Среда, 17.06.2020, 18:58 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16780
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Фильтр не вариант?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФильтр не вариант?

Автор - Pelena
Дата добавления - 17.06.2020 в 18:58
russcand Дата: Среда, 17.06.2020, 19:00 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Фильтр не вариант?

Таблица нужна на другом листе. Кроме этого при фильтре сильно подвисает.
 
Ответить
Сообщение
Фильтр не вариант?

Таблица нужна на другом листе. Кроме этого при фильтре сильно подвисает.

Автор - russcand
Дата добавления - 17.06.2020 в 19:00
AlexM Дата: Среда, 17.06.2020, 19:09 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Для номеров формула массива
Код
=НАИМЕНЬШИЙ(ЕСЛИ(C$3:C$13>=--ПСТР(C$17;2;9);B$3:B$13);СТРОКА(A1))
Для остального
Код
=ИНДЕКС(C$3:C$13;$B19)
К сообщению приложен файл: 2031842_01.xlsx(11.6 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеДля номеров формула массива
Код
=НАИМЕНЬШИЙ(ЕСЛИ(C$3:C$13>=--ПСТР(C$17;2;9);B$3:B$13);СТРОКА(A1))
Для остального
Код
=ИНДЕКС(C$3:C$13;$B19)

Автор - AlexM
Дата добавления - 17.06.2020 в 19:09
Pelena Дата: Среда, 17.06.2020, 19:22 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 16780
Репутация: 3621 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
при фильтре сильно подвисает

Формулы, думаете, будут быстрее?
Ещё варианты Расширенным фильтром и Power Query
К сообщению приложен файл: 3797074.xlsx(25.2 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
при фильтре сильно подвисает

Формулы, думаете, будут быстрее?
Ещё варианты Расширенным фильтром и Power Query

Автор - Pelena
Дата добавления - 17.06.2020 в 19:22
russcand Дата: Среда, 17.06.2020, 19:29 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Алекс , есть проблема.
Почему формулы по таблице_3 ( то , что Вы нарисовали ) обращаются к таблице_2 , а не к исходнику ( таблица_1 )?
вот это: =ИНДЕКС(C$3:C$13;$B19)


Сообщение отредактировал russcand - Среда, 17.06.2020, 19:33
 
Ответить
СообщениеАлекс , есть проблема.
Почему формулы по таблице_3 ( то , что Вы нарисовали ) обращаются к таблице_2 , а не к исходнику ( таблица_1 )?
вот это: =ИНДЕКС(C$3:C$13;$B19)

Автор - russcand
Дата добавления - 17.06.2020 в 19:29
AlexM Дата: Среда, 17.06.2020, 19:33 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
из таблицы 2 только условие из C$17. --ПСТР(C$17;2;9)
Все остальное из исходной таблицы
PS. Ошибся. Так нужно
Код
=ИНДЕКС(C$3:C$13;$B25)

Исправил файл. Все расчеты в таблице 2
К сообщению приложен файл: 2031842_02.xlsx(11.1 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 17.06.2020, 19:37
 
Ответить
Сообщениеиз таблицы 2 только условие из C$17. --ПСТР(C$17;2;9)
Все остальное из исходной таблицы
PS. Ошибся. Так нужно
Код
=ИНДЕКС(C$3:C$13;$B25)

Исправил файл. Все расчеты в таблице 2

Автор - AlexM
Дата добавления - 17.06.2020 в 19:33
russcand Дата: Среда, 17.06.2020, 19:40 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Так таблица_2 это пример того , как должна выглядеть новая таблица , исходником которой является таблица_1.
У Вас получается , что создается таблица_3 , которая обращается ( хотя бы одним обращением ) к таблице_2 , которая является образцом , но формулами с исходной не связана.
Есть исходная таблица_1 , нужна таблица , связанная с первой. А вторая это лишь образец.
 
Ответить
СообщениеТак таблица_2 это пример того , как должна выглядеть новая таблица , исходником которой является таблица_1.
У Вас получается , что создается таблица_3 , которая обращается ( хотя бы одним обращением ) к таблице_2 , которая является образцом , но формулами с исходной не связана.
Есть исходная таблица_1 , нужна таблица , связанная с первой. А вторая это лишь образец.

Автор - russcand
Дата добавления - 17.06.2020 в 19:40
AlexM Дата: Среда, 17.06.2020, 19:43 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
russcand, диапазоны из таблицы 1. Я с индексом ошибся и взял его не из таблицы 3, а из 2.
Пример уже исправил в сообщении №7



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщениеrusscand, диапазоны из таблицы 1. Я с индексом ошибся и взял его не из таблицы 3, а из 2.
Пример уже исправил в сообщении №7

Автор - AlexM
Дата добавления - 17.06.2020 в 19:43
russcand Дата: Среда, 17.06.2020, 19:44 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Ага , теперь ( вроде ) верно , буду пробовать.
Спасибо.
 
Ответить
СообщениеАга , теперь ( вроде ) верно , буду пробовать.
Спасибо.

Автор - russcand
Дата добавления - 17.06.2020 в 19:44
russcand Дата: Среда, 17.06.2020, 20:44 | Сообщение № 11
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
У меня в строке В23 стоит #ЧИСЛО! ( там формула , как и во всей графе "В" таблицы_2 ).
Как сделать , чтобы , если нет значения , удовлетворяющего условию , было пустое поле вместо #ЧИСЛО!?
 
Ответить
СообщениеУ меня в строке В23 стоит #ЧИСЛО! ( там формула , как и во всей графе "В" таблицы_2 ).
Как сделать , чтобы , если нет значения , удовлетворяющего условию , было пустое поле вместо #ЧИСЛО!?

Автор - russcand
Дата добавления - 17.06.2020 в 20:44
AlexM Дата: Среда, 17.06.2020, 22:28 | Сообщение № 12
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Функция ЕСЛИОШИБКА()
Не забывайте, в столбце В формулы массива, ввод которых делают тремя клавишами Ctrl+Shift+Ente
Правильно введённая формула выглядит так.
{=формула массива}



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 17.06.2020, 22:34
 
Ответить
СообщениеФункция ЕСЛИОШИБКА()
Не забывайте, в столбце В формулы массива, ввод которых делают тремя клавишами Ctrl+Shift+Ente
Правильно введённая формула выглядит так.
{=формула массива}

Автор - AlexM
Дата добавления - 17.06.2020 в 22:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формирование таблицы_2 по условию на основе таблицы_1 (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!