Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Интервал рабочих дней в зависимости от недели - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Интервал рабочих дней в зависимости от недели (Формулы/Formulas)
Интервал рабочих дней в зависимости от недели
Kat Дата: Четверг, 18.06.2020, 15:47 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Может ли EXCEL в зависимости от того, какая неделя Года, указать рабочие дни в одной ячейке?

Пример во вложении.

Спасибо
К сообщению приложен файл: 9956726.xlsx(8.8 Kb)
 
Ответить
СообщениеДобрый день.
Может ли EXCEL в зависимости от того, какая неделя Года, указать рабочие дни в одной ячейке?

Пример во вложении.

Спасибо

Автор - Kat
Дата добавления - 18.06.2020 в 15:47
Nic70y Дата: Четверг, 18.06.2020, 17:17 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6618
Репутация: 1459 ±
Замечаний: 0% ±

ru13;10;03
У Вас в примере не по № недели, а по начальной дате,
аналогично вариант
Код
=ТЕКСТ(МАКС($B$2;ОСТАТ(12-ДЕНЬНЕД($B$2;2);7)+(СТОЛБЕЦ(A1)-1)*7+$B$2-4);"ДД.ММ.ГГ")&ТЕКСТ(ОСТАТ(12-ДЕНЬНЕД($B$2;2);7)+(СТОЛБЕЦ(A1)-1)*7+$B$2;"-ДД.ММ.ГГ")
без учета праздников
К сообщению приложен файл: 5505283.xlsx(8.9 Kb)


Яндекс Деньги 41001841029809
 
Ответить
СообщениеУ Вас в примере не по № недели, а по начальной дате,
аналогично вариант
Код
=ТЕКСТ(МАКС($B$2;ОСТАТ(12-ДЕНЬНЕД($B$2;2);7)+(СТОЛБЕЦ(A1)-1)*7+$B$2-4);"ДД.ММ.ГГ")&ТЕКСТ(ОСТАТ(12-ДЕНЬНЕД($B$2;2);7)+(СТОЛБЕЦ(A1)-1)*7+$B$2;"-ДД.ММ.ГГ")
без учета праздников

Автор - Nic70y
Дата добавления - 18.06.2020 в 17:17
AlexM Дата: Четверг, 18.06.2020, 17:23 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4256
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Почти так же
Код
=ТЕКСТ(МАКС($B2;(4&-1&-ГОД($B2))-ДЕНЬНЕД(3&-1&-ГОД($B2))+B4*7-6);"ДД.ММ.ГГ")&"-"&ТЕКСТ((4&-1&-ГОД($B2))-ДЕНЬНЕД(3&-1&-ГОД($B2))+B4*7-2;"ДД.ММ.ГГ")
К сообщению приложен файл: 9956726_01.xlsx(8.6 Kb)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеПочти так же
Код
=ТЕКСТ(МАКС($B2;(4&-1&-ГОД($B2))-ДЕНЬНЕД(3&-1&-ГОД($B2))+B4*7-6);"ДД.ММ.ГГ")&"-"&ТЕКСТ((4&-1&-ГОД($B2))-ДЕНЬНЕД(3&-1&-ГОД($B2))+B4*7-2;"ДД.ММ.ГГ")

Автор - AlexM
Дата добавления - 18.06.2020 в 17:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Интервал рабочих дней в зависимости от недели (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!