Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма чисел в скобках из одной ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма чисел в скобках из одной ячейки (Формулы/Formulas)
Сумма чисел в скобках из одной ячейки
petr1 Дата: Воскресенье, 28.06.2020, 12:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте. Помогите пожалуйста с формулой.
Есть одна ячейка в которой написаны числа, нужно взять из нее все числа которые в скобках и сложить между собой,
а ответ вывести в другую ячейку (необязательно(прибавив надпись "шт." без кавычек.))
Пример: 2*5(15) 3*1(5) 1*1(3) .Сумма 23шт. должна выйти
заранее спасибо.
К сообщению приложен файл: 0239390.xlsx(4.8 Kb)


Сообщение отредактировал petr1 - Воскресенье, 28.06.2020, 16:10
 
Ответить
СообщениеЗдравствуйте. Помогите пожалуйста с формулой.
Есть одна ячейка в которой написаны числа, нужно взять из нее все числа которые в скобках и сложить между собой,
а ответ вывести в другую ячейку (необязательно(прибавив надпись "шт." без кавычек.))
Пример: 2*5(15) 3*1(5) 1*1(3) .Сумма 23шт. должна выйти
заранее спасибо.

Автор - petr1
Дата добавления - 28.06.2020 в 12:04
Anis625 Дата: Воскресенье, 28.06.2020, 22:52 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 410
Репутация: 12 ±
Замечаний: 0% ±

Excel 2013
petr1,
Идея решения подсмотрена тут. Решение локальное исходя из примера, если количество скобок меняется то формулу нужно менять.
Готовое решение во вложении
К сообщению приложен файл: 0239390_2.xlsx(8.6 Kb)
 
Ответить
Сообщениеpetr1,
Идея решения подсмотрена тут. Решение локальное исходя из примера, если количество скобок меняется то формулу нужно менять.
Готовое решение во вложении

Автор - Anis625
Дата добавления - 28.06.2020 в 22:52
Hugo Дата: Воскресенье, 28.06.2020, 23:38 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3070
Репутация: 662 ±
Замечаний: 0% ±

Обычно такое решают с помощью VBA, привлекая RegExp. Но это не по профилю раздела... Но решение есть.


excel@nxt.ru
webmoney: E265281470651 R418926282008 Z422237915069
 
Ответить
СообщениеОбычно такое решают с помощью VBA, привлекая RegExp. Но это не по профилю раздела... Но решение есть.

Автор - Hugo
Дата добавления - 28.06.2020 в 23:38
Светлый Дата: Понедельник, 29.06.2020, 00:10 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1475
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010, 2013
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;"(";ПОВТОР(" ";99));")";ПОВТОР(" ";99));СТРОКА($1:$20)*99-98;99);))
*Даже так:
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;"(";")");")";ПОВТОР(" ";99));СТРОКА($1:$20)*99-98;99);))&" шт."
**Немассивная формула:
Код
=СУММПРОИЗВ(--(0&СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПСТР(ПОДСТАВИТЬ(A2;"(";ПОВТОР(" ";99));СТРОКА($1:$9)*99;99);")";ПОВТОР(" ";99));99))))&" шт."
***
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(-ЛЕВБ(ПОДСТАВИТЬ(ПСТР(A2;ПОИСК("!";ПОДСТАВИТЬ(A2;"(";"!";{1;2;3;4;5}));9);")";")       ");9);))&" шт."


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 29.06.2020, 00:40
 
Ответить
СообщениеФормула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;"(";ПОВТОР(" ";99));")";ПОВТОР(" ";99));СТРОКА($1:$20)*99-98;99);))
*Даже так:
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(ПОДСТАВИТЬ(ПОДСТАВИТЬ(A2;"(";")");")";ПОВТОР(" ";99));СТРОКА($1:$20)*99-98;99);))&" шт."
**Немассивная формула:
Код
=СУММПРОИЗВ(--(0&СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(ПСТР(ПОДСТАВИТЬ(A2;"(";ПОВТОР(" ";99));СТРОКА($1:$9)*99;99);")";ПОВТОР(" ";99));99))))&" шт."
***
Код
=СУММПРОИЗВ(ЕСЛИОШИБКА(-ЛЕВБ(ПОДСТАВИТЬ(ПСТР(A2;ПОИСК("!";ПОДСТАВИТЬ(A2;"(";"!";{1;2;3;4;5}));9);")";")       ");9);))&" шт."

Автор - Светлый
Дата добавления - 29.06.2020 в 00:10
petr1 Дата: Понедельник, 29.06.2020, 00:29 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо большое! всем откликнувшимся.
воспользовался формулой Anis625, но ув.Светлый и Hugo Вам тоже спасибо.
и перешел в тему где подсмотрено, почитал ее....господи какие же там формулы ограменные...
но эт отступление. еще раз Спасибо.


Сообщение отредактировал petr1 - Понедельник, 29.06.2020, 00:35
 
Ответить
СообщениеСпасибо большое! всем откликнувшимся.
воспользовался формулой Anis625, но ув.Светлый и Hugo Вам тоже спасибо.
и перешел в тему где подсмотрено, почитал ее....господи какие же там формулы ограменные...
но эт отступление. еще раз Спасибо.

Автор - petr1
Дата добавления - 29.06.2020 в 00:29
Светлый Дата: Вторник, 30.06.2020, 23:33 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1475
Репутация: 385 ±
Замечаний: 0% ±

Excel 2010, 2013
Ещё идеи пришли в голову:
Код
=СУММПРОИЗВ(-ЛЕВБ(ПОДСТАВИТЬ(ПСТР("(0)"&A2;(ПСТР(A2;СТРОКА($1:97);1)="(")*СТРОКА($3:99)+1;9);")";")    ");7))&" шт."


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЕщё идеи пришли в голову:
Код
=СУММПРОИЗВ(-ЛЕВБ(ПОДСТАВИТЬ(ПСТР("(0)"&A2;(ПСТР(A2;СТРОКА($1:97);1)="(")*СТРОКА($3:99)+1;9);")";")    ");7))&" шт."

Автор - Светлый
Дата добавления - 30.06.2020 в 23:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма чисел в скобках из одной ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!