Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула "ЕСЛИ(И)" подставляет только первое значение - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула "ЕСЛИ(И)" подставляет только первое значение (Формулы/Formulas)
Формула "ЕСЛИ(И)" подставляет только первое значение
monja60 Дата: Вторник, 30.06.2020, 10:22 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Добрый день. Почему-то не работает формула =ЕСЛИ(И), нужно, чтобы при совпадении двух параметров (наименование, фамилия) вставляла значение (дата выдачи), работает только с первой строкой диапазона. Пример в прикрепленном файле. Давно не работал, может что-то не так. Подскажите, что? Спасибо!
К сообщению приложен файл: 0622689.xlsx(19.7 Kb)
 
Ответить
СообщениеДобрый день. Почему-то не работает формула =ЕСЛИ(И), нужно, чтобы при совпадении двух параметров (наименование, фамилия) вставляла значение (дата выдачи), работает только с первой строкой диапазона. Пример в прикрепленном файле. Давно не работал, может что-то не так. Подскажите, что? Спасибо!

Автор - monja60
Дата добавления - 30.06.2020 в 10:22
Pelena Дата: Вторник, 30.06.2020, 10:31 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16052
Репутация: 3489 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
А если таких дат несколько?
Для первой даты
массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$4:$A$51;ПОИСКПОЗ(M$3&$B4;Лист2!$B$4:$B$51&Лист2!$J$4:$J$51;0));"")

или простая
Код
=ЕСЛИОШИБКА(АГРЕГАТ(15;6;Лист2!$A$4:$A$51/(M$3=Лист2!$B$4:$B$51)/($B4=Лист2!$J$4:$J$51);1);"")

для последней даты
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(M$3=Лист2!$B$4:$B$51)/($B4=Лист2!$J$4:$J$51);Лист2!$A$4:$A$51);"")
К сообщению приложен файл: 5302199.xlsx(20.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
А если таких дат несколько?
Для первой даты
массивная
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!$A$4:$A$51;ПОИСКПОЗ(M$3&$B4;Лист2!$B$4:$B$51&Лист2!$J$4:$J$51;0));"")

или простая
Код
=ЕСЛИОШИБКА(АГРЕГАТ(15;6;Лист2!$A$4:$A$51/(M$3=Лист2!$B$4:$B$51)/($B4=Лист2!$J$4:$J$51);1);"")

для последней даты
Код
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/(M$3=Лист2!$B$4:$B$51)/($B4=Лист2!$J$4:$J$51);Лист2!$A$4:$A$51);"")

Автор - Pelena
Дата добавления - 30.06.2020 в 10:31
monja60 Дата: Вторник, 30.06.2020, 11:04 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, Спасибо, красивое решение, но немного не то. СУТЬ: это учет сроков выдачи средств защиты пожарным в пожарной части. Срок носки не менее 1 года.Таблицы учета каждый год новые(даты выдачи имущества одного наименования одному лицу повторятся не могут). Нужно отследить сроки следующей выдачи. (ИВАНОВУ-1 параметр выдана ФУТБОЛКА - 2 параметр, ДАТА ВЫДАЧИ - искомое значение (далее через условное форматирование, там все понятно)).
 
Ответить
СообщениеPelena, Спасибо, красивое решение, но немного не то. СУТЬ: это учет сроков выдачи средств защиты пожарным в пожарной части. Срок носки не менее 1 года.Таблицы учета каждый год новые(даты выдачи имущества одного наименования одному лицу повторятся не могут). Нужно отследить сроки следующей выдачи. (ИВАНОВУ-1 параметр выдана ФУТБОЛКА - 2 параметр, ДАТА ВЫДАЧИ - искомое значение (далее через условное форматирование, там все понятно)).

Автор - monja60
Дата добавления - 30.06.2020 в 11:04
monja60 Дата: Вторник, 30.06.2020, 11:06 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
На всякий случай прикреплю весь файл.
К сообщению приложен файл: 7874696.xlsx(169.0 Kb)
 
Ответить
СообщениеНа всякий случай прикреплю весь файл.

Автор - monja60
Дата добавления - 30.06.2020 в 11:06
bigor Дата: Вторник, 30.06.2020, 11:40 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 192
Репутация: 32 ±
Замечаний: 0% ±

Excel 2016
У вас Петров получает футболки и в январе и в феврале, какую, дату вы хотите увидеть?
 
Ответить
СообщениеУ вас Петров получает футболки и в январе и в феврале, какую, дату вы хотите увидеть?

Автор - bigor
Дата добавления - 30.06.2020 в 11:40
monja60 Дата: Вторник, 30.06.2020, 11:52 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Вопрос не в Петрове (мой косяк!). Вопрос: Почему у ИВАНОВА показывает только футболки?!!!
 
Ответить
СообщениеВопрос не в Петрове (мой косяк!). Вопрос: Почему у ИВАНОВА показывает только футболки?!!!

Автор - monja60
Дата добавления - 30.06.2020 в 11:52
bigor Дата: Вторник, 30.06.2020, 12:05 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 192
Репутация: 32 ±
Замечаний: 0% ±

Excel 2016
Потому что нужна формула массива. Или с агрегате мудрить
Попробуйте
Код
=MIN(IF(($Расход.$K$4:$K$499=$Сроки.$B4)*($Расход.$C$4:$C$499=$Сроки.M$3);$Расход.$B$4:$B$499;""))

массивная, правда нужно еще условие на 0, а то некрасиво результат выводит
 
Ответить
СообщениеПотому что нужна формула массива. Или с агрегате мудрить
Попробуйте
Код
=MIN(IF(($Расход.$K$4:$K$499=$Сроки.$B4)*($Расход.$C$4:$C$499=$Сроки.M$3);$Расход.$B$4:$B$499;""))

массивная, правда нужно еще условие на 0, а то некрасиво результат выводит

Автор - bigor
Дата добавления - 30.06.2020 в 12:05
monja60 Дата: Вторник, 30.06.2020, 12:10 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо, буду мудрить дальше...!
 
Ответить
СообщениеСпасибо, буду мудрить дальше...!

Автор - monja60
Дата добавления - 30.06.2020 в 12:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула "ЕСЛИ(И)" подставляет только первое значение (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!