Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка по текстовому критерию с несколькими значениями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по текстовому критерию с несколькими значениями (Формулы/Formulas)
Выборка по текстовому критерию с несколькими значениями
Sozonovas Дата: Воскресенье, 26.07.2020, 17:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, гуру Экселя.
Имеется массив приобретенных ценных бумаг с указанием по каждой бумаге сектора экономики.
Хочу сформировать таблицу со всеми секторами (критерий отбора) с указанием каждого вида купленной бумаги по нему.
Используя ИНДЕКС и ПОИСКПОЗ у меня подставляется первая бумага, отвечающая отбору. Не могу понять, что прописать, чтобы и все последующие бумаги из данного сектора также включались в таблицу.
К сообщению приложен файл: 4022417.xls(32.0 Kb)
 
Ответить
СообщениеЗдравствуйте, гуру Экселя.
Имеется массив приобретенных ценных бумаг с указанием по каждой бумаге сектора экономики.
Хочу сформировать таблицу со всеми секторами (критерий отбора) с указанием каждого вида купленной бумаги по нему.
Используя ИНДЕКС и ПОИСКПОЗ у меня подставляется первая бумага, отвечающая отбору. Не могу понять, что прописать, чтобы и все последующие бумаги из данного сектора также включались в таблицу.

Автор - Sozonovas
Дата добавления - 26.07.2020 в 17:47
Che79 Дата: Воскресенье, 26.07.2020, 18:23 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1595
Репутация: 297 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Здравствуйте. Если допускается немного переделать структуру, то вот такой вариант. Умная таблица на Листе 2 +Выпадающий список в А2 и формула массива (вводится одновременным нажатием Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!B:B;НАИМЕНЬШИЙ(ЕСЛИ(Лист2!E:E=A$2;СТРОКА($A$1:$A$1000));СТРОКА(A1)));"")

В желтой строке на Листе 2 ручная проверка работы таблицы. Можете добавлять данные ниже, они автоматом будут попадать в выпадающий список в A2.
К сообщению приложен файл: 4022417-2.xls(30.0 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте. Если допускается немного переделать структуру, то вот такой вариант. Умная таблица на Листе 2 +Выпадающий список в А2 и формула массива (вводится одновременным нажатием Ctrl+Shift+Enter)
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист2!B:B;НАИМЕНЬШИЙ(ЕСЛИ(Лист2!E:E=A$2;СТРОКА($A$1:$A$1000));СТРОКА(A1)));"")

В желтой строке на Листе 2 ручная проверка работы таблицы. Можете добавлять данные ниже, они автоматом будут попадать в выпадающий список в A2.

Автор - Che79
Дата добавления - 26.07.2020 в 18:23
прохожий2019 Дата: Воскресенье, 26.07.2020, 18:27 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 251
Репутация: 50 ±
Замечаний: 0% ±

365 Current Channel
в 2010 excel можно сводной
К сообщению приложен файл: 4022417-1-.xls(33.5 Kb)
 
Ответить
Сообщениев 2010 excel можно сводной

Автор - прохожий2019
Дата добавления - 26.07.2020 в 18:27
jakim Дата: Воскресенье, 26.07.2020, 18:38 | Сообщение № 4
Группа: Друзья
Ранг: Ветеран
Сообщений: 956
Репутация: 249 ±
Замечаний: 0% ±

Excel 2010
Если у Вас действительно Excel 2010, то предлагаю такую формулу

Код
=IFERROR(INDEX(Лист2!B$3:B$100;AGGREGATE(15;6;ROW($1:$100)/(A$2=Лист2!E$3:E$200);ROWS($3:3)));"")
К сообщению приложен файл: 4022417.xlsx(11.9 Kb)
 
Ответить
Сообщение
Если у Вас действительно Excel 2010, то предлагаю такую формулу

Код
=IFERROR(INDEX(Лист2!B$3:B$100;AGGREGATE(15;6;ROW($1:$100)/(A$2=Лист2!E$3:E$200);ROWS($3:3)));"")

Автор - jakim
Дата добавления - 26.07.2020 в 18:38
Sozonovas Дата: Воскресенье, 26.07.2020, 19:55 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Спасибо всем откликнувшимся, на первый взгляд решение jakim прям то, что нужно. Пошел изучать функции, которые мне не были известны.
Сводной пробовал, но мне не понравилось. Не слишком информативно для глаза получалось.
 
Ответить
СообщениеСпасибо всем откликнувшимся, на первый взгляд решение jakim прям то, что нужно. Пошел изучать функции, которые мне не были известны.
Сводной пробовал, но мне не понравилось. Не слишком информативно для глаза получалось.

Автор - Sozonovas
Дата добавления - 26.07.2020 в 19:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка по текстовому критерию с несколькими значениями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!