Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматическое заполнение дат - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение дат (Формулы/Formulas)
Автоматическое заполнение дат
FoxLord Дата: Среда, 02.09.2020, 06:50 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Приветствую.
Подскажи как правильно оформить заполнение формулой или средствами Excel (по типу в приложении)
Рабочие дни по 7 шт одинаковых ячеек, выходные по две шт одинаковых ячеек.
С прогрессией не совладал.
Спасибо.
К сообщению приложен файл: 3675474.xlsx(12.6 Kb)


Делить на ноль можно, как процесс, но результат непредсказуем.
 
Ответить
СообщениеПриветствую.
Подскажи как правильно оформить заполнение формулой или средствами Excel (по типу в приложении)
Рабочие дни по 7 шт одинаковых ячеек, выходные по две шт одинаковых ячеек.
С прогрессией не совладал.
Спасибо.

Автор - FoxLord
Дата добавления - 02.09.2020 в 06:50
прохожий2019 Дата: Среда, 02.09.2020, 07:40 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 363
Репутация: 61 ±
Замечаний: 0% ±

365 Beta Channel
Код
=B2+ЕСЛИ(ДЕНЬНЕД(B2;2)>5;ЕСЛИ(СЧЁТЕСЛИ($B$1:B2;B2)>1;1;0);ЕСЛИ(СЧЁТЕСЛИ($B$1:B2;B2)>6;1;0))
К сообщению приложен файл: 9668040.xlsx(19.0 Kb)
 
Ответить
Сообщение
Код
=B2+ЕСЛИ(ДЕНЬНЕД(B2;2)>5;ЕСЛИ(СЧЁТЕСЛИ($B$1:B2;B2)>1;1;0);ЕСЛИ(СЧЁТЕСЛИ($B$1:B2;B2)>6;1;0))

Автор - прохожий2019
Дата добавления - 02.09.2020 в 07:40
FoxLord Дата: Среда, 02.09.2020, 09:25 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
прохожий2019,
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$1:B2;B2)>1;1;0);ЕСЛИ(СЧЁТЕСЛИ($B$1:B2;B2)>6;1;0)

Вот в этой части в значениях истины и лжи сравнения с 1 и 6 почему именно они? Я думал всегда будет считать, т.к. больше 1 всегда?
Хочется понять как работает система.
Спасибо.


Делить на ноль можно, как процесс, но результат непредсказуем.

Сообщение отредактировал FoxLord - Среда, 02.09.2020, 09:26
 
Ответить
Сообщениепрохожий2019,
Код
=ЕСЛИ(СЧЁТЕСЛИ($B$1:B2;B2)>1;1;0);ЕСЛИ(СЧЁТЕСЛИ($B$1:B2;B2)>6;1;0)

Вот в этой части в значениях истины и лжи сравнения с 1 и 6 почему именно они? Я думал всегда будет считать, т.к. больше 1 всегда?
Хочется понять как работает система.
Спасибо.

Автор - FoxLord
Дата добавления - 02.09.2020 в 09:25
прохожий2019 Дата: Среда, 02.09.2020, 09:35 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 363
Репутация: 61 ±
Замечаний: 0% ±

365 Beta Channel
Я думал всегда будет считать, т.к. больше 1 всегда?
как это всегда, может же быть =1
там вложенное если - первое проверяет день недели вышестоящей ячейки:
- если выходной - проверяем сколько раз эта дата уже встретилась раз - если >1 (т.е. два и более) то переходим на следующий день
- если рабочий - то же самое, но если >6 (т.е семь и более)
 
Ответить
Сообщение
Я думал всегда будет считать, т.к. больше 1 всегда?
как это всегда, может же быть =1
там вложенное если - первое проверяет день недели вышестоящей ячейки:
- если выходной - проверяем сколько раз эта дата уже встретилась раз - если >1 (т.е. два и более) то переходим на следующий день
- если рабочий - то же самое, но если >6 (т.е семь и более)

Автор - прохожий2019
Дата добавления - 02.09.2020 в 09:35
FoxLord Дата: Среда, 02.09.2020, 10:14 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
прохожий2019, такое озарение снизашло, когда разобрался в работе формулы.
Как Вы создаете такие вещи? Составляете алгоритм в/на голове/бумаге и потом его "оцифровываете" ? Или это просто опыт уже?


Делить на ноль можно, как процесс, но результат непредсказуем.

Сообщение отредактировал FoxLord - Среда, 02.09.2020, 10:15
 
Ответить
Сообщениепрохожий2019, такое озарение снизашло, когда разобрался в работе формулы.
Как Вы создаете такие вещи? Составляете алгоритм в/на голове/бумаге и потом его "оцифровываете" ? Или это просто опыт уже?

Автор - FoxLord
Дата добавления - 02.09.2020 в 10:14
прохожий2019 Дата: Среда, 02.09.2020, 11:54 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 363
Репутация: 61 ±
Замечаний: 0% ±

365 Beta Channel
Как Вы создаете такие вещи?
сложно сказать - в основе формулы должен лежать алгоритм - его можно прикинуть в голове, в сложных ситуациях - на бумаге (почему бы и нет), а дальше перевести на язык формул - просто с опытом это происходит "сразу" :)
 
Ответить
Сообщение
Как Вы создаете такие вещи?
сложно сказать - в основе формулы должен лежать алгоритм - его можно прикинуть в голове, в сложных ситуациях - на бумаге (почему бы и нет), а дальше перевести на язык формул - просто с опытом это происходит "сразу" :)

Автор - прохожий2019
Дата добавления - 02.09.2020 в 11:54
AlexM Дата: Воскресенье, 06.09.2020, 09:22 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4255
Репутация: 1044 ±
Замечаний: 0% ±

Excel 2003
Немного сократил формулу Михаила
Код
=B2+(СЧЁТЕСЛИ(B$1:B2;B2)>1+5*(ДЕНЬНЕД(B2;2)<=5))
или в два раза
Код
=B2+(СЧЁТЕСЛИ(B$1:B2;B2)>1+5*(ОСТАТ(B2;7)>1))



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Воскресенье, 06.09.2020, 09:41
 
Ответить
СообщениеНемного сократил формулу Михаила
Код
=B2+(СЧЁТЕСЛИ(B$1:B2;B2)>1+5*(ДЕНЬНЕД(B2;2)<=5))
или в два раза
Код
=B2+(СЧЁТЕСЛИ(B$1:B2;B2)>1+5*(ОСТАТ(B2;7)>1))

Автор - AlexM
Дата добавления - 06.09.2020 в 09:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматическое заполнение дат (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!