Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/учет перерывов и обедов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » учет перерывов и обедов (Формулы/Formulas)
учет перерывов и обедов
bimka Дата: Суббота, 03.10.2020, 07:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте, есть технологический процесс который разбит на подпроцессы где указаны время начала процесса и время его окончания. некоторые подпроцессы могут попасть на время перерывов или обеда, соответсвенно, на это время перерыва увеличивается и сам подпроцесс. Например, подпроцесс начинается в 8:32 и идет 60 минут и должен заканчиваться в 9:32,но с 9:00 до 9:15 перерыв, и это значит, что подпроцесс идет 60 +15 минут и должен окончиться в 9:47. я сделал формулу, она очень громоздкая и по логике формулы если окончание процесса попадает в интервал перерыва, то время подпроцесса не увеличивается. Как это исправить?

Код
=ЕСЛИ(ИЛИ(И(((C3+D3)<=--"09:00:00");((C3+D3)>=--"09:15:00"));И(((C3)<=--"14:00:00");((C3+D3)>=--"14:15:00"));И(((C3)<=--"22:00:00");((C3+D3)>=--"22:15:00"));И(((C3)>=--"18:00:00");((C3+D3)<=--"18:15:00")));(C3+D3+--"00:15:00");ЕСЛИ(И(C3+D3>=--"20:00:00";C3+D3<=--"20:30:00");C3+D3+--"00:30:00";ЕСЛИ(И(C3+D3>=--"11:00:00";C3+D3<=--"11:45:00");C3+D3+--"00:45:00";(C3+D3))))


где C3 - время начала подпроцесса, D3 - длительность подпроцесса
К сообщению приложен файл: 2019851.xlsx(10.3 Kb)


Сообщение отредактировал bimka - Суббота, 03.10.2020, 08:27
 
Ответить
СообщениеЗдравствуйте, есть технологический процесс который разбит на подпроцессы где указаны время начала процесса и время его окончания. некоторые подпроцессы могут попасть на время перерывов или обеда, соответсвенно, на это время перерыва увеличивается и сам подпроцесс. Например, подпроцесс начинается в 8:32 и идет 60 минут и должен заканчиваться в 9:32,но с 9:00 до 9:15 перерыв, и это значит, что подпроцесс идет 60 +15 минут и должен окончиться в 9:47. я сделал формулу, она очень громоздкая и по логике формулы если окончание процесса попадает в интервал перерыва, то время подпроцесса не увеличивается. Как это исправить?

Код
=ЕСЛИ(ИЛИ(И(((C3+D3)<=--"09:00:00");((C3+D3)>=--"09:15:00"));И(((C3)<=--"14:00:00");((C3+D3)>=--"14:15:00"));И(((C3)<=--"22:00:00");((C3+D3)>=--"22:15:00"));И(((C3)>=--"18:00:00");((C3+D3)<=--"18:15:00")));(C3+D3+--"00:15:00");ЕСЛИ(И(C3+D3>=--"20:00:00";C3+D3<=--"20:30:00");C3+D3+--"00:30:00";ЕСЛИ(И(C3+D3>=--"11:00:00";C3+D3<=--"11:45:00");C3+D3+--"00:45:00";(C3+D3))))


где C3 - время начала подпроцесса, D3 - длительность подпроцесса

Автор - bimka
Дата добавления - 03.10.2020 в 07:18
Pelena Дата: Суббота, 03.10.2020, 08:55 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 16641
Репутация: 3598 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Технологический процесс круглосуточный с шестью перерывами, так?
Допускается в отдельном диапазоне прописать время перерывов?

==============
Ответа не дождалась. Посмотрите такой вариант. Обратите внимание также на формулы в других столбцах
К сообщению приложен файл: 5706882.xlsx(12.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеТехнологический процесс круглосуточный с шестью перерывами, так?
Допускается в отдельном диапазоне прописать время перерывов?

==============
Ответа не дождалась. Посмотрите такой вариант. Обратите внимание также на формулы в других столбцах

Автор - Pelena
Дата добавления - 03.10.2020 в 08:55
bimka Дата: Суббота, 03.10.2020, 11:08 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Pelena, Спасибо, то что надо.
Надо еще посидеть обмозговать формулу на будущее
 
Ответить
СообщениеPelena, Спасибо, то что надо.
Надо еще посидеть обмозговать формулу на будущее

Автор - bimka
Дата добавления - 03.10.2020 в 11:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » учет перерывов и обедов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!