Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/извлечь данные на другой лист по критерию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » извлечь данные на другой лист по критерию (Формулы/Formulas)
извлечь данные на другой лист по критерию
Shakal07 Дата: Четверг, 08.10.2020, 11:08 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Excel 2k3;2k7;2k10;2k13;2k19
Здравствуйте

Есть таблица со всеми студентами
Надо из нее извлечь список студентов по критерию на другой лист
Критерий данные колонки "Проживает в горной местности" листа "Вступ"
если учащийся проживает в горной местности он должен отобразится на листе "Список"
Надо из листа "Вступ" извлечь ФИО студентов на лист "Список"
Надо чтобы все было автоматизировано. Если на лист "Вступ" добавятся
учащиеся они должны автоматически подтянутся на лист "Список"

С уважением,
К сообщению приложен файл: 6746557.xlsx(18.4 Kb)


Сообщение отредактировал Shakal07 - Четверг, 08.10.2020, 11:08
 
Ответить
СообщениеЗдравствуйте

Есть таблица со всеми студентами
Надо из нее извлечь список студентов по критерию на другой лист
Критерий данные колонки "Проживает в горной местности" листа "Вступ"
если учащийся проживает в горной местности он должен отобразится на листе "Список"
Надо из листа "Вступ" извлечь ФИО студентов на лист "Список"
Надо чтобы все было автоматизировано. Если на лист "Вступ" добавятся
учащиеся они должны автоматически подтянутся на лист "Список"

С уважением,

Автор - Shakal07
Дата добавления - 08.10.2020 в 11:08
Che79 Дата: Четверг, 08.10.2020, 12:00 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1629
Репутация: 301 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Здравствуйте.
Как вариант, для версии 2003 - формула массива (вводится Ctrl+Shift+Enter) - вдруг правильно? (с)
Код
=ЕСЛИ(ЕОШИБКА(ИНДЕКС(Вступ!$A$2:$L$100;НАИМЕНЬШИЙ(ЕСЛИ(Вступ!$G$2:$G$100="да";СТРОКА(Вступ!$A$2:$A$100)-1);СТРОКА(A1));ПОИСКПОЗ(A$1;Вступ!$A$1:$L$1;)));"";ИНДЕКС(Вступ!$A$2:$L$100;НАИМЕНЬШИЙ(ЕСЛИ(Вступ!$G$2:$G$100="да";СТРОКА(Вступ!$A$2:$A$100)-1);СТРОКА(A1));ПОИСКПОЗ(A$1;Вступ!$A$1:$L$1;)))
Только проверьте идентичность написания заголовков столбцов "Группа" и "Документ" на обоих листах, иначе выдаст ошибки на выходе
К сообщению приложен файл: 6746557-1.xlsx(20.2 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте.
Как вариант, для версии 2003 - формула массива (вводится Ctrl+Shift+Enter) - вдруг правильно? (с)
Код
=ЕСЛИ(ЕОШИБКА(ИНДЕКС(Вступ!$A$2:$L$100;НАИМЕНЬШИЙ(ЕСЛИ(Вступ!$G$2:$G$100="да";СТРОКА(Вступ!$A$2:$A$100)-1);СТРОКА(A1));ПОИСКПОЗ(A$1;Вступ!$A$1:$L$1;)));"";ИНДЕКС(Вступ!$A$2:$L$100;НАИМЕНЬШИЙ(ЕСЛИ(Вступ!$G$2:$G$100="да";СТРОКА(Вступ!$A$2:$A$100)-1);СТРОКА(A1));ПОИСКПОЗ(A$1;Вступ!$A$1:$L$1;)))
Только проверьте идентичность написания заголовков столбцов "Группа" и "Документ" на обоих листах, иначе выдаст ошибки на выходе

Автор - Che79
Дата добавления - 08.10.2020 в 12:00
alexa1965 Дата: Четверг, 08.10.2020, 12:16 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 196
Репутация: 11 ±
Замечаний: 0% ±

2003> 2010> 2016
Код
=ИНДЕКС(Вступ!B$1:B$500;НАИМЕНЬШИЙ(ЕСЛИ(Вступ[Проживает в горной местности]="да";СТРОКА(Вступ[Проживает в горной местности]);500);СТРОКА(A1)))&""

Как вариант, тоже массивная


Главное не быть балабастиком

Сообщение отредактировал alexa1965 - Четверг, 08.10.2020, 12:27
 
Ответить
Сообщение
Код
=ИНДЕКС(Вступ!B$1:B$500;НАИМЕНЬШИЙ(ЕСЛИ(Вступ[Проживает в горной местности]="да";СТРОКА(Вступ[Проживает в горной местности]);500);СТРОКА(A1)))&""

Как вариант, тоже массивная

Автор - alexa1965
Дата добавления - 08.10.2020 в 12:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » извлечь данные на другой лист по критерию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!