Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/подсчёт по месяцу и фамелии, по 2 разным условиям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчёт по месяцу и фамелии, по 2 разным условиям (Формулы/Formulas)
подсчёт по месяцу и фамелии, по 2 разным условиям
vitek73 Дата: Среда, 14.10.2020, 19:20 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
День добрый,
при подсчёте месяца, формула цепляется к конкретному дню, хотя в ячейки ставил отображать только месяц,
получается вместо поиска месяца, вручную определяю диапазон, а уже по слову идёт поиск,
в идеале хотел добиться, Чтоб при указании нужного месяца и нужной фамилии, шёл подсчёт, но пока никак, (
К сообщению приложен файл: EXPORT_141020.xlsx(15.3 Kb)


vitёk73
 
Ответить
СообщениеДень добрый,
при подсчёте месяца, формула цепляется к конкретному дню, хотя в ячейки ставил отображать только месяц,
получается вместо поиска месяца, вручную определяю диапазон, а уже по слову идёт поиск,
в идеале хотел добиться, Чтоб при указании нужного месяца и нужной фамилии, шёл подсчёт, но пока никак, (

Автор - vitek73
Дата добавления - 14.10.2020 в 19:20
Che79 Дата: Среда, 14.10.2020, 20:03 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1638
Репутация: 303 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Добрый день.
Если правильно понял)
В случае, если год не важен, то можно так
Код
=СУММПРОИЗВ((C2:C1000=J2)*(МЕСЯЦ(A2:A1000)=(ПОИСК(ПСТР(L2;2;2);"нвеварпрайюнюлвгенктояек")+1)/2))
Результат в синей ячейке (в желтой - месяцы текстом в виде выпадающего списка)
Если важен и год и квартал, то вариант сводной таблицей

vitek73 задавая на форуме вопрос, о кроссе принято сообщать заранее
К сообщению приложен файл: EXPORT_141020_1.xlsx(25.3 Kb)


Делай нормально и будет нормально!

Сообщение отредактировал Che79 - Среда, 14.10.2020, 22:34
 
Ответить
СообщениеДобрый день.
Если правильно понял)
В случае, если год не важен, то можно так
Код
=СУММПРОИЗВ((C2:C1000=J2)*(МЕСЯЦ(A2:A1000)=(ПОИСК(ПСТР(L2;2;2);"нвеварпрайюнюлвгенктояек")+1)/2))
Результат в синей ячейке (в желтой - месяцы текстом в виде выпадающего списка)
Если важен и год и квартал, то вариант сводной таблицей

vitek73 задавая на форуме вопрос, о кроссе принято сообщать заранее

Автор - Che79
Дата добавления - 14.10.2020 в 20:03
vitek73 Дата: Среда, 14.10.2020, 23:14 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 53
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
vitek73 задавая на форуме вопрос, о кроссе принято сообщать заранее

спасибо, буду знать)
, за пример спасибо ;-)


vitёk73
 
Ответить
Сообщение
vitek73 задавая на форуме вопрос, о кроссе принято сообщать заранее

спасибо, буду знать)
, за пример спасибо ;-)

Автор - vitek73
Дата добавления - 14.10.2020 в 23:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » подсчёт по месяцу и фамелии, по 2 разным условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!