Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Динамическая двухуровневая сортировка по дате от минимальной - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Динамическая двухуровневая сортировка по дате от минимальной (Формулы/Formulas)
Динамическая двухуровневая сортировка по дате от минимальной
Mazarthatun Дата: Воскресенье, 08.11.2020, 18:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем добрый!
Задача из списка задач с датами сделать сортировку по ближайшей дате, причем нужно учитывать, что на одну дату может приходиться несколько задач. При этом нулевые строки нужно убрать.
С первой частью справился, но вторую пока победить не могу.

Заранее всем огромное спасибо за помощь!
К сообщению приложен файл: 2020_11__.xlsx(29.1 Kb)
 
Ответить
СообщениеВсем добрый!
Задача из списка задач с датами сделать сортировку по ближайшей дате, причем нужно учитывать, что на одну дату может приходиться несколько задач. При этом нулевые строки нужно убрать.
С первой частью справился, но вторую пока победить не могу.

Заранее всем огромное спасибо за помощь!

Автор - Mazarthatun
Дата добавления - 08.11.2020 в 18:35
gling Дата: Воскресенье, 08.11.2020, 20:27 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2194
Репутация: 545 ±
Замечаний: 0% ±

2010
Здравствуйте.
А сводная таблица не устроит?
К сообщению приложен файл: 2020_11_.xlsx(34.7 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
А сводная таблица не устроит?

Автор - gling
Дата добавления - 08.11.2020 в 20:27
Mazarthatun Дата: Воскресенье, 08.11.2020, 20:54 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
К сожалению, в данном случае нет. Нужно докрутить сортировку, чтобы просто не было в начале пустых строк.
 
Ответить
СообщениеК сожалению, в данном случае нет. Нужно докрутить сортировку, чтобы просто не было в начале пустых строк.

Автор - Mazarthatun
Дата добавления - 08.11.2020 в 20:54
gling Дата: Воскресенье, 08.11.2020, 21:13 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2194
Репутация: 545 ±
Замечаний: 0% ±

2010
Ну если только формулами, тогда еще вариант с динамическими диапазонами "Задача" и Дедлайн", в диспетчере имен.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Задача;ПОИСКПОЗ(НАИМЕНЬШИЙ(Дедлайн+СТРОКА(Дедлайн)%%%;СТРОКА(A1));Дедлайн+СТРОКА(Дедлайн)%%%;0));"")
К сообщению приложен файл: 7305231.xlsx(33.9 Kb)


ЯД-41001506838083

Сообщение отредактировал gling - Воскресенье, 08.11.2020, 21:16
 
Ответить
СообщениеНу если только формулами, тогда еще вариант с динамическими диапазонами "Задача" и Дедлайн", в диспетчере имен.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Задача;ПОИСКПОЗ(НАИМЕНЬШИЙ(Дедлайн+СТРОКА(Дедлайн)%%%;СТРОКА(A1));Дедлайн+СТРОКА(Дедлайн)%%%;0));"")

Автор - gling
Дата добавления - 08.11.2020 в 21:13
Mazarthatun Дата: Воскресенье, 08.11.2020, 21:16 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Уже близко, но в каждой строчке нужна дата.
Нужно примерно как здесь, но уже ума не хватает: https://excel2.ru/article....s-excel


Сообщение отредактировал Mazarthatun - Воскресенье, 08.11.2020, 21:18
 
Ответить
СообщениеУже близко, но в каждой строчке нужна дата.
Нужно примерно как здесь, но уже ума не хватает: https://excel2.ru/article....s-excel

Автор - Mazarthatun
Дата добавления - 08.11.2020 в 21:16
gling Дата: Воскресенье, 08.11.2020, 21:21 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2194
Репутация: 545 ±
Замечаний: 0% ±

2010
но в каждой строчке нужна дата
Что то я не понял. Измененные формулы в столбцах F и G, а с пропусками дат в строке это сводная таблица. В столбцах I и J располагается сводная таблица которая вас не устроила. В каком столбце пропуски дат?


ЯД-41001506838083

Сообщение отредактировал gling - Воскресенье, 08.11.2020, 21:26
 
Ответить
Сообщение
но в каждой строчке нужна дата
Что то я не понял. Измененные формулы в столбцах F и G, а с пропусками дат в строке это сводная таблица. В столбцах I и J располагается сводная таблица которая вас не устроила. В каком столбце пропуски дат?

Автор - gling
Дата добавления - 08.11.2020 в 21:21
Mazarthatun Дата: Понедельник, 09.11.2020, 05:32 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Ой, все супер!!!! Это я уже от борьбы с формулами пропустил. СПАСИБО!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 
Ответить
СообщениеОй, все супер!!!! Это я уже от борьбы с формулами пропустил. СПАСИБО!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Автор - Mazarthatun
Дата добавления - 09.11.2020 в 05:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Динамическая двухуровневая сортировка по дате от минимальной (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!