Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск позиции и подстановка из таблицы - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск позиции и подстановка из таблицы (Формулы/Formulas)
Поиск позиции и подстановка из таблицы
GP75 Дата: Понедельник, 16.11.2020, 22:59 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте. Занялся тут земляными работами и понял, что расчет грунта можно упростить в excel. Но так как руки растут из ж, подобрать формулу для получения автоматического результата не получается. Видимо нужна комбинация функций ПОИСКПОЗ и ВПР. А как их соединить не понимаю. Подробнее проблема в прикреплении .
К сообщению приложен файл: 9076493.xls(28.0 Kb)
 
Ответить
СообщениеЗдравствуйте. Занялся тут земляными работами и понял, что расчет грунта можно упростить в excel. Но так как руки растут из ж, подобрать формулу для получения автоматического результата не получается. Видимо нужна комбинация функций ПОИСКПОЗ и ВПР. А как их соединить не понимаю. Подробнее проблема в прикреплении .

Автор - GP75
Дата добавления - 16.11.2020 в 22:59
bigor Дата: Понедельник, 16.11.2020, 23:59 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 331
Репутация: 62 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер

Как вариант. Что бы не усложнять переписал название диапазона 0,00-1,5
Код
=INDEX(F7:H11;MATCH(B1;D7:D11;0);SMALL(IF((--LEFT(F6:H6;4)<=B2)*(--RIGHT(F6:H6;3)>=B2);COLUMN(F6:H6);"");1)-5)
 
Ответить
СообщениеДобрый вечер

Как вариант. Что бы не усложнять переписал название диапазона 0,00-1,5
Код
=INDEX(F7:H11;MATCH(B1;D7:D11;0);SMALL(IF((--LEFT(F6:H6;4)<=B2)*(--RIGHT(F6:H6;3)>=B2);COLUMN(F6:H6);"");1)-5)

Автор - bigor
Дата добавления - 16.11.2020 в 23:59
Che79 Дата: Вторник, 17.11.2020, 00:09 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1638
Репутация: 303 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Здравствуйте.
Что бы не усложнять
переделал таблицу :D
Код
=ЕСЛИОШИБКА(ИНДЕКС(E7:G11;ПОИСКПОЗ(B1;D7:D11;);ПОИСКПОЗ(B2;E6:G6));)
К сообщению приложен файл: 9076493-1.xlsx(10.0 Kb)


Делай нормально и будет нормально!
 
Ответить
СообщениеЗдравствуйте.
Что бы не усложнять
переделал таблицу :D
Код
=ЕСЛИОШИБКА(ИНДЕКС(E7:G11;ПОИСКПОЗ(B1;D7:D11;);ПОИСКПОЗ(B2;E6:G6));)

Автор - Che79
Дата добавления - 17.11.2020 в 00:09
GP75 Дата: Вторник, 17.11.2020, 00:26 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо за участие и помощь товарищи. Премного благодарствую. Удачи!
 
Ответить
СообщениеСпасибо за участие и помощь товарищи. Премного благодарствую. Удачи!

Автор - GP75
Дата добавления - 17.11.2020 в 00:26
Serge_007 Дата: Вторник, 17.11.2020, 00:50 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 13348
Репутация: ±
Замечаний: ±

Excel 2010
переделал таблицу
Без переделки :D
Код
=ИНДЕКС(F7:H11;ПОИСКПОЗ(B1;D7:D11;0);ПОИСКПОЗ(B2;(СТОЛБЕЦ(A1:C1)-1)*1,5+0,01))
К сообщению приложен файл: GP75.xls(29.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
переделал таблицу
Без переделки :D
Код
=ИНДЕКС(F7:H11;ПОИСКПОЗ(B1;D7:D11;0);ПОИСКПОЗ(B2;(СТОЛБЕЦ(A1:C1)-1)*1,5+0,01))

Автор - Serge_007
Дата добавления - 17.11.2020 в 00:50
GP75 Дата: Вторник, 17.11.2020, 00:51 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
переделал таблицу

Скопировал формулы в свой расчёт. Почему в искомой ячейке (отмечена красным) не появляется результат? Может дела в текстовом условии?
К сообщению приложен файл: _2.xls(39.0 Kb)
 
Ответить
Сообщение
переделал таблицу

Скопировал формулы в свой расчёт. Почему в искомой ячейке (отмечена красным) не появляется результат? Может дела в текстовом условии?

Автор - GP75
Дата добавления - 17.11.2020 в 00:51
Serge_007 Дата: Вторник, 17.11.2020, 00:59 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 13348
Репутация: ±
Замечаний: ±

Excel 2010
Почему в искомой ячейке (отмечена красным) не появляется результат?
Вот тут точку с запятой убрать надо:
...N9:P9;);...


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Почему в искомой ячейке (отмечена красным) не появляется результат?
Вот тут точку с запятой убрать надо:
...N9:P9;);...

Автор - Serge_007
Дата добавления - 17.11.2020 в 00:59
Serge_007 Дата: Вторник, 17.11.2020, 01:05 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 13348
Репутация: ±
Замечаний: ±

Excel 2010
И ещё

Вы местами два ПОИСКПОЗ перепутали
Так правильно:
Код
=ЕСЛИОШИБКА(ИНДЕКС(N10:P14;ПОИСКПОЗ(B15;M10:M14;);ПОИСКПОЗ(B19;N9:P9));)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеИ ещё

Вы местами два ПОИСКПОЗ перепутали
Так правильно:
Код
=ЕСЛИОШИБКА(ИНДЕКС(N10:P14;ПОИСКПОЗ(B15;M10:M14;);ПОИСКПОЗ(B19;N9:P9));)

Автор - Serge_007
Дата добавления - 17.11.2020 в 01:05
Che79 Дата: Вторник, 17.11.2020, 01:08 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1638
Репутация: 303 ±
Замечаний: 0% ±

2013 Win, 365 Mac
Скопировал формулы
и перепутали строки со столбцами. Вот так посмотрите
Код
=ЕСЛИОШИБКА(ИНДЕКС(N10:P14;ПОИСКПОЗ(B15;M10:M14;);ПОИСКПОЗ(B19;N9:P9));)
К сообщению приложен файл: _2_.xlsx(15.2 Kb)


Делай нормально и будет нормально!
 
Ответить
Сообщение
Скопировал формулы
и перепутали строки со столбцами. Вот так посмотрите
Код
=ЕСЛИОШИБКА(ИНДЕКС(N10:P14;ПОИСКПОЗ(B15;M10:M14;);ПОИСКПОЗ(B19;N9:P9));)

Автор - Che79
Дата добавления - 17.11.2020 в 01:08
Serge_007 Дата: Вторник, 17.11.2020, 01:12 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 13348
Репутация: ±
Замечаний: ±

Excel 2010
Вы местами два ПОИСКПОЗ перепутали

и перепутали строки со столбцами
:D :D :D


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Вы местами два ПОИСКПОЗ перепутали

и перепутали строки со столбцами
:D :D :D

Автор - Serge_007
Дата добавления - 17.11.2020 в 01:12
GP75 Дата: Вторник, 17.11.2020, 01:44 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Спасибо всем искреннее от души. Буду пррробывать!
 
Ответить
СообщениеСпасибо всем искреннее от души. Буду пррробывать!

Автор - GP75
Дата добавления - 17.11.2020 в 01:44
GP75 Дата: Суббота, 21.11.2020, 22:44 | Сообщение № 12
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Функция "еслиошибка" я так понимаю не работает в 2003 excele, что пишет при сохранении А есть ли какие альтернативные формулы , которые прнимет 2003 версия по поиску диапазона в таблице?


Сообщение отредактировал GP75 - Суббота, 21.11.2020, 22:45
 
Ответить
СообщениеФункция "еслиошибка" я так понимаю не работает в 2003 excele, что пишет при сохранении А есть ли какие альтернативные формулы , которые прнимет 2003 версия по поиску диапазона в таблице?

Автор - GP75
Дата добавления - 21.11.2020 в 22:44
Pelena Дата: Суббота, 21.11.2020, 23:31 | Сообщение № 13
Группа: Админы
Ранг: Местный житель
Сообщений: 16766
Репутация: 3619 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
в 2003 excel
будет немного длиннее
Код
=ЕСЛИ(ЕОШИБКА(ИНДЕКС(N10:P14;ПОИСКПОЗ(B15;M10:M14;);ПОИСКПОЗ(B19;N9:P9)));"";ИНДЕКС(N10:P14;ПОИСКПОЗ(B15;M10:M14;);ПОИСКПОЗ(B19;N9:P9)))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
в 2003 excel
будет немного длиннее
Код
=ЕСЛИ(ЕОШИБКА(ИНДЕКС(N10:P14;ПОИСКПОЗ(B15;M10:M14;);ПОИСКПОЗ(B19;N9:P9)));"";ИНДЕКС(N10:P14;ПОИСКПОЗ(B15;M10:M14;);ПОИСКПОЗ(B19;N9:P9)))

Автор - Pelena
Дата добавления - 21.11.2020 в 23:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск позиции и подстановка из таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

jooble Яндекс цитирования
© 2010-2020 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!