Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определение квадратов сетки по координатам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение квадратов сетки по координатам (Формулы/Formulas)
Определение квадратов сетки по координатам
Nikitasergeevitsch Дата: Понедельник, 14.12.2020, 09:09 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Здравствуйте многоуважаемые знатоки!
Очень нуждаюсь в Вашей помощи...
Занимаюсь археологией, на данный момент пишем отчёт о проведенных раскопках.

Ситуация следующая:
- Имеется список координат находок (X,Y)
- Имеется сетка квадратов раскопа (Квадраты 2*2 метра)
- Имеются границы сетки в файле эксель

Необходимо сделать так, чтобы в списке координат находок в отдельном столбце\столбцах была показана принадлежность определенной точки к квадрату раскопа (например точка 4747 - квадрат Л-49)
Заранее очень всем благодарен за помощь...
Файлы прикрепляю...
К сообщению приложен файл: ___.zip(60.8 Kb)
 
Ответить
СообщениеЗдравствуйте многоуважаемые знатоки!
Очень нуждаюсь в Вашей помощи...
Занимаюсь археологией, на данный момент пишем отчёт о проведенных раскопках.

Ситуация следующая:
- Имеется список координат находок (X,Y)
- Имеется сетка квадратов раскопа (Квадраты 2*2 метра)
- Имеются границы сетки в файле эксель

Необходимо сделать так, чтобы в списке координат находок в отдельном столбце\столбцах была показана принадлежность определенной точки к квадрату раскопа (например точка 4747 - квадрат Л-49)
Заранее очень всем благодарен за помощь...
Файлы прикрепляю...

Автор - Nikitasergeevitsch
Дата добавления - 14.12.2020 в 09:09
bigor Дата: Понедельник, 14.12.2020, 09:42 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 399
Репутация: 71 ±
Замечаний: 0% ±

Excel 2016
Добрый день.

Если правильно понял
Код
=LOOKUP(C3;$Лист2.$C$3:$C$41;$Лист2.$A$3:$A$41)&" "&LOOKUP(D3;$Лист2.$g$3:$g$24;$Лист2.$F$3:$F$24)
, но с Вашим примером
Цитата Nikitasergeevitsch, 14.12.2020 в 09:09, в сообщении № 1 ()
(например точка 4747 - квадрат Л-49)
не совпадает.

ps подправил диапазон
К сообщению приложен файл: __leica.xlsx(12.4 Kb)


Сообщение отредактировал bigor - Понедельник, 14.12.2020, 09:51
 
Ответить
СообщениеДобрый день.

Если правильно понял
Код
=LOOKUP(C3;$Лист2.$C$3:$C$41;$Лист2.$A$3:$A$41)&" "&LOOKUP(D3;$Лист2.$g$3:$g$24;$Лист2.$F$3:$F$24)
, но с Вашим примером
Цитата Nikitasergeevitsch, 14.12.2020 в 09:09, в сообщении № 1 ()
(например точка 4747 - квадрат Л-49)
не совпадает.

ps подправил диапазон

Автор - bigor
Дата добавления - 14.12.2020 в 09:42
bmv98rus Дата: Понедельник, 14.12.2020, 09:44 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3415
Репутация: 594 ±
Замечаний: 0% ±

Excel 2013/2016


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениекросс

Автор - bmv98rus
Дата добавления - 14.12.2020 в 09:44
Nikitasergeevitsch Дата: Понедельник, 14.12.2020, 09:49 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Ну я это сделал как пример, не смотрел где именно находится эта точка...
Дело в том, что находок около 15 тысяч, и обрабатывать это вручную, выгружая эти точки в автокад - то ещё занятие.
Да и на будущее эта формула очень необходима, для других раскопов...
 
Ответить
СообщениеНу я это сделал как пример, не смотрел где именно находится эта точка...
Дело в том, что находок около 15 тысяч, и обрабатывать это вручную, выгружая эти точки в автокад - то ещё занятие.
Да и на будущее эта формула очень необходима, для других раскопов...

Автор - Nikitasergeevitsch
Дата добавления - 14.12.2020 в 09:49
Kostya_Ye Дата: Понедельник, 14.12.2020, 09:55 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 225
Репутация: 219 ±
Замечаний: 0% ±

Excel 2016
Nikitasergeevitsch,
еще вариант, с учетом направления сортировки исходного массива сетки
Код
=ИНДЕКС( '[Список координат От До Буквы Цифры.xlsx]Лист1'!$A$3:$A$41; ПОИСКПОЗ(C3;'[Список координат От До Буквы Цифры.xlsx]Лист1'!$B$3:$B$41;-1)) & "-" & ИНДЕКС('[Список координат От До Буквы Цифры.xlsx]Лист1'!$F$3:$F$24; ПОИСКПОЗ(D3; '[Список координат От До Буквы Цифры.xlsx]Лист1'!$G$3:$G$24; 1))


Сообщение отредактировал Kostya_Ye - Понедельник, 14.12.2020, 09:56
 
Ответить
СообщениеNikitasergeevitsch,
еще вариант, с учетом направления сортировки исходного массива сетки
Код
=ИНДЕКС( '[Список координат От До Буквы Цифры.xlsx]Лист1'!$A$3:$A$41; ПОИСКПОЗ(C3;'[Список координат От До Буквы Цифры.xlsx]Лист1'!$B$3:$B$41;-1)) & "-" & ИНДЕКС('[Список координат От До Буквы Цифры.xlsx]Лист1'!$F$3:$F$24; ПОИСКПОЗ(D3; '[Список координат От До Буквы Цифры.xlsx]Лист1'!$G$3:$G$24; 1))

Автор - Kostya_Ye
Дата добавления - 14.12.2020 в 09:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определение квадратов сетки по координатам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!