Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка в ячейку цифры из числа - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка в ячейку цифры из числа (Формулы/Formulas)
Подстановка в ячейку цифры из числа
fobospk85 Дата: Среда, 30.12.2020, 04:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Доброго дня!
Есть определенная форма отчета, где необходимо что бы цифры числа располагались в каждой отдельной ячейке. Число должно быть в двумя знаками после запятой.
И все вроде работает! но если число заканчивается на ноль "0", допустим 1,10, то эксель его видит как 1,1 и вместо "0" ничего не ставит. Это не корректно и нужно что бы ставился нолик.
В общих чертах формула выглядит так:
Код
=ЕСЛИОШИБКА(ПСТР($N7;ДЛСТР($N7);1);" ")
ну только ячеек больше.
Подскажите есть ли какое-нибудь решение проблемы?
К сообщению приложен файл: File_01.xls(32.0 Kb)
 
Ответить
СообщениеДоброго дня!
Есть определенная форма отчета, где необходимо что бы цифры числа располагались в каждой отдельной ячейке. Число должно быть в двумя знаками после запятой.
И все вроде работает! но если число заканчивается на ноль "0", допустим 1,10, то эксель его видит как 1,1 и вместо "0" ничего не ставит. Это не корректно и нужно что бы ставился нолик.
В общих чертах формула выглядит так:
Код
=ЕСЛИОШИБКА(ПСТР($N7;ДЛСТР($N7);1);" ")
ну только ячеек больше.
Подскажите есть ли какое-нибудь решение проблемы?

Автор - fobospk85
Дата добавления - 30.12.2020 в 04:00
bmv98rus Дата: Среда, 30.12.2020, 07:44 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3418
Репутация: 594 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=IFERROR(MID($N7,LEN(TEXT($N7,0,00"),1)," ")


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=IFERROR(MID($N7,LEN(TEXT($N7,0,00"),1)," ")

Автор - bmv98rus
Дата добавления - 30.12.2020 в 07:44
fobospk85 Дата: Среда, 30.12.2020, 08:51 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

ну во-первых в Вашей формуле не хватает еще одной скобки, и кавычек. Поправил так:
Код
=ЕСЛИОШИБКА(ПСТР($DF21;ДЛСТР(ТЕКСТ($DF21;"0,00"))-0;1);" ")
А во-вторых ничего не изменилось.
Если в конце стоит "0", то ячейка пустая.
 
Ответить
Сообщениену во-первых в Вашей формуле не хватает еще одной скобки, и кавычек. Поправил так:
Код
=ЕСЛИОШИБКА(ПСТР($DF21;ДЛСТР(ТЕКСТ($DF21;"0,00"))-0;1);" ")
А во-вторых ничего не изменилось.
Если в конце стоит "0", то ячейка пустая.

Автор - fobospk85
Дата добавления - 30.12.2020 в 08:51
Serge_007 Дата: Среда, 30.12.2020, 09:23 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13730
Репутация: 2304 ±
Замечаний: ±

Excel 2010
Здравствуйте

Код
=ЕСЛИОШИБКА(ПСТР(ТЕКСТ($N7;"0,00");ДЛСТР(ТЕКСТ($N7;"0,00"))-(12-СТОЛБЕЦ());1);"")
К сообщению приложен файл: 20201230_fobosp.xls(33.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ЕСЛИОШИБКА(ПСТР(ТЕКСТ($N7;"0,00");ДЛСТР(ТЕКСТ($N7;"0,00"))-(12-СТОЛБЕЦ());1);"")

Автор - Serge_007
Дата добавления - 30.12.2020 в 09:23
fobospk85 Дата: Четверг, 31.12.2020, 11:03 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Цитата
Здравствуйте

С наступающим Вас ))
воспользовался Вашей формулой
Код
=ЕСЛИОШИБКА(ПСТР(ТЕКСТ($N7;"0,00");ДЛСТР(ТЕКСТ($N7;"0,00"))-(12-СТОЛБЕЦ());1);"")

однако, при попытке скопировать ее в другой файл опять ничего не получается.
что означает (12-СТОЛБЕЦ()) ??
если я заменяю на другой столбец (ну 81-83 объединенная ячейка) уже все сбивается. связано ли это с тем, что нужная ячейка объединена из 3х столбцов?
К сообщению приложен файл: 011.xls(41.0 Kb)
 
Ответить
Сообщение
Цитата
Здравствуйте

С наступающим Вас ))
воспользовался Вашей формулой
Код
=ЕСЛИОШИБКА(ПСТР(ТЕКСТ($N7;"0,00");ДЛСТР(ТЕКСТ($N7;"0,00"))-(12-СТОЛБЕЦ());1);"")

однако, при попытке скопировать ее в другой файл опять ничего не получается.
что означает (12-СТОЛБЕЦ()) ??
если я заменяю на другой столбец (ну 81-83 объединенная ячейка) уже все сбивается. связано ли это с тем, что нужная ячейка объединена из 3х столбцов?

Автор - fobospk85
Дата добавления - 31.12.2020 в 11:03
Serge_007 Дата: Четверг, 31.12.2020, 11:17 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 13730
Репутация: 2304 ±
Замечаний: ±

Excel 2010
И Вас с наступающим!

что означает (12-СТОЛБЕЦ()) ?
Это означает что из 12-и вычитается номер столбца, в котором находится формула


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеИ Вас с наступающим!

что означает (12-СТОЛБЕЦ()) ?
Это означает что из 12-и вычитается номер столбца, в котором находится формула

Автор - Serge_007
Дата добавления - 31.12.2020 в 11:17
Serge_007 Дата: Четверг, 31.12.2020, 11:17 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 13730
Репутация: 2304 ±
Замечаний: ±

Excel 2010
связано ли это с тем, что нужная ячейка объединена из 3х столбцов?
Нет)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
связано ли это с тем, что нужная ячейка объединена из 3х столбцов?
Нет)

Автор - Serge_007
Дата добавления - 31.12.2020 в 11:17
Pelena Дата: Четверг, 31.12.2020, 13:09 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 17271
Репутация: 3824 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
нужная ячейка объединена из 3х столбцов
не из трёх, а из двух, поэтому в Вашей формуле 83-СТОЛБЕЦ() делим на 2
Код
=ЕСЛИОШИБКА(ПСТР(ТЕКСТ($DA23;"0,00");ДЛСТР(ТЕКСТ($DA23;"0,00"))-((83-СТОЛБЕЦ())/2);1);"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
нужная ячейка объединена из 3х столбцов
не из трёх, а из двух, поэтому в Вашей формуле 83-СТОЛБЕЦ() делим на 2
Код
=ЕСЛИОШИБКА(ПСТР(ТЕКСТ($DA23;"0,00");ДЛСТР(ТЕКСТ($DA23;"0,00"))-((83-СТОЛБЕЦ())/2);1);"")

Автор - Pelena
Дата добавления - 31.12.2020 в 13:09
fobospk85 Дата: Пятница, 01.01.2021, 12:02 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Цитата
не из трёх, а из двух, поэтому в Вашей формуле 83-СТОЛБЕЦ() делим на 2

Большое спасибо! Теперь все отлично работает!
 
Ответить
Сообщение
Цитата
не из трёх, а из двух, поэтому в Вашей формуле 83-СТОЛБЕЦ() делим на 2

Большое спасибо! Теперь все отлично работает!

Автор - fobospk85
Дата добавления - 01.01.2021 в 12:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка в ячейку цифры из числа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!