Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выполнить действие при нахождении дубликата по условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выполнить действие при нахождении дубликата по условиям (Нужно найти дубликат и определить первую дату вхождения в сп)
Выполнить действие при нахождении дубликата по условиям
kofeimoloko Дата: Понедельник, 11.01.2021, 16:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

День добрый!

Помогите пожалуйста! Всю голову сломал уже

Нужно найти дубликат в столбце Контрагент. Далее нужно найти первое вхождение дубликата по дате и в столбце "Категория" присвоить значение «Новый» Соответственно, второе и последующие вхождения этого контрагента обозначаются как Старый.

Если ранее в списке не было такого значения в столбце «Контрагент», то в ст. "Категория" присваивается значение «Новый». соответственно, последующие вхождения - статус "Старый"

Если контрагент в одну дату засветился 2 раза, то первому вхождению присваивается Категория - "Новый", а второму - "Старый"

Строк пустых не будет

Дата будет именно как представлено в примере

Очень желательно без VBA и без формулы массива
К сообщению приложен файл: ____.xlsx(14.9 Kb)
 
Ответить
СообщениеДень добрый!

Помогите пожалуйста! Всю голову сломал уже

Нужно найти дубликат в столбце Контрагент. Далее нужно найти первое вхождение дубликата по дате и в столбце "Категория" присвоить значение «Новый» Соответственно, второе и последующие вхождения этого контрагента обозначаются как Старый.

Если ранее в списке не было такого значения в столбце «Контрагент», то в ст. "Категория" присваивается значение «Новый». соответственно, последующие вхождения - статус "Старый"

Если контрагент в одну дату засветился 2 раза, то первому вхождению присваивается Категория - "Новый", а второму - "Старый"

Строк пустых не будет

Дата будет именно как представлено в примере

Очень желательно без VBA и без формулы массива

Автор - kofeimoloko
Дата добавления - 11.01.2021 в 16:20
kofeimoloko Дата: Понедельник, 11.01.2021, 16:43 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

вот написал, но не работает
Код
=ЕСЛИ(G11="";""; ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ(G11;ЕСЛИ(ТЕКСТ($D$4:$D$105;"mmmm yy")=ТЕКСТ(D11;"mmmm yy");"";$G$4:$G$105);0);"")="";"Нов";"Стар"))
 
Ответить
Сообщениевот написал, но не работает
Код
=ЕСЛИ(G11="";""; ЕСЛИ(ЕСЛИОШИБКА(ПОИСКПОЗ(G11;ЕСЛИ(ТЕКСТ($D$4:$D$105;"mmmm yy")=ТЕКСТ(D11;"mmmm yy");"";$G$4:$G$105);0);"")="";"Нов";"Стар"))

Автор - kofeimoloko
Дата добавления - 11.01.2021 в 16:43
Pelena Дата: Понедельник, 11.01.2021, 17:56 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 17510
Репутация: 3890 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Формула массива
Код
=ЕСЛИ(--C4=МИН(ЕСЛИ($G$4:$G$105=G4;--$C$4:$C$105));"новый";"старый")
К сообщению приложен файл: 8022928.xlsx(17.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива
Код
=ЕСЛИ(--C4=МИН(ЕСЛИ($G$4:$G$105=G4;--$C$4:$C$105));"новый";"старый")

Автор - Pelena
Дата добавления - 11.01.2021 в 17:56
jakim Дата: Понедельник, 11.01.2021, 18:38 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1003
Репутация: 273 ±
Замечаний: 0% ±

Excel 2010
Елена сравните Ваши и мои расчёты.
К сообщению приложен файл: 0850041.xlsx(19.1 Kb)
 
Ответить
Сообщение
Елена сравните Ваши и мои расчёты.

Автор - jakim
Дата добавления - 11.01.2021 в 18:38
Pelena Дата: Понедельник, 11.01.2021, 19:37 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 17510
Репутация: 3890 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Вячеслав, у Вас точнее


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВячеслав, у Вас точнее

Автор - Pelena
Дата добавления - 11.01.2021 в 19:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выполнить действие при нахождении дубликата по условиям (Нужно найти дубликат и определить первую дату вхождения в сп)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!