Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция ЕСЛИ вместе с функцией ИЛИ - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция ЕСЛИ вместе с функцией ИЛИ (Формулы/Formulas)
Функция ЕСЛИ вместе с функцией ИЛИ
Extremal Дата: Пятница, 22.01.2021, 12:52 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Прошу помочь с формулой.
Как объединить обе функции.
ЕСЛИМН использовать нет возможности.

Задача
Если во всех ячейках B33, C33, D33 имеется значение "низкий", то в итоговой ячейке должна быть цифра 1
Если во всех ячейках B33, C33, D33 имеется значение "средний", то в итоговой ячейке должна быть цифра 2
Если во всех ячейках B33, C33, D33 имеется значение "высокмй", то в итоговой ячейке должна быть цифра 3

Нечто подобное, но не работает:

Код
ЕСЛИ(И(B33="низкий";C33="низкий";D33="низкий");1;"разные значения") ИЛИ ЕСЛИ(И(B33="средний";C33="средний";D33="средний");2;"разные значения") ИЛИ ЕСЛИ(И(B33="высокий";C33="высокий";D33="высокий");3;"разные значения")


Сообщение отредактировал Extremal - Пятница, 22.01.2021, 14:00
 
Ответить
СообщениеПрошу помочь с формулой.
Как объединить обе функции.
ЕСЛИМН использовать нет возможности.

Задача
Если во всех ячейках B33, C33, D33 имеется значение "низкий", то в итоговой ячейке должна быть цифра 1
Если во всех ячейках B33, C33, D33 имеется значение "средний", то в итоговой ячейке должна быть цифра 2
Если во всех ячейках B33, C33, D33 имеется значение "высокмй", то в итоговой ячейке должна быть цифра 3

Нечто подобное, но не работает:

Код
ЕСЛИ(И(B33="низкий";C33="низкий";D33="низкий");1;"разные значения") ИЛИ ЕСЛИ(И(B33="средний";C33="средний";D33="средний");2;"разные значения") ИЛИ ЕСЛИ(И(B33="высокий";C33="высокий";D33="высокий");3;"разные значения")

Автор - Extremal
Дата добавления - 22.01.2021 в 12:52
Светлый Дата: Пятница, 22.01.2021, 13:02 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1523
Репутация: 398 ±
Замечаний: 0% ±

Excel 2010, 2013
И Вам, здравствуйте.
Формулу надо оформить тегами.
А "разные значения" использовать только один раз в самом внутреннем ЕСЛИ. ИЛИ не нужен.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеИ Вам, здравствуйте.
Формулу надо оформить тегами.
А "разные значения" использовать только один раз в самом внутреннем ЕСЛИ. ИЛИ не нужен.

Автор - Светлый
Дата добавления - 22.01.2021 в 13:02
Extremal Дата: Пятница, 22.01.2021, 13:22 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Светлый
Добрый день и спасибо за ответ!
Убрал под спойлер.

Можете подробнее пояснить, т.е. мне ИЛИ не нужен вообще?
а как тогда разделять ECЛИ?
 
Ответить
СообщениеСветлый
Добрый день и спасибо за ответ!
Убрал под спойлер.

Можете подробнее пояснить, т.е. мне ИЛИ не нужен вообще?
а как тогда разделять ECЛИ?

Автор - Extremal
Дата добавления - 22.01.2021 в 13:22
Serge_007 Дата: Пятница, 22.01.2021, 13:54 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13730
Репутация: 2304 ±
Замечаний: ±

Excel 2010
Убрал под спойлер.
Extremal, бан хотите?

Как оформлять сообщения?

мне ИЛИ не нужен вообще?
И ЕСЛИ() тоже не нужно:
Код
=СУММПРОИЗВ((B33:D33="низкий")+(B33:D33="средний")*2+(B33:D33="высокий")*3)/3


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Убрал под спойлер.
Extremal, бан хотите?

Как оформлять сообщения?

мне ИЛИ не нужен вообще?
И ЕСЛИ() тоже не нужно:
Код
=СУММПРОИЗВ((B33:D33="низкий")+(B33:D33="средний")*2+(B33:D33="высокий")*3)/3

Автор - Serge_007
Дата добавления - 22.01.2021 в 13:54
Extremal Дата: Пятница, 22.01.2021, 14:02 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Serge_007,
Спасибо!

Свое первое сообщение отредактировал в соответствии с правилами!


Сообщение отредактировал Extremal - Пятница, 22.01.2021, 14:08
 
Ответить
СообщениеSerge_007,
Спасибо!

Свое первое сообщение отредактировал в соответствии с правилами!

Автор - Extremal
Дата добавления - 22.01.2021 в 14:02
Светлый Дата: Пятница, 22.01.2021, 14:13 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1523
Репутация: 398 ±
Замечаний: 0% ±

Excel 2010, 2013
Serge_007, по Вашей формуле при всех разных даст "2". При некоторых комбинациях даже дробные числа будут.
наиболее близкое решение:
Код
=ЕСЛИ(И(B33:D33="низкий");1;ЕСЛИ(И(B33:D33="средний");2;ЕСЛИ(И(B33:D33="высокий");3;"разные значения")))
*Ну, или так:
Код
=СУММПРОИЗВ(И(B33:D33="низкий")+И(B33:D33="средний")*2+И(B33:D33="высокий")*3)
Код
=ВЫБОР(И(B33:D33="низкий")+И(B33:D33="средний")*2+И(B33:D33="высокий")*3+1;"разные значения";1;2;3)
**ЕСЛИ и ВЫБОР - формулы массивов. Можно так:
Код
=МАКС((МУМНОЖ(Ч(B33:D33={"низкий":"средний":"высокий"});{1:1:1})=3)*{1:2:3})


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 22.01.2021, 14:46
 
Ответить
СообщениеSerge_007, по Вашей формуле при всех разных даст "2". При некоторых комбинациях даже дробные числа будут.
наиболее близкое решение:
Код
=ЕСЛИ(И(B33:D33="низкий");1;ЕСЛИ(И(B33:D33="средний");2;ЕСЛИ(И(B33:D33="высокий");3;"разные значения")))
*Ну, или так:
Код
=СУММПРОИЗВ(И(B33:D33="низкий")+И(B33:D33="средний")*2+И(B33:D33="высокий")*3)
Код
=ВЫБОР(И(B33:D33="низкий")+И(B33:D33="средний")*2+И(B33:D33="высокий")*3+1;"разные значения";1;2;3)
**ЕСЛИ и ВЫБОР - формулы массивов. Можно так:
Код
=МАКС((МУМНОЖ(Ч(B33:D33={"низкий":"средний":"высокий"});{1:1:1})=3)*{1:2:3})

Автор - Светлый
Дата добавления - 22.01.2021 в 14:13
Nic70y Дата: Пятница, 22.01.2021, 14:40 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 6761
Репутация: 1561 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(СЧЁТЕСЛИ(B33:D33;B33)=СЧЁТЗ(B33:D33);ПОИСК(ЛЕВБ(B33);"нсв");)
+
Код
=ЕСЛИОШИБКА((СЧЁТЕСЛИ(B33:D33;B33)=ЧИСЛСТОЛБ(B33:D33))*ПОИСК(ЛЕВБ(B33);"нсв");)


ЮMoney(Яндекс Деньги) 41001841029809

Сообщение отредактировал Nic70y - Пятница, 22.01.2021, 14:45
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИ(B33:D33;B33)=СЧЁТЗ(B33:D33);ПОИСК(ЛЕВБ(B33);"нсв");)
+
Код
=ЕСЛИОШИБКА((СЧЁТЕСЛИ(B33:D33;B33)=ЧИСЛСТОЛБ(B33:D33))*ПОИСК(ЛЕВБ(B33);"нсв");)

Автор - Nic70y
Дата добавления - 22.01.2021 в 14:40
Serge_007 Дата: Пятница, 22.01.2021, 14:43 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 13730
Репутация: 2304 ±
Замечаний: ±

Excel 2010
Цитата Светлый, 22.01.2021 в 14:13, в сообщении № 6 ()
по Вашей формуле при всех разных даст "2"
Сергей, в условиях задачи не описан вариант со всеми разными значениями)

Цитата Светлый, 22.01.2021 в 14:13, в сообщении № 6 ()
При некоторых комбинациях даже дробные числа будут
Верно. Дробное значение будет означать. что в ячейках нет 3-х одинаковых значений


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Цитата Светлый, 22.01.2021 в 14:13, в сообщении № 6 ()
по Вашей формуле при всех разных даст "2"
Сергей, в условиях задачи не описан вариант со всеми разными значениями)

Цитата Светлый, 22.01.2021 в 14:13, в сообщении № 6 ()
При некоторых комбинациях даже дробные числа будут
Верно. Дробное значение будет означать. что в ячейках нет 3-х одинаковых значений

Автор - Serge_007
Дата добавления - 22.01.2021 в 14:43
Extremal Дата: Пятница, 22.01.2021, 14:59 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Коллеги, спасибо за ваши ответы, очень многое прояснилось!
 
Ответить
СообщениеКоллеги, спасибо за ваши ответы, очень многое прояснилось!

Автор - Extremal
Дата добавления - 22.01.2021 в 14:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция ЕСЛИ вместе с функцией ИЛИ (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!