Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как правильно использовать VLOOKUP и CHOOSE - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как правильно использовать VLOOKUP и CHOOSE (Формулы/Formulas)
Как правильно использовать VLOOKUP и CHOOSE
oxojeck Дата: Пятница, 29.01.2021, 16:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Собственно проблемка, мне нужно сопоставить 2 таблички, но столбец искомого значения в диапазоне идёт не первой колонкой. Пробую использовать CHOOSE, но выдает ошибку reference error. Пример прикрепил. Что не так? Спасибо.
К сообщению приложен файл: Example.xlsx(9.9 Kb)
 
Ответить
СообщениеСобственно проблемка, мне нужно сопоставить 2 таблички, но столбец искомого значения в диапазоне идёт не первой колонкой. Пробую использовать CHOOSE, но выдает ошибку reference error. Пример прикрепил. Что не так? Спасибо.

Автор - oxojeck
Дата добавления - 29.01.2021 в 16:50
Serge_007 Дата: Пятница, 29.01.2021, 16:58 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13925
Репутация: 2318 ±
Замечаний: ±

Excel 2010
Здравствуйте

Так будет работать:
Код
=ВПР(A2;ВЫБОР({1;2};E$2:E$5;D$2:D$5);2;)
К сообщению приложен файл: 20210129_oxojec.xls(28.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Так будет работать:
Код
=ВПР(A2;ВЫБОР({1;2};E$2:E$5;D$2:D$5);2;)

Автор - Serge_007
Дата добавления - 29.01.2021 в 16:58
oxojeck Дата: Пятница, 29.01.2021, 17:07 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Спасибо, работает. Вместо "," надо "\". Разные версии - разные символы разделения.
 
Ответить
СообщениеСпасибо, работает. Вместо "," надо "\". Разные версии - разные символы разделения.

Автор - oxojeck
Дата добавления - 29.01.2021 в 17:07
Serge_007 Дата: Пятница, 29.01.2021, 17:12 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13925
Репутация: 2318 ±
Замечаний: ±

Excel 2010
Верно)

Интересно, что ещё 7 лет назад тема ВПР не по первому столбцу была в Мозговом штурме, а сейчас уже многие знают как заставить ВПР работать нестандартно :D


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеВерно)

Интересно, что ещё 7 лет назад тема ВПР не по первому столбцу была в Мозговом штурме, а сейчас уже многие знают как заставить ВПР работать нестандартно :D

Автор - Serge_007
Дата добавления - 29.01.2021 в 17:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как правильно использовать VLOOKUP и CHOOSE (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!