Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Количество дней, попадающих в один из периодов - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество дней, попадающих в один из периодов (Формулы/Formulas)
Количество дней, попадающих в один из периодов
Russel Дата: Среда, 24.02.2021, 19:18 | Сообщение № 1
Группа: Друзья
Ранг: Старожил
Сообщений: 1366
Репутация: 308 ±
Замечаний: 0% ±

Excel 2010
Коллеги, доброго дня!
У меня голова опухла, не могу изящного решения придумать.
Есть рассматриваемый месяц (столбец А), есть три периода (столбцы B:G, не пересекающиеся).
Надо высчитать кол-во дней рассматриваемого месяца, попадающих в один из периодов.
Я придумал какую-то безобразную формулу, которую и показывать стыдно :(
Прошу помощи уважаемого коллектива в решении вопроса.
Очень желательна быстрая формула, ибо строк таких - сотни тысяч.
К сообщению приложен файл: 1025085.xlsx(9.6 Kb)


QIWI 9173973973
 
Ответить
СообщениеКоллеги, доброго дня!
У меня голова опухла, не могу изящного решения придумать.
Есть рассматриваемый месяц (столбец А), есть три периода (столбцы B:G, не пересекающиеся).
Надо высчитать кол-во дней рассматриваемого месяца, попадающих в один из периодов.
Я придумал какую-то безобразную формулу, которую и показывать стыдно :(
Прошу помощи уважаемого коллектива в решении вопроса.
Очень желательна быстрая формула, ибо строк таких - сотни тысяч.

Автор - Russel
Дата добавления - 24.02.2021 в 19:18
Pelena Дата: Среда, 24.02.2021, 21:16 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17499
Репутация: 3886 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Руслан, добрый день.
Точно не пересекающиеся? В 8 и 9 строках периоды пересекаются. По какому считать? Периодов не больше трёх?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеРуслан, добрый день.
Точно не пересекающиеся? В 8 и 9 строках периоды пересекаются. По какому считать? Периодов не больше трёх?

Автор - Pelena
Дата добавления - 24.02.2021 в 21:16
Russel Дата: Среда, 24.02.2021, 23:52 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1366
Репутация: 308 ±
Замечаний: 0% ±

Excel 2010
Точно не пересекаются, Елена, это я с примером перестарался, глаз замылился. Моя формула порядка 200+ символов, мне кажется не оптимальной.
Периодов не больше трёх, но могут быть пустые.
К сообщению приложен файл: 8085733.xlsx(9.8 Kb)


QIWI 9173973973

Сообщение отредактировал Russel - Среда, 24.02.2021, 23:53
 
Ответить
СообщениеТочно не пересекаются, Елена, это я с примером перестарался, глаз замылился. Моя формула порядка 200+ символов, мне кажется не оптимальной.
Периодов не больше трёх, но могут быть пустые.

Автор - Russel
Дата добавления - 24.02.2021 в 23:52
Pelena Дата: Четверг, 25.02.2021, 09:40 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17499
Репутация: 3886 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Пока тоже не очень короткая
Код
=СУММ(МАКС(МИН(КОНМЕСЯЦА(A5;0);0&C5)-МАКС(A5;B5)+1;0);МАКС(МИН(КОНМЕСЯЦА(A5;0);0&E5)-МАКС(A5;D5)+1;0);МАКС(МИН(КОНМЕСЯЦА(A5;0);0&G5)-МАКС(A5;F5)+1;0))

или
Код
=СУММ(--ТЕКСТ(КОНМЕСЯЦА(A5;0)-ТЕКСТ(КОНМЕСЯЦА(A5;0)-C5:G5*($C$4:$G$4="конец");"0;\0")-(ТЕКСТ((B5:F5-A5)*($B$4:$F$4="начало");"0;\0")+A5)+1;"0;\0"))

и да, в десятой строке ячейки не совсем пустые, нажимала Del, чтобы очистить
К сообщению приложен файл: Russel.xlsx(11.2 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПока тоже не очень короткая
Код
=СУММ(МАКС(МИН(КОНМЕСЯЦА(A5;0);0&C5)-МАКС(A5;B5)+1;0);МАКС(МИН(КОНМЕСЯЦА(A5;0);0&E5)-МАКС(A5;D5)+1;0);МАКС(МИН(КОНМЕСЯЦА(A5;0);0&G5)-МАКС(A5;F5)+1;0))

или
Код
=СУММ(--ТЕКСТ(КОНМЕСЯЦА(A5;0)-ТЕКСТ(КОНМЕСЯЦА(A5;0)-C5:G5*($C$4:$G$4="конец");"0;\0")-(ТЕКСТ((B5:F5-A5)*($B$4:$F$4="начало");"0;\0")+A5)+1;"0;\0"))

и да, в десятой строке ячейки не совсем пустые, нажимала Del, чтобы очистить

Автор - Pelena
Дата добавления - 25.02.2021 в 09:40
Russel Дата: Четверг, 25.02.2021, 10:40 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1366
Репутация: 308 ±
Замечаний: 0% ±

Excel 2010
Пока тоже не очень короткая


В два раза короче моей! Спасибо, Елена!


QIWI 9173973973
 
Ответить
Сообщение
Пока тоже не очень короткая


В два раза короче моей! Спасибо, Елена!

Автор - Russel
Дата добавления - 25.02.2021 в 10:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество дней, попадающих в один из периодов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!