Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Последовательно суммирование данных (но не поряд) - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Последовательно суммирование данных (но не поряд) (Формулы/Formulas)
Последовательно суммирование данных (но не поряд)
Shtein Дата: Пятница, 19.03.2021, 10:55 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день, подскажите, пожалуйста, как можно решить такую задачу.
Есть таблица, в которой ежедневно вносятся кол-во м общая сумма продаж. В примере 5 дней, но их может быть сотни. Нужны в столбцах K и L формулы, которые суммирую все кол-во и сумму продаж за все дни.
Я реализовал просто сложением ячеек, но это неудобно. За 2 года более 700 последовательных сложений и надо постоянно добавлять в формулу. когда добавляются новые дни в таблицу, но и есть риск промахнуться и не учесть какую-то ячейку.
Код
=A3+C3+E3+G3+I3

Код
=B3+D3+F3+H3+J3


Может есть какая-то возможность автоматизировать цикл, чтобы формула считала сумму в указанном диапазоне A3:I3, но не подряд, а через одну ячейку? Если бы был в 1 день 1 столбце, то можно было бы просто через формулу СУММ.
А вот как дать ему понять, чтобы через одну считал?
К сообщению приложен файл: 2661833.xlsx(15.1 Kb)


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.


Сообщение отредактировал Shtein - Пятница, 19.03.2021, 11:28
 
Ответить
СообщениеДобрый день, подскажите, пожалуйста, как можно решить такую задачу.
Есть таблица, в которой ежедневно вносятся кол-во м общая сумма продаж. В примере 5 дней, но их может быть сотни. Нужны в столбцах K и L формулы, которые суммирую все кол-во и сумму продаж за все дни.
Я реализовал просто сложением ячеек, но это неудобно. За 2 года более 700 последовательных сложений и надо постоянно добавлять в формулу. когда добавляются новые дни в таблицу, но и есть риск промахнуться и не учесть какую-то ячейку.
Код
=A3+C3+E3+G3+I3

Код
=B3+D3+F3+H3+J3


Может есть какая-то возможность автоматизировать цикл, чтобы формула считала сумму в указанном диапазоне A3:I3, но не подряд, а через одну ячейку? Если бы был в 1 день 1 столбце, то можно было бы просто через формулу СУММ.
А вот как дать ему понять, чтобы через одну считал?

Автор - Shtein
Дата добавления - 19.03.2021 в 10:55
Serge_007 Дата: Пятница, 19.03.2021, 11:05 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13873
Репутация: 2315 ±
Замечаний: ±

Excel 2010
Здравствуйте

Например так:
Код
=СУММЕСЛИ(A2:J2;"сумма";A3:J3)


Или так, если нет признака, на который можно сослаться:
Код
=СУММПРОИЗВ(ЕЧЁТН(СТОЛБЕЦ(A1:J1))*A3:J3)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Например так:
Код
=СУММЕСЛИ(A2:J2;"сумма";A3:J3)


Или так, если нет признака, на который можно сослаться:
Код
=СУММПРОИЗВ(ЕЧЁТН(СТОЛБЕЦ(A1:J1))*A3:J3)

Автор - Serge_007
Дата добавления - 19.03.2021 в 11:05
Egyptian Дата: Пятница, 19.03.2021, 11:07 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 39 ±
Замечаний: 0% ±

Excel 2013/2016
Варианты:
Код
=SUM(IF(MOD(COLUMN($B3:$J3);2)=0;$B3:$J3;0))

Код
=SUMPRODUCT(MOD(COLUMN($A3:$I3);2);$B3:$J3)
К сообщению приложен файл: 6864399.xlsx(9.8 Kb)
 
Ответить
СообщениеВарианты:
Код
=SUM(IF(MOD(COLUMN($B3:$J3);2)=0;$B3:$J3;0))

Код
=SUMPRODUCT(MOD(COLUMN($A3:$I3);2);$B3:$J3)

Автор - Egyptian
Дата добавления - 19.03.2021 в 11:07
Shtein Дата: Пятница, 19.03.2021, 11:13 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
сумму по столбцу L считает. А как сделать, чтобы и в К считало? Я поменял в формуле диапазон, но не срабатывает...


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
Сообщениесумму по столбцу L считает. А как сделать, чтобы и в К считало? Я поменял в формуле диапазон, но не срабатывает...

Автор - Shtein
Дата добавления - 19.03.2021 в 11:13
Serge_007 Дата: Пятница, 19.03.2021, 11:18 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 13873
Репутация: 2315 ±
Замечаний: ±

Excel 2010
как сделать, чтобы и в К считало?
Код
=СУММПРОИЗВ(ЕНЕЧЁТ(СТОЛБЕЦ(A1:J1))*A3:J3)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
как сделать, чтобы и в К считало?
Код
=СУММПРОИЗВ(ЕНЕЧЁТ(СТОЛБЕЦ(A1:J1))*A3:J3)

Автор - Serge_007
Дата добавления - 19.03.2021 в 11:18
Shtein Дата: Пятница, 19.03.2021, 11:24 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Serge_007, супер))
подскажите, а вот вы в одной формуле сделали с абсолютными ссылками на диапазон, а в другой с относительными. По идее можно в обоих случаях зафиксировать $-ми?

Код
=СУММПРОИЗВ(ЕНЕЧЁТ(СТОЛБЕЦ(A1:J1))*A3:J3)

Код
=СУММПРОИЗВ(ОСТАТ(СТОЛБЕЦ($A3:$I3);2);$B3:$J3)


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.


Сообщение отредактировал Serge_007 - Пятница, 19.03.2021, 11:27
 
Ответить
СообщениеSerge_007, супер))
подскажите, а вот вы в одной формуле сделали с абсолютными ссылками на диапазон, а в другой с относительными. По идее можно в обоих случаях зафиксировать $-ми?

Код
=СУММПРОИЗВ(ЕНЕЧЁТ(СТОЛБЕЦ(A1:J1))*A3:J3)

Код
=СУММПРОИЗВ(ОСТАТ(СТОЛБЕЦ($A3:$I3);2);$B3:$J3)

Автор - Shtein
Дата добавления - 19.03.2021 в 11:24
китин Дата: Пятница, 19.03.2021, 11:25 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 6417
Репутация: 984 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение- Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 19.03.2021 в 11:25
Serge_007 Дата: Пятница, 19.03.2021, 11:27 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 13873
Репутация: 2315 ±
Замечаний: ±

Excel 2010
вы в одной формуле сделали с абсолютными ссылками
Не, я не делал. В Вашем примере в этом нет смысла

ожно в обоих случаях зафиксировать $-ми?
Можно. Только незачем. У Вас формула не копируется по горизонтали

[p.s.]В правилах написано про теги. Почитайте


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
вы в одной формуле сделали с абсолютными ссылками
Не, я не делал. В Вашем примере в этом нет смысла

ожно в обоих случаях зафиксировать $-ми?
Можно. Только незачем. У Вас формула не копируется по горизонтали

[p.s.]В правилах написано про теги. Почитайте

Автор - Serge_007
Дата добавления - 19.03.2021 в 11:27
Egyptian Дата: Пятница, 19.03.2021, 11:27 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 39 ±
Замечаний: 0% ±

Excel 2013/2016
Я поменял в формуле диапазон, но не срабатывает...

И я поменял.
Код
=SUMPRODUCT(MOD(COLUMN($A3:$I3);2);$A3:$I3)

Подозрительно, но считает))
 
Ответить
Сообщение
Я поменял в формуле диапазон, но не срабатывает...

И я поменял.
Код
=SUMPRODUCT(MOD(COLUMN($A3:$I3);2);$A3:$I3)

Подозрительно, но считает))

Автор - Egyptian
Дата добавления - 19.03.2021 в 11:27
Shtein Дата: Пятница, 19.03.2021, 11:39 | Сообщение № 10
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
ребята, спасибо огромное, тегами оформил.
Serge_007, да у вас было все с относительными, я не туда глянул.

Egyptian, вот эта считает вроде не так, но остальные 2 рабочие
Код
=СУММ(ЕСЛИ(ОСТАТ(СТОЛБЕЦ($B3:$J3);2)=0;$B3:$J3;0))


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
Сообщениеребята, спасибо огромное, тегами оформил.
Serge_007, да у вас было все с относительными, я не туда глянул.

Egyptian, вот эта считает вроде не так, но остальные 2 рабочие
Код
=СУММ(ЕСЛИ(ОСТАТ(СТОЛБЕЦ($B3:$J3);2)=0;$B3:$J3;0))

Автор - Shtein
Дата добавления - 19.03.2021 в 11:39
Egyptian Дата: Пятница, 19.03.2021, 11:53 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 39 ±
Замечаний: 0% ±

Excel 2013/2016
Shtein,
Это формула массива, ее надо вводить через CTRL+SHIFT+ENTER
 
Ответить
СообщениеShtein,
Это формула массива, ее надо вводить через CTRL+SHIFT+ENTER

Автор - Egyptian
Дата добавления - 19.03.2021 в 11:53
Shtein Дата: Пятница, 19.03.2021, 12:17 | Сообщение № 12
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
аа, понял, тогда все работает :D


"В мире давным давно все известно, главное знать у кого спросить"
Рэй Бредбери.
 
Ответить
Сообщениеаа, понял, тогда все работает :D

Автор - Shtein
Дата добавления - 19.03.2021 в 12:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Последовательно суммирование данных (но не поряд) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!