Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет средней для ячеек с определенным значением без 0 - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет средней для ячеек с определенным значением без 0 (Формулы/Formulas)
Расчет средней для ячеек с определенным значением без 0
nica_246 Дата: Четверг, 06.05.2021, 12:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте.
Ищу решение, как можно рассчитать среднюю для ячеек с определенным содержанием.
Например, есть Европа, к которой относятся Волгоград и Воронеж и есть Азия, к которой относятся города: Барнаул, Владивосток, Екатеринбург, Иркутск.
Нужно посчитать среднее по Европе и Азии
Подскажите, пожалуйста, как можно прописать формулу чтобы не привязываться к номерам ячеек, а к содержимому в них.
Потому что, эти данные динамичны из месяца в месяц и ячейки постоянно меняются, а города одинаковы всегда.

В январе я использовала формулу для Азии
Код
=СУММ(E9;E309;E454;E482)/СУММПРОИЗВ((E9>0)+(E309>0)+(E454>0)+(E482>0))

и для Европы
Код
=СУММ(E334;E359)/СУММПРОИЗВ((E334>0)+(E359>0))

В феврале все ячейки поменялись и нужно переписывать формулу, в оригинале до 100 городов((

Буду рада любому совету!
К сообщению приложен файл: 4867215.xls(493.0 Kb)
 
Ответить
СообщениеЗдравствуйте.
Ищу решение, как можно рассчитать среднюю для ячеек с определенным содержанием.
Например, есть Европа, к которой относятся Волгоград и Воронеж и есть Азия, к которой относятся города: Барнаул, Владивосток, Екатеринбург, Иркутск.
Нужно посчитать среднее по Европе и Азии
Подскажите, пожалуйста, как можно прописать формулу чтобы не привязываться к номерам ячеек, а к содержимому в них.
Потому что, эти данные динамичны из месяца в месяц и ячейки постоянно меняются, а города одинаковы всегда.

В январе я использовала формулу для Азии
Код
=СУММ(E9;E309;E454;E482)/СУММПРОИЗВ((E9>0)+(E309>0)+(E454>0)+(E482>0))

и для Европы
Код
=СУММ(E334;E359)/СУММПРОИЗВ((E334>0)+(E359>0))

В феврале все ячейки поменялись и нужно переписывать формулу, в оригинале до 100 городов((

Буду рада любому совету!

Автор - nica_246
Дата добавления - 06.05.2021 в 12:54
Pelena Дата: Четверг, 06.05.2021, 13:33 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17625
Репутация: 3925 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Буду рада любому совету!
завести столбец или отдельную таблицу соответствия названия города и части света

Дополняйте таблицу на листе Справочник и корректируйте при необходимости диапазоны в формуле
К сообщению приложен файл: 4867215.xlsx(109.9 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Буду рада любому совету!
завести столбец или отдельную таблицу соответствия названия города и части света

Дополняйте таблицу на листе Справочник и корректируйте при необходимости диапазоны в формуле

Автор - Pelena
Дата добавления - 06.05.2021 в 13:33
nica_246 Дата: Четверг, 06.05.2021, 18:36 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Pelena, огромное спасибо! :heart:
 
Ответить
СообщениеPelena, огромное спасибо! :heart:

Автор - nica_246
Дата добавления - 06.05.2021 в 18:36
nica_246 Дата: Вторник, 11.05.2021, 19:15 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Pelena, извините, пожалуйста за тугодумность!
Формула для среднего работает идеально, спасибо Вам!

Код
=СУММПРОИЗВ(МУМНОЖ(--($A$9:$A$581=ТРАНСП(Справочник!$A$2:$A$29));--($A582=Справочник!$B$2:$B$29));$D$9:$D$581)/СУММ(МУМНОЖ(--($A$9:$A$581=ТРАНСП(Справочник!$A$2:$A$29));--($A582=Справочник!$B$2:$B$29)))


Попыталась изменить её просто для суммирования.
Хочу применить ее для подсчета количества мероприятий для каждой части света (Европы и Азии).

Код
=СУММ(МУМНОЖ(--($A$9:$A$581=ТРАНСП(Справочник!$A$2:$A$29));--($A582=Справочник!$B$2:$B$29));$E$9:$E$581)


При суммировании прибавляет количество городов (если правильно поняла).
Подскажите как изменить формулу, чтобы считалось именно количество мероприятий без учета городов, не совсем понимаю((
К сообщению приложен файл: -2-.xls(478.5 Kb)


Сообщение отредактировал nica_246 - Вторник, 11.05.2021, 19:59
 
Ответить
СообщениеPelena, извините, пожалуйста за тугодумность!
Формула для среднего работает идеально, спасибо Вам!

Код
=СУММПРОИЗВ(МУМНОЖ(--($A$9:$A$581=ТРАНСП(Справочник!$A$2:$A$29));--($A582=Справочник!$B$2:$B$29));$D$9:$D$581)/СУММ(МУМНОЖ(--($A$9:$A$581=ТРАНСП(Справочник!$A$2:$A$29));--($A582=Справочник!$B$2:$B$29)))


Попыталась изменить её просто для суммирования.
Хочу применить ее для подсчета количества мероприятий для каждой части света (Европы и Азии).

Код
=СУММ(МУМНОЖ(--($A$9:$A$581=ТРАНСП(Справочник!$A$2:$A$29));--($A582=Справочник!$B$2:$B$29));$E$9:$E$581)


При суммировании прибавляет количество городов (если правильно поняла).
Подскажите как изменить формулу, чтобы считалось именно количество мероприятий без учета городов, не совсем понимаю((

Автор - nica_246
Дата добавления - 11.05.2021 в 19:15
Pelena Дата: Вторник, 11.05.2021, 19:44 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 17625
Репутация: 3925 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
nica_246, оформите формулы тегами с помощью кнопки fx в режиме правки поста.

По теме: среднее - это сумма, деленная на количество, поэтому за количество отвечает часть формулы, которая после знака деления /


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщениеnica_246, оформите формулы тегами с помощью кнопки fx в режиме правки поста.

По теме: среднее - это сумма, деленная на количество, поэтому за количество отвечает часть формулы, которая после знака деления /

Автор - Pelena
Дата добавления - 11.05.2021 в 19:44
nica_246 Дата: Вторник, 11.05.2021, 20:16 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Pelena,
Код
=СУММ(МУМНОЖ(--($A$9:$A$581=ТРАНСП(Справочник!$A$2:$A$29));--($A582=Справочник!$B$2:$B$29));$E$9:$E$581)


попробовала для Азии, снова я где-то ошибаюсь(
К сообщению приложен файл: 0769295.xls(478.0 Kb)
 
Ответить
СообщениеPelena,
Код
=СУММ(МУМНОЖ(--($A$9:$A$581=ТРАНСП(Справочник!$A$2:$A$29));--($A582=Справочник!$B$2:$B$29));$E$9:$E$581)


попробовала для Азии, снова я где-то ошибаюсь(

Автор - nica_246
Дата добавления - 11.05.2021 в 20:16
Pelena Дата: Вторник, 11.05.2021, 22:37 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 17625
Репутация: 3925 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Я написала ПОСЛЕ знака деления
Код
=СУММ(МУМНОЖ(--($A$9:$A$581=ТРАНСП(Справочник!$A$2:$A$29));--($A582=Справочник!$B$2:$B$29)))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЯ написала ПОСЛЕ знака деления
Код
=СУММ(МУМНОЖ(--($A$9:$A$581=ТРАНСП(Справочник!$A$2:$A$29));--($A582=Справочник!$B$2:$B$29)))

Автор - Pelena
Дата добавления - 11.05.2021 в 22:37
nica_246 Дата: Среда, 12.05.2021, 04:41 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Pelena, я написала формулу после знака /, но добавила диапазон ячеек.
Без диапазона ячеек
Код
$E$2:$E$29
выдает количество городов(
Спасибо за наводку, буду разбираться :)


Сообщение отредактировал nica_246 - Среда, 12.05.2021, 04:41
 
Ответить
СообщениеPelena, я написала формулу после знака /, но добавила диапазон ячеек.
Без диапазона ячеек
Код
$E$2:$E$29
выдает количество городов(
Спасибо за наводку, буду разбираться :)

Автор - nica_246
Дата добавления - 12.05.2021 в 04:41
Pelena Дата: Среда, 12.05.2021, 07:57 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 17625
Репутация: 3925 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Виновата, невнимательно прочитала задачу.
Тогда, наоборот, нужна первая часть до знака деления, но с другим диапазоном
Код
=СУММПРОИЗВ(МУМНОЖ(--($A$9:$A$581=ТРАНСП(Справочник!$A$2:$A$29));--($A582=Справочник!$B$2:$B$29));$E$9:$E$581)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеВиновата, невнимательно прочитала задачу.
Тогда, наоборот, нужна первая часть до знака деления, но с другим диапазоном
Код
=СУММПРОИЗВ(МУМНОЖ(--($A$9:$A$581=ТРАНСП(Справочник!$A$2:$A$29));--($A582=Справочник!$B$2:$B$29));$E$9:$E$581)

Автор - Pelena
Дата добавления - 12.05.2021 в 07:57
nica_246 Дата: Среда, 12.05.2021, 08:18 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Pelena, Урааа! Считает корректно hands Спасибо Вам огромное за терпение и помощь!
 
Ответить
СообщениеPelena, Урааа! Считает корректно hands Спасибо Вам огромное за терпение и помощь!

Автор - nica_246
Дата добавления - 12.05.2021 в 08:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет средней для ячеек с определенным значением без 0 (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!