Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сделать вывод записи из таблицы по условию? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать вывод записи из таблицы по условию? (Формулы/Formulas)
Как сделать вывод записи из таблицы по условию?
TSC Дата: Понедельник, 17.05.2021, 10:08 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Есть основная таблица данных с заявками (лист "ДАННЫЕ")
Сделал как мог календарик и вывод количества заявок по типу.
А вот как сделать вывод фамилий из таблицы по выбранным условиям (город / месяц / число), не понимаю.
Думается, надо как-то образовать по нужным критериям массив, а уже оттуда взять с помощью ВПР записи (через уникальный ID записей), но как организовать такой массив в формуле не понимаю.
Подскажите, пожалуйста

К сообщению приложен файл: 1629071.xlsx(32.1 Kb)


Сообщение отредактировал TSC - Понедельник, 17.05.2021, 10:11
 
Ответить
СообщениеДобрый день!
Есть основная таблица данных с заявками (лист "ДАННЫЕ")
Сделал как мог календарик и вывод количества заявок по типу.
А вот как сделать вывод фамилий из таблицы по выбранным условиям (город / месяц / число), не понимаю.
Думается, надо как-то образовать по нужным критериям массив, а уже оттуда взять с помощью ВПР записи (через уникальный ID записей), но как организовать такой массив в формуле не понимаю.
Подскажите, пожалуйста


Автор - TSC
Дата добавления - 17.05.2021 в 10:08
Serge_007 Дата: Понедельник, 17.05.2021, 10:29 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
Здравствуйте

Формула массива:
Код
=ИНДЕКС(ДАННЫЕ!$B$2:$B$48;НАИМЕНЬШИЙ(ЕСЛИ((Офис=ДАННЫЕ!$E$2:$E$48)*(ДАТА(Год;ПОИСКПОЗ(Месяц;{"янв":"фев":"мар":"апр":"май":"июн":"июл":"авг":"сен":"окт":"ноя":"дек"};);D$5)=ДАННЫЕ!$G$2:$G$48);СТРОКА($1:$47));СТРОКА(A1)))
К сообщению приложен файл: 20210517_TSC.xls(77.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Формула массива:
Код
=ИНДЕКС(ДАННЫЕ!$B$2:$B$48;НАИМЕНЬШИЙ(ЕСЛИ((Офис=ДАННЫЕ!$E$2:$E$48)*(ДАТА(Год;ПОИСКПОЗ(Месяц;{"янв":"фев":"мар":"апр":"май":"июн":"июл":"авг":"сен":"окт":"ноя":"дек"};);D$5)=ДАННЫЕ!$G$2:$G$48);СТРОКА($1:$47));СТРОКА(A1)))

Автор - Serge_007
Дата добавления - 17.05.2021 в 10:29
TSC Дата: Понедельник, 17.05.2021, 11:45 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Serge_007, спасибо, работает!

Я отредактировал формулу под смарт-таблицу, т.к. основная таблица данных будет расти.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Данные[Фамилия];НАИМЕНЬШИЙ(ЕСЛИ((Офис=Данные[Офис])*(ДАТА(Год;ПОИСКПОЗ(Месяц;{"янв":"фев":"мар":"апр":"май":"июн":"июл":"авг":"сен":"окт":"ноя":"дек"};);D$5)=Данные[Дата]);СТРОКА($1:$47));СТРОКА(A1)));"")


А вот не пойму, что делают СТРОКА($1:$47));СТРОКА(A1)?
Они же возвращают номер строки, сейчас их 47 в таблице данных, а если будет 500, то эту часть формулы тоже менять?
То есть не будет ли ошибки впоследствии, когда строк в исходной таблице будет больше
 
Ответить
СообщениеSerge_007, спасибо, работает!

Я отредактировал формулу под смарт-таблицу, т.к. основная таблица данных будет расти.
Код
=ЕСЛИОШИБКА(ИНДЕКС(Данные[Фамилия];НАИМЕНЬШИЙ(ЕСЛИ((Офис=Данные[Офис])*(ДАТА(Год;ПОИСКПОЗ(Месяц;{"янв":"фев":"мар":"апр":"май":"июн":"июл":"авг":"сен":"окт":"ноя":"дек"};);D$5)=Данные[Дата]);СТРОКА($1:$47));СТРОКА(A1)));"")


А вот не пойму, что делают СТРОКА($1:$47));СТРОКА(A1)?
Они же возвращают номер строки, сейчас их 47 в таблице данных, а если будет 500, то эту часть формулы тоже менять?
То есть не будет ли ошибки впоследствии, когда строк в исходной таблице будет больше

Автор - TSC
Дата добавления - 17.05.2021 в 11:45
Serge_007 Дата: Понедельник, 17.05.2021, 11:52 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
TSC, прочитайте эту статью: Извлечение уникальных значений формулами
В статье подробно описано для чего используется часть формулы с функцией СТРОКА()


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеTSC, прочитайте эту статью: Извлечение уникальных значений формулами
В статье подробно описано для чего используется часть формулы с функцией СТРОКА()

Автор - Serge_007
Дата добавления - 17.05.2021 в 11:52
TSC Дата: Понедельник, 17.05.2021, 12:58 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Serge_007, спасибо, прочитал. Стало понятнее.
Но вторую часть вопроса это не сняло
Методом тыка решил проверить, и к сожалению, опасения подтвердились. Если к этой дате в данном городе добавить новую запись в таблице Данные, то пропадают значения в имевшихся ячейках календаря (точнее, появляется ошибка #Н/Д)
То есть при каждом добавлении записи в исходную таблицу, необходимо менять формулы календаря, расширяя диапазон. При этом нельзя заблаговременно обозначить диапазон на 1000 строк, скажем, т.к. это тоже приводит к той же ошибке.
Пытаюсь сделать функцию СТРОКА динамичной, но не получается
 
Ответить
СообщениеSerge_007, спасибо, прочитал. Стало понятнее.
Но вторую часть вопроса это не сняло
Методом тыка решил проверить, и к сожалению, опасения подтвердились. Если к этой дате в данном городе добавить новую запись в таблице Данные, то пропадают значения в имевшихся ячейках календаря (точнее, появляется ошибка #Н/Д)
То есть при каждом добавлении записи в исходную таблицу, необходимо менять формулы календаря, расширяя диапазон. При этом нельзя заблаговременно обозначить диапазон на 1000 строк, скажем, т.к. это тоже приводит к той же ошибке.
Пытаюсь сделать функцию СТРОКА динамичной, но не получается

Автор - TSC
Дата добавления - 17.05.2021 в 12:58
Serge_007 Дата: Понедельник, 17.05.2021, 13:07 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
Пытаюсь сделать функцию СТРОКА динамичной
Один из вариантов:
Код
=ИНДЕКС(ДАННЫЕ!$B$2:$B$48;НАИМЕНЬШИЙ(ЕСЛИ((Офис=ДАННЫЕ!$E$2:$E$48)*(ДАТА(Год;ПОИСКПОЗ(Месяц;{"янв":"фев":"мар":"апр":"май":"июн":"июл":"авг":"сен":"окт":"ноя":"дек"};);D$5)=ДАННЫЕ!$G$2:$G$48);СТРОКА(ДВССЫЛ("$1:"&ПОИСКПОЗ("яяя";ДАННЫЕ!$B$2:$B$999))));СТРОКА(A1)))


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Пытаюсь сделать функцию СТРОКА динамичной
Один из вариантов:
Код
=ИНДЕКС(ДАННЫЕ!$B$2:$B$48;НАИМЕНЬШИЙ(ЕСЛИ((Офис=ДАННЫЕ!$E$2:$E$48)*(ДАТА(Год;ПОИСКПОЗ(Месяц;{"янв":"фев":"мар":"апр":"май":"июн":"июл":"авг":"сен":"окт":"ноя":"дек"};);D$5)=ДАННЫЕ!$G$2:$G$48);СТРОКА(ДВССЫЛ("$1:"&ПОИСКПОЗ("яяя";ДАННЫЕ!$B$2:$B$999))));СТРОКА(A1)))

Автор - Serge_007
Дата добавления - 17.05.2021 в 13:07
TSC Дата: Понедельник, 17.05.2021, 14:27 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 16
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Serge_007, Спасибо большое
В который раз удивляюсь, что для вас нет ничего невозможного
 
Ответить
СообщениеSerge_007, Спасибо большое
В который раз удивляюсь, что для вас нет ничего невозможного

Автор - TSC
Дата добавления - 17.05.2021 в 14:27
Serge_007 Дата: Понедельник, 17.05.2021, 14:31 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
:)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение:)

Автор - Serge_007
Дата добавления - 17.05.2021 в 14:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать вывод записи из таблицы по условию? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!