Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Индекс+поискпоз из разных таблиц - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Индекс+поискпоз из разных таблиц (Формулы/Formulas)
Индекс+поискпоз из разных таблиц
duckky Дата: Вторник, 01.06.2021, 09:33 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день, прошу помочь разобраться с формулой для массива, вроде бы делал по примерам с форума, но видимо где-то недопонял принцип функции индекс.
В прилагаемом файле необходимо найти температуру мазута.
В ячейке С31 вносится время состава в пути.
В ячейку С33 - температура наружного воздуха.
В итоге в ячейке J22 надо найти температуру мазута по таблицам. Не могу сообразить почему формулы в столбце D показывают ошибку. Прошу помочь, как изменить в столбце D формулы.
К сообщению приложен файл: mazut.xlsx(12.5 Kb)
 
Ответить
СообщениеДобрый день, прошу помочь разобраться с формулой для массива, вроде бы делал по примерам с форума, но видимо где-то недопонял принцип функции индекс.
В прилагаемом файле необходимо найти температуру мазута.
В ячейке С31 вносится время состава в пути.
В ячейку С33 - температура наружного воздуха.
В итоге в ячейке J22 надо найти температуру мазута по таблицам. Не могу сообразить почему формулы в столбце D показывают ошибку. Прошу помочь, как изменить в столбце D формулы.

Автор - duckky
Дата добавления - 01.06.2021 в 09:33
amfor Дата: Вторник, 01.06.2021, 09:46 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 211
Репутация: 64 ±
Замечаний: 0% ±

Excel 2016
Добрый.Как понял.
Код
=ИНДЕКС($C$4:$I$18;ПОИСКПОЗ($C22;$B$4:$B$18;0);ПОИСКПОЗ($B22;$C$3:$I$3;0))
К сообщению приложен файл: 9950501.xlsx(12.8 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеДобрый.Как понял.
Код
=ИНДЕКС($C$4:$I$18;ПОИСКПОЗ($C22;$B$4:$B$18;0);ПОИСКПОЗ($B22;$C$3:$I$3;0))

Автор - amfor
Дата добавления - 01.06.2021 в 09:46
китин Дата: Вторник, 01.06.2021, 09:48 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6456
Репутация: 989 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=ИНДЕКС($C$4:$I$18;ПОИСКПОЗ($C22;$B$4:$B$18;0);ПОИСКПОЗ($B22;$C$3:$I$3;0))
К сообщению приложен файл: 9194319.xlsx(12.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
=ИНДЕКС($C$4:$I$18;ПОИСКПОЗ($C22;$B$4:$B$18;0);ПОИСКПОЗ($B22;$C$3:$I$3;0))

Автор - китин
Дата добавления - 01.06.2021 в 09:48
Serge_007 Дата: Вторник, 01.06.2021, 09:49 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
Здравствуйте

Так надо?
Код
=ГПР(B22;C$3:I$18;ПОИСКПОЗ(C22;B$3:B$18;);)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Так надо?
Код
=ГПР(B22;C$3:I$18;ПОИСКПОЗ(C22;B$3:B$18;);)

Автор - Serge_007
Дата добавления - 01.06.2021 в 09:49
Pelena Дата: Вторник, 01.06.2021, 10:01 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 17625
Репутация: 3925 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
До кучи: формула прямого подсчёта Т маз. при Тхв без промежуточной таблицы
Код
=ИНДЕКС($C$4:$I$18;ПОИСКПОЗ(ОКРУГЛТ($C24;0,5);$B$4:$B$18);ПОИСКПОЗ($C26;$C$3:$I$3;-1))
К сообщению приложен файл: 5209613.xlsx(12.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеДо кучи: формула прямого подсчёта Т маз. при Тхв без промежуточной таблицы
Код
=ИНДЕКС($C$4:$I$18;ПОИСКПОЗ(ОКРУГЛТ($C24;0,5);$B$4:$B$18);ПОИСКПОЗ($C26;$C$3:$I$3;-1))

Автор - Pelena
Дата добавления - 01.06.2021 в 10:01
duckky Дата: Вторник, 01.06.2021, 11:44 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо за варианты, у меня почему-то 2 раза создалась тема(

Все варианты отличные, про ГПР, что-то не подумал даже
 
Ответить
СообщениеСпасибо за варианты, у меня почему-то 2 раза создалась тема(

Все варианты отличные, про ГПР, что-то не подумал даже

Автор - duckky
Дата добавления - 01.06.2021 в 11:44
duckky Дата: Вторник, 01.06.2021, 11:55 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
@pelena, а если бы у меня список был бы не отсортирован по уменьшению в столбце, тогда мне в вашей формуле в конце использовать не -1, а 0? и может мне луще произвести округление температуры?

Потому что у вас в формуле, если подставить 14, то вариант не меняется.

Код
=ИНДЕКС($C$4:$I$18;ПОИСКПОЗ(ОКРУГЛТ($C31;0,5);$B$4:$B$18);ПОИСКПОЗ(ОКРУГЛТ($C33;10);$C$3:$I$3;0))


Сообщение отредактировал duckky - Вторник, 01.06.2021, 11:56
 
Ответить
Сообщение@pelena, а если бы у меня список был бы не отсортирован по уменьшению в столбце, тогда мне в вашей формуле в конце использовать не -1, а 0? и может мне луще произвести округление температуры?

Потому что у вас в формуле, если подставить 14, то вариант не меняется.

Код
=ИНДЕКС($C$4:$I$18;ПОИСКПОЗ(ОКРУГЛТ($C31;0,5);$B$4:$B$18);ПОИСКПОЗ(ОКРУГЛТ($C33;10);$C$3:$I$3;0))

Автор - duckky
Дата добавления - 01.06.2021 в 11:55
Serge_007 Дата: Вторник, 01.06.2021, 12:23 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
если подставить 14, то вариант не меняется
А почему он должен меняться, если диапазон от 10-и до 20-и?
И 14, и 18 в него входят

в конце использовать не -1, а 0
0 - это точное совпадение, оно Вам не подойдет в данной задаче

список был бы не отсортирован по уменьшению
Список должен быть отсортирован в ту или другую сторону


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
если подставить 14, то вариант не меняется
А почему он должен меняться, если диапазон от 10-и до 20-и?
И 14, и 18 в него входят

в конце использовать не -1, а 0
0 - это точное совпадение, оно Вам не подойдет в данной задаче

список был бы не отсортирован по уменьшению
Список должен быть отсортирован в ту или другую сторону

Автор - Serge_007
Дата добавления - 01.06.2021 в 12:23
duckky Дата: Вторник, 01.06.2021, 15:43 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
А почему он должен меняться, если диапазон от 10-и до 20-и?
И 14, и 18 в него входят


Может потому что 14 ближе к 10, а 18 к 20. Я бы так в ручную выбирал бы.
 
Ответить
Сообщение
А почему он должен меняться, если диапазон от 10-и до 20-и?
И 14, и 18 в него входят


Может потому что 14 ближе к 10, а 18 к 20. Я бы так в ручную выбирал бы.

Автор - duckky
Дата добавления - 01.06.2021 в 15:43
Serge_007 Дата: Вторник, 01.06.2021, 16:40 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
14 ближе к 10, а 18 к 20
В таком случае ПОИСКПОЗ() Вам не подойдет, как и ПРОСМОТР(), ГПР() и ВПР()


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
14 ближе к 10, а 18 к 20
В таком случае ПОИСКПОЗ() Вам не подойдет, как и ПРОСМОТР(), ГПР() и ВПР()

Автор - Serge_007
Дата добавления - 01.06.2021 в 16:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Индекс+поискпоз из разных таблиц (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!