Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/учесть фактическое время пребывания участника на семинаре - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » учесть фактическое время пребывания участника на семинаре (Формулы/Formulas)
учесть фактическое время пребывания участника на семинаре
morselle Дата: Среда, 02.06.2021, 03:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

как прописать формулу так, что бы учитывалось только время фактического пребывания участника на семинаре по расписанию
Т.е. семинар начинается в 02:30 заканчивается в 04:30
Сама конференция запущенна в 02:15 и закончена в 04:45
Человек "приступил" к семинару в 02:46:00, «вышел» в 03:30:00, также можно учесть, что его разъединило и "приступил" повторно 03:32:00 "вышел" 04:30:00
К сообщению приложен файл: 7556379.xls(29.0 Kb)
 
Ответить
Сообщениекак прописать формулу так, что бы учитывалось только время фактического пребывания участника на семинаре по расписанию
Т.е. семинар начинается в 02:30 заканчивается в 04:30
Сама конференция запущенна в 02:15 и закончена в 04:45
Человек "приступил" к семинару в 02:46:00, «вышел» в 03:30:00, также можно учесть, что его разъединило и "приступил" повторно 03:32:00 "вышел" 04:30:00

Автор - morselle
Дата добавления - 02.06.2021 в 03:12
amfor Дата: Среда, 02.06.2021, 06:59 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 211
Репутация: 64 ±
Замечаний: 0% ±

Excel 2016
И Вам добрый день.Как понял.
В Е6
Код
=ЕСЛИ(B6>$B$3;C6-B6;C6-$B$3)

В Н6
Код
=СУММЕСЛИ($A$6:$A$9;G6;$E$6:$E$9)
К сообщению приложен файл: 4936592.xls(29.5 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеИ Вам добрый день.Как понял.
В Е6
Код
=ЕСЛИ(B6>$B$3;C6-B6;C6-$B$3)

В Н6
Код
=СУММЕСЛИ($A$6:$A$9;G6;$E$6:$E$9)

Автор - amfor
Дата добавления - 02.06.2021 в 06:59
Светлый Дата: Среда, 02.06.2021, 07:35 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1617
Репутация: 426 ±
Замечаний: 0% ±

Excel 2010, 2013
И Вам, здравствуйте!
Код
=СУММПРОИЗВ((C$6:C$11+C$3-ABS(C$6:C$11-C$3)-B$6:B$11-B$3-ABS(B$6:B$11-B$3))/2*(A$6:A$11=G6))
*Суммирует только время на семинаре, а не всё время подключения. Если надо всё, то в C$3 и B$3 "3" заменить на "2".
**Или немного упростить:
Код
=СУММПРОИЗВ(((B$6:C$11+B$3:C$3)*{-1;1}-ABS(B$6:C$11-B$3:C$3))*(A$6:A$11=G6))/2


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 02.06.2021, 08:12
 
Ответить
СообщениеИ Вам, здравствуйте!
Код
=СУММПРОИЗВ((C$6:C$11+C$3-ABS(C$6:C$11-C$3)-B$6:B$11-B$3-ABS(B$6:B$11-B$3))/2*(A$6:A$11=G6))
*Суммирует только время на семинаре, а не всё время подключения. Если надо всё, то в C$3 и B$3 "3" заменить на "2".
**Или немного упростить:
Код
=СУММПРОИЗВ(((B$6:C$11+B$3:C$3)*{-1;1}-ABS(B$6:C$11-B$3:C$3))*(A$6:A$11=G6))/2

Автор - Светлый
Дата добавления - 02.06.2021 в 07:35
morselle Дата: Среда, 02.06.2021, 10:44 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день и здравствуйте :)
Прочитал в правилах форума, не писать лишнее «Помогите…» «спасите…» pray , а именно так и хотелось))
Спасибо большое, это выгладить как фаталити respect , отличное решение!
А возможно ли учесть тех же людей, но уже по датам? :prof:
К сообщению приложен файл: _4936592.xls(32.5 Kb)
 
Ответить
СообщениеДобрый день и здравствуйте :)
Прочитал в правилах форума, не писать лишнее «Помогите…» «спасите…» pray , а именно так и хотелось))
Спасибо большое, это выгладить как фаталити respect , отличное решение!
А возможно ли учесть тех же людей, но уже по датам? :prof:

Автор - morselle
Дата добавления - 02.06.2021 в 10:44
amfor Дата: Среда, 02.06.2021, 11:47 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 211
Репутация: 64 ±
Замечаний: 0% ±

Excel 2016
Так?
Код
=СУММПРОИЗВ(($D$6:$D$13+$D$3-ABS($D$6:$D$13-$D$3)-$C$6:$C$13-$C$3-ABS($C$6:$C$13-$C$3))/2*($A$6:$A$13=$H6)*($B$6:$B$13=--ПРАВСИМВ(K$5;10)))
К сообщению приложен файл: 6235343.xls(33.5 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеТак?
Код
=СУММПРОИЗВ(($D$6:$D$13+$D$3-ABS($D$6:$D$13-$D$3)-$C$6:$C$13-$C$3-ABS($C$6:$C$13-$C$3))/2*($A$6:$A$13=$H6)*($B$6:$B$13=--ПРАВСИМВ(K$5;10)))

Автор - amfor
Дата добавления - 02.06.2021 в 11:47
morselle Дата: Среда, 02.06.2021, 13:19 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Больше спасибо, именно так, как хотелось бы! pray off_top amfor,
 
Ответить
СообщениеБольше спасибо, именно так, как хотелось бы! pray off_top amfor,

Автор - morselle
Дата добавления - 02.06.2021 в 13:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » учесть фактическое время пребывания участника на семинаре (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!