Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск текста в обратном направлении - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск текста в обратном направлении (Формулы/Formulas)
Поиск текста в обратном направлении
4step Дата: Четверг, 03.06.2021, 15:58 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!

Подскажите пожалуйста, как можно переделать формулу, чтобы поиск "*ТУ" искал в обратном направлении?
Поиск "ТУ*""ОСТ*""ГОСТ*"" работает, а в обратном направлении *ТУ" нет.
К сообщению приложен файл: 2849560.xlsx(10.2 Kb)
 
Ответить
СообщениеДобрый день!

Подскажите пожалуйста, как можно переделать формулу, чтобы поиск "*ТУ" искал в обратном направлении?
Поиск "ТУ*""ОСТ*""ГОСТ*"" работает, а в обратном направлении *ТУ" нет.

Автор - 4step
Дата добавления - 03.06.2021 в 15:58
Serge_007 Дата: Четверг, 03.06.2021, 16:51 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14490
Репутация: 2390 ±
Замечаний: ±

Excel 2010
Здравствуйте

Поиск "ТУ*""ОСТ*""ГОСТ*"" работает, а в обратном направлении *ТУ" нет
Не работает у Вас поиск ни в каком направлении
Ваша формула считает количество вхождений значений ячеек в диапазон
Синтаксис "ГОСТ*""ОСТ*""ТУ*""*ТУ" в
Код
=ПОИСК("ГОСТ*""ОСТ*""ТУ*""*ТУ";$A:$A)
недопустим, поэтому в формуле работает только та часть, которая после знака умножения
Код
=ЕЧИСЛО(ПОИСКПОЗ($A:$A;$A2;0))


Правильная формула:
Код
=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК({"ОСТ*";"*ТУ*"};A2)))>0
К сообщению приложен файл: 20210603_4step.xls(31.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Поиск "ТУ*""ОСТ*""ГОСТ*"" работает, а в обратном направлении *ТУ" нет
Не работает у Вас поиск ни в каком направлении
Ваша формула считает количество вхождений значений ячеек в диапазон
Синтаксис "ГОСТ*""ОСТ*""ТУ*""*ТУ" в
Код
=ПОИСК("ГОСТ*""ОСТ*""ТУ*""*ТУ";$A:$A)
недопустим, поэтому в формуле работает только та часть, которая после знака умножения
Код
=ЕЧИСЛО(ПОИСКПОЗ($A:$A;$A2;0))


Правильная формула:
Код
=СУММПРОИЗВ(--ЕЧИСЛО(ПОИСК({"ОСТ*";"*ТУ*"};A2)))>0

Автор - Serge_007
Дата добавления - 03.06.2021 в 16:51
4step Дата: Пятница, 04.06.2021, 02:16 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Serge_007,
Я немного не так выразил задачу. Нужно чтобы дубликаты выделялись, кроме текста который начинается с
ТУ...;
...ТУ;
... ТУ;
ОСТ...;
ГОСТ...

Ранее "выделятор" по тексту все же выделял "ТУ" который располагался в конце текста:
ОЖО.467.180 ТУ или ОЖО.467.180ТУ.
А в остальных случаях ТУ*, ГОСТ*, ОСТ* работал как надо.

Не знаю как решить эту задачу.
К сообщению приложен файл: _3.xls(31.0 Kb)


Сообщение отредактировал 4step - Пятница, 04.06.2021, 02:24
 
Ответить
СообщениеSerge_007,
Я немного не так выразил задачу. Нужно чтобы дубликаты выделялись, кроме текста который начинается с
ТУ...;
...ТУ;
... ТУ;
ОСТ...;
ГОСТ...

Ранее "выделятор" по тексту все же выделял "ТУ" который располагался в конце текста:
ОЖО.467.180 ТУ или ОЖО.467.180ТУ.
А в остальных случаях ТУ*, ГОСТ*, ОСТ* работал как надо.

Не знаю как решить эту задачу.

Автор - 4step
Дата добавления - 04.06.2021 в 02:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск текста в обратном направлении (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!