Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Связь данных в столбцах с одинаковым названием - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Связь данных в столбцах с одинаковым названием (Формулы/Formulas)
Связь данных в столбцах с одинаковым названием
VadimSh Дата: Воскресенье, 13.06.2021, 16:30 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Добрый день. Необходимо сделать ведомость физической подготовки с расчетом полученных баллов за каждое упражнение. Не получается связать баллы в ведомости и нормативах по названию упражнения в столбцах (не по номеру ячейки, а сравнить название упражнения в соответствующем столбце ведомости, найти небходимый результат в столбце с таким же названием упражнения в нормативах и подставить набранные баллы. Пробывал использовать ПРОСМОТР, ИНДЕКС, ПОИСКПОЗ, но пока не выходит.
И второй вопрос: в упражнениях на скорость некорректно считает баллы или выдает ошибку. Насколько понял это связано с тем, что в просматриваемом диапазоне функции ПРОСМОТР значения уменьшаются. Как можно это обойти. Заранее спасибо
К сообщению приложен файл: 4169281.xls(61.0 Kb)
 
Ответить
СообщениеДобрый день. Необходимо сделать ведомость физической подготовки с расчетом полученных баллов за каждое упражнение. Не получается связать баллы в ведомости и нормативах по названию упражнения в столбцах (не по номеру ячейки, а сравнить название упражнения в соответствующем столбце ведомости, найти небходимый результат в столбце с таким же названием упражнения в нормативах и подставить набранные баллы. Пробывал использовать ПРОСМОТР, ИНДЕКС, ПОИСКПОЗ, но пока не выходит.
И второй вопрос: в упражнениях на скорость некорректно считает баллы или выдает ошибку. Насколько понял это связано с тем, что в просматриваемом диапазоне функции ПРОСМОТР значения уменьшаются. Как можно это обойти. Заранее спасибо

Автор - VadimSh
Дата добавления - 13.06.2021 в 16:30
прохожий2019 Дата: Воскресенье, 13.06.2021, 18:07 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 616
Репутация: 142 ±
Замечаний: 0% ±

365 Beta Channel
только обратите внимание, что названия столбцов были именно одинаковыми - без пробелов всяких как в отжимании
Код
=ИНДЕКС('Нормативы физо'!$A$5:$A$100;ПОИСКПОЗ(C10;ИНДЕКС('Нормативы физо'!$B$5:$F$100;;ПОИСКПОЗ(C$8;'Нормативы физо'!$B$4:$F$4;));1))
К сообщению приложен файл: 6279240.xls(71.0 Kb)
 
Ответить
Сообщениетолько обратите внимание, что названия столбцов были именно одинаковыми - без пробелов всяких как в отжимании
Код
=ИНДЕКС('Нормативы физо'!$A$5:$A$100;ПОИСКПОЗ(C10;ИНДЕКС('Нормативы физо'!$B$5:$F$100;;ПОИСКПОЗ(C$8;'Нормативы физо'!$B$4:$F$4;));1))

Автор - прохожий2019
Дата добавления - 13.06.2021 в 18:07
VadimSh Дата: Воскресенье, 13.06.2021, 19:26 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
прохожий2019, спасибо большое
 
Ответить
Сообщениепрохожий2019, спасибо большое

Автор - VadimSh
Дата добавления - 13.06.2021 в 19:26
jakim Дата: Воскресенье, 13.06.2021, 21:31 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1015
Репутация: 277 ±
Замечаний: 0% ±

Excel 2010
Предлагаю такую формулу

Код
=IFERROR(LOOKUP(C10;1/(C10='Нормативы физо1'!B$5:B$100);'Нормативы физо1'!A$5:A$100);100)
К сообщению приложен файл: 5508045.xls(52.0 Kb)
 
Ответить
Сообщение
Предлагаю такую формулу

Код
=IFERROR(LOOKUP(C10;1/(C10='Нормативы физо1'!B$5:B$100);'Нормативы физо1'!A$5:A$100);100)

Автор - jakim
Дата добавления - 13.06.2021 в 21:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Связь данных в столбцах с одинаковым названием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!