Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Неполная фиксация ячейки с условием - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Неполная фиксация ячейки с условием (Формулы/Formulas)
Неполная фиксация ячейки с условием
oksanagolotvina Дата: Вторник, 29.06.2021, 20:58 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Есть два листа с данными. На первом листе нужно сделать пропорциональный расчет в зависимости от цифры на втором листе.
На втором листе стоит цифра на сколько ячеек нужно распределить цифры
Использовала фиксацию ячейки с строки
Код
=ЕСЛИ(Лист2!$A$1>=СТРОКА(Лист2!D1)-СТРОКА(Лист2!D$1)+1;($S1/Лист2!$B$1*Лист2!D$1);"-")


Необходимо чтобы фиксация переходила на другую строку
К сообщению приложен файл: 22.xlsx(12.0 Kb)
 
Ответить
СообщениеЕсть два листа с данными. На первом листе нужно сделать пропорциональный расчет в зависимости от цифры на втором листе.
На втором листе стоит цифра на сколько ячеек нужно распределить цифры
Использовала фиксацию ячейки с строки
Код
=ЕСЛИ(Лист2!$A$1>=СТРОКА(Лист2!D1)-СТРОКА(Лист2!D$1)+1;($S1/Лист2!$B$1*Лист2!D$1);"-")


Необходимо чтобы фиксация переходила на другую строку

Автор - oksanagolotvina
Дата добавления - 29.06.2021 в 20:58
Nic70y Дата: Среда, 30.06.2021, 08:28 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6932
Репутация: 1599 ±
Замечаний: 0% ±

Excel 2010
ниче не понял.
вдруг правильно
Код
=ЕСЛИОШИБКА($S1/ИНДЕКС(Лист2!$B$1:$B$30;ПОИСКПОЗ(9E+307;Лист2!$A$1:$A$30)-СЧЁТЕСЛИ(Лист2!$A$1:$A$30;">="&СТРОКА())+1)*ИНДЕКС(Лист2!D$1:D$30;ПОИСКПОЗ(9E+307;Лист2!$A$1:$A$30)-СЧЁТЕСЛИ(Лист2!$A$1:$A$30;">="&СТРОКА())+1);"-")
К сообщению приложен файл: 23.xlsx(12.2 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениениче не понял.
вдруг правильно
Код
=ЕСЛИОШИБКА($S1/ИНДЕКС(Лист2!$B$1:$B$30;ПОИСКПОЗ(9E+307;Лист2!$A$1:$A$30)-СЧЁТЕСЛИ(Лист2!$A$1:$A$30;">="&СТРОКА())+1)*ИНДЕКС(Лист2!D$1:D$30;ПОИСКПОЗ(9E+307;Лист2!$A$1:$A$30)-СЧЁТЕСЛИ(Лист2!$A$1:$A$30;">="&СТРОКА())+1);"-")

Автор - Nic70y
Дата добавления - 30.06.2021 в 08:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Неполная фиксация ячейки с условием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!