Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Распределение сумм - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределение сумм (Формулы/Formulas)
Распределение сумм
Miyagi88 Дата: Понедельник, 19.07.2021, 10:18 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Помогите пожалуйста распределить сумму, список длинный, чтоб формула искала имя и ниже сумму месяца распределели по ячейкам. Пример прилагаю.
К сообщению приложен файл: 7313588.xlsx(12.3 Kb)
 
Ответить
СообщениеПомогите пожалуйста распределить сумму, список длинный, чтоб формула искала имя и ниже сумму месяца распределели по ячейкам. Пример прилагаю.

Автор - Miyagi88
Дата добавления - 19.07.2021 в 10:18
Nic70y Дата: Понедельник, 19.07.2021, 10:56 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7117
Репутация: 1641 ±
Замечаний: 0% ±

Excel 2010
вариант
с доп.столбцом,
убрал г.,
условие имена должны идти по-порядку - как в примере
К сообщению приложен файл: 32.xlsx(13.3 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениевариант
с доп.столбцом,
убрал г.,
условие имена должны идти по-порядку - как в примере

Автор - Nic70y
Дата добавления - 19.07.2021 в 10:56
Светлый Дата: Понедельник, 19.07.2021, 11:31 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1708
Репутация: 457 ±
Замечаний: 0% ±

Excel 2013, 2016
Без дополнительных, но имена не должны быть второй раз.
Код
=СУММПРОИЗВ((G$2&" "&ЛЕВБ(ПРОСМОТР("яяя";$G$1:G$1);4)=ИНДЕКС($A:$A;ПОИСКПОЗ($E3;$A:$A;)):ИНДЕКС($A:$A;ЕСЛИОШИБКА(ПОИСКПОЗ($E3;$A:$A;)-1+АГРЕГАТ(15;6;ПОИСКПОЗ($E$3:$F$7;ИНДЕКС($A:$A;ПОИСКПОЗ($E3;$A:$A;)+1):$A$999;);1);99)))*ИНДЕКС($B:$B;ПОИСКПОЗ($E3;$A:$A;)):ИНДЕКС($B:$B;ЕСЛИОШИБКА(ПОИСКПОЗ($E3;$A:$A;)-1+АГРЕГАТ(15;6;ПОИСКПОЗ($E$3:$F$7;ИНДЕКС($A:$A;ПОИСКПОЗ($E3;$A:$A;)+1):$A$999;);1);99)))
*Немного упростил. Формула массива:
Код
=СУММ((СТРОКА($1:$99)>ПОИСКПОЗ($E3;$A:$A;))*(СТРОКА($1:$99)<ЕСЛИОШИБКА(АГРЕГАТ(15;6;ЕСЛИ(ПОИСКПОЗ($E$3:$E$7;$A:$A;)>ПОИСКПОЗ($E3;$A:$A;);ПОИСКПОЗ($E$3:$E$7;$A:$A;));1);99))*((G$2&" "&ЛЕВБ(ПРОСМОТР("яяя";$G$1:G$1);4)=$A$1:$A$99))*$B$1:$B$99)
К сообщению приложен файл: 7313588-1.xlsx(13.1 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 19.07.2021, 14:00
 
Ответить
СообщениеБез дополнительных, но имена не должны быть второй раз.
Код
=СУММПРОИЗВ((G$2&" "&ЛЕВБ(ПРОСМОТР("яяя";$G$1:G$1);4)=ИНДЕКС($A:$A;ПОИСКПОЗ($E3;$A:$A;)):ИНДЕКС($A:$A;ЕСЛИОШИБКА(ПОИСКПОЗ($E3;$A:$A;)-1+АГРЕГАТ(15;6;ПОИСКПОЗ($E$3:$F$7;ИНДЕКС($A:$A;ПОИСКПОЗ($E3;$A:$A;)+1):$A$999;);1);99)))*ИНДЕКС($B:$B;ПОИСКПОЗ($E3;$A:$A;)):ИНДЕКС($B:$B;ЕСЛИОШИБКА(ПОИСКПОЗ($E3;$A:$A;)-1+АГРЕГАТ(15;6;ПОИСКПОЗ($E$3:$F$7;ИНДЕКС($A:$A;ПОИСКПОЗ($E3;$A:$A;)+1):$A$999;);1);99)))
*Немного упростил. Формула массива:
Код
=СУММ((СТРОКА($1:$99)>ПОИСКПОЗ($E3;$A:$A;))*(СТРОКА($1:$99)<ЕСЛИОШИБКА(АГРЕГАТ(15;6;ЕСЛИ(ПОИСКПОЗ($E$3:$E$7;$A:$A;)>ПОИСКПОЗ($E3;$A:$A;);ПОИСКПОЗ($E$3:$E$7;$A:$A;));1);99))*((G$2&" "&ЛЕВБ(ПРОСМОТР("яяя";$G$1:G$1);4)=$A$1:$A$99))*$B$1:$B$99)

Автор - Светлый
Дата добавления - 19.07.2021 в 11:31
Miyagi88 Дата: Понедельник, 19.07.2021, 11:38 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
ТОВАРИЩИ СПАСИБО ВАМ ОГРОМНОЕ, ДАЙ БОГ ЗДОРОВЬЯ ВАМ!!!!!!!!!!!!!
 
Ответить
СообщениеТОВАРИЩИ СПАСИБО ВАМ ОГРОМНОЕ, ДАЙ БОГ ЗДОРОВЬЯ ВАМ!!!!!!!!!!!!!

Автор - Miyagi88
Дата добавления - 19.07.2021 в 11:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Распределение сумм (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!