Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Разбить людей по группам в новой таблице. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разбить людей по группам в новой таблице. (Формулы/Formulas)
Разбить людей по группам в новой таблице.
Cepreu-d Дата: Вторник, 20.07.2021, 08:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Добрый день. Помогите с реализацией следующей задачи. Нужно отсортировать людей по помещениям, например Петров находится в 21 помещении, его строка переносится на лист с номером помещения.

р.s. приложить файл не могу, так как рабочий комп без выхода в интернет, пишу с телефона.
К сообщению приложен файл: 9997543.jpg(56.5 Kb) · 0465269.jpg(57.6 Kb)


Сообщение отредактировал Cepreu-d - Вторник, 20.07.2021, 09:05
 
Ответить
СообщениеДобрый день. Помогите с реализацией следующей задачи. Нужно отсортировать людей по помещениям, например Петров находится в 21 помещении, его строка переносится на лист с номером помещения.

р.s. приложить файл не могу, так как рабочий комп без выхода в интернет, пишу с телефона.

Автор - Cepreu-d
Дата добавления - 20.07.2021 в 08:49
Almost Дата: Вторник, 20.07.2021, 15:20 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 37
Репутация: 2 ±
Замечаний: 0% ±

Excel 2013
Cepreu-d,
Если задача разовая, то проще скопировать лист исходного списка по количеству помещений, каждую копию отфильтровать и удалить лишние строки и столбцы.
Если задача регулярная, то я бы те же самые ручные действия записал в макрос.
 
Ответить
СообщениеCepreu-d,
Если задача разовая, то проще скопировать лист исходного списка по количеству помещений, каждую копию отфильтровать и удалить лишние строки и столбцы.
Если задача регулярная, то я бы те же самые ручные действия записал в макрос.

Автор - Almost
Дата добавления - 20.07.2021 в 15:20
NikitaDvorets Дата: Вторник, 20.07.2021, 15:59 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 251
Репутация: 41 ±
Замечаний: 0% ±

Excel 2019
Цитата
Если задача регулярная


Предположение - это разовая задача. Какой смысл каждый раз создавать "сводную"/исходную таблицу для последующего разнесения этих данных по таблицам помещений?
 
Ответить
Сообщение
Цитата
Если задача регулярная


Предположение - это разовая задача. Какой смысл каждый раз создавать "сводную"/исходную таблицу для последующего разнесения этих данных по таблицам помещений?

Автор - NikitaDvorets
Дата добавления - 20.07.2021 в 15:59
Cepreu-d Дата: Среда, 21.07.2021, 09:06 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Нет, это не разовая задача. Список будет около 100 фамилий, и люди будут постоянно перемещаться из одного помещения в другое, и посещений больше.

Значит реализация только через написания макроса, имеющимися формулами это никак не реализовать, по примеру проверки плюса в столбце с номером помещения и переноса строчки если + есть.
 
Ответить
СообщениеНет, это не разовая задача. Список будет около 100 фамилий, и люди будут постоянно перемещаться из одного помещения в другое, и посещений больше.

Значит реализация только через написания макроса, имеющимися формулами это никак не реализовать, по примеру проверки плюса в столбце с номером помещения и переноса строчки если + есть.

Автор - Cepreu-d
Дата добавления - 21.07.2021 в 09:06
Egyptian Дата: Среда, 21.07.2021, 10:22 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 186
Репутация: 59 ±
Замечаний: 0% ±

Excel 2013/2016
Сделал для вас пример с простыми формулами. Если подойдет, можете доделать сами по тому же принципу.
К сообщению приложен файл: 0995854.xlsx(16.0 Kb)
 
Ответить
СообщениеСделал для вас пример с простыми формулами. Если подойдет, можете доделать сами по тому же принципу.

Автор - Egyptian
Дата добавления - 21.07.2021 в 10:22
Cepreu-d Дата: Среда, 21.07.2021, 16:49 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Сделал для вас пример с простыми формулами.

Спасибо большое, но видимо не будет у меня работать на версии 97-2003 нет функции AGGREGATE.
 
Ответить
Сообщение
Сделал для вас пример с простыми формулами.

Спасибо большое, но видимо не будет у меня работать на версии 97-2003 нет функции AGGREGATE.

Автор - Cepreu-d
Дата добавления - 21.07.2021 в 16:49
Egyptian Дата: Среда, 21.07.2021, 17:33 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 186
Репутация: 59 ±
Замечаний: 0% ±

Excel 2013/2016
Сделал с олдскульными формулами, должно работать в MSO2003
К сообщению приложен файл: 1789183.xls(69.5 Kb)


Сообщение отредактировал Egyptian - Среда, 21.07.2021, 17:37
 
Ответить
СообщениеСделал с олдскульными формулами, должно работать в MSO2003

Автор - Egyptian
Дата добавления - 21.07.2021 в 17:33
Serge_007 Дата: Среда, 21.07.2021, 17:52 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 14578
Репутация: 2408 ±
Замечаний: ±

Excel 2010
не будет у меня работать на версии 97-2003
Так будет работать:
Код
=ИНДЕКС(Список!D5:D13;СУММПРОИЗВ((Список!E5:H13="+")*СТРОКА(1:9)*(D2=Список!E4:H4)*СТОЛБЕЦ(A:D)))
К сообщению приложен файл: 20210721_Cepreu.xls(78.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
не будет у меня работать на версии 97-2003
Так будет работать:
Код
=ИНДЕКС(Список!D5:D13;СУММПРОИЗВ((Список!E5:H13="+")*СТРОКА(1:9)*(D2=Список!E4:H4)*СТОЛБЕЦ(A:D)))

Автор - Serge_007
Дата добавления - 21.07.2021 в 17:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Разбить людей по группам в новой таблице. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!