Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сцепить непустые ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сцепить непустые ячейки (Формулы/Formulas)
Сцепить непустые ячейки
Tallen Дата: Среда, 25.08.2021, 12:48 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте, уважаемые специалисты Excel!
Помогите пожалуйста исправить формулу в столбце G (а может там нужна совершенно другая..?), чтобы сцеплялись только непустые значения ячеек. На ПК Excel 2007
К сообщению приложен файл: __.xlsx(10.7 Kb)


Сообщение отредактировал Tallen - Среда, 25.08.2021, 12:50
 
Ответить
СообщениеЗдравствуйте, уважаемые специалисты Excel!
Помогите пожалуйста исправить формулу в столбце G (а может там нужна совершенно другая..?), чтобы сцеплялись только непустые значения ячеек. На ПК Excel 2007

Автор - Tallen
Дата добавления - 25.08.2021 в 12:48
bigor Дата: Среда, 25.08.2021, 13:10 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 492
Репутация: 94 ±
Замечаний: 0% ±

нет
Добрый день

примерно так

Код
=IF(F4>0;$B$1&" "&F4&" в т.ч.  "&IF(B4>0;$B$2&" - "&B4&" ";"")&IF(C4>0;$C$2&" - "&C4&" ";"")&IF(D4>0;$D$2&" - "&D4&" ";"")&IF(E4>0;$E$2&" - "&E4&" ";"");"")


Сообщение отредактировал bigor - Среда, 25.08.2021, 13:11
 
Ответить
СообщениеДобрый день

примерно так

Код
=IF(F4>0;$B$1&" "&F4&" в т.ч.  "&IF(B4>0;$B$2&" - "&B4&" ";"")&IF(C4>0;$C$2&" - "&C4&" ";"")&IF(D4>0;$D$2&" - "&D4&" ";"")&IF(E4>0;$E$2&" - "&E4&" ";"");"")

Автор - bigor
Дата добавления - 25.08.2021 в 13:10
Serge_007 Дата: Среда, 25.08.2021, 13:11 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14486
Репутация: 2390 ±
Замечаний: ±

Excel 2010
Здравствуйте

Код
=ЕСЛИ(F3=0;"";B$1&": "&$F3&", в т.ч.: "&ЕСЛИ(B3="";"";B$2&" - "&B3&"; ")&ЕСЛИ(C3="";"";C$2&" - "&C3&"; ")&ЕСЛИ(D3="";"";D$2&" - "&D3&"; ")&ЕСЛИ(E3="";"";E$2&" - "&E3&"; "))
К сообщению приложен файл: 20210825_Tallen.xls(47.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ЕСЛИ(F3=0;"";B$1&": "&$F3&", в т.ч.: "&ЕСЛИ(B3="";"";B$2&" - "&B3&"; ")&ЕСЛИ(C3="";"";C$2&" - "&C3&"; ")&ЕСЛИ(D3="";"";D$2&" - "&D3&"; ")&ЕСЛИ(E3="";"";E$2&" - "&E3&"; "))

Автор - Serge_007
Дата добавления - 25.08.2021 в 13:11
Tallen Дата: Среда, 25.08.2021, 13:24 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Serge_007, спасибо большое! Именно это и нужно мне для полного счастья! ))
 
Ответить
СообщениеSerge_007, спасибо большое! Именно это и нужно мне для полного счастья! ))

Автор - Tallen
Дата добавления - 25.08.2021 в 13:24
Tallen Дата: Среда, 25.08.2021, 13:27 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
bigor, спасибо!
 
Ответить
Сообщениеbigor, спасибо!

Автор - Tallen
Дата добавления - 25.08.2021 в 13:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сцепить непустые ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!