Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка значений по дате - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений по дате
Подстановка значений по дате
Gopronotmore Дата: Четверг, 02.09.2021, 14:08 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Уважаемые формучане, подскажите,

столкнулся с проблемой. Есть массив данных с датами и номерами договоров.

Как сделать через формулу массива, что бы при заданной дате попадали все значения из массива.

Файл прилагаю
К сообщению приложен файл: 2432730.xlsx(9.7 Kb)
 
Ответить
СообщениеУважаемые формучане, подскажите,

столкнулся с проблемой. Есть массив данных с датами и номерами договоров.

Как сделать через формулу массива, что бы при заданной дате попадали все значения из массива.

Файл прилагаю

Автор - Gopronotmore
Дата добавления - 02.09.2021 в 14:08
Gopronotmore Дата: Четверг, 02.09.2021, 14:25 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Не в ту тему написал, перенесите пожалуйста топик в Вопросы по Excel
 
Ответить
СообщениеНе в ту тему написал, перенесите пожалуйста топик в Вопросы по Excel

Автор - Gopronotmore
Дата добавления - 02.09.2021 в 14:25
китин Дата: Четверг, 02.09.2021, 14:29 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6538
Репутация: 997 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
как то так.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$49;НАИМЕНЬШИЙ(ЕСЛИ($H$4=$A$2:$A$49;СТРОКА($A$2:$A$49)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
только увидел: у вас действительно Excel для Mac или вы не в ту тему запостили?
[moder]тему перенес[/moder]
К сообщению приложен файл: 8739865.xlsx(10.6 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Четверг, 02.09.2021, 14:30
 
Ответить
Сообщениекак то так.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$49;НАИМЕНЬШИЙ(ЕСЛИ($H$4=$A$2:$A$49;СТРОКА($A$2:$A$49)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
только увидел: у вас действительно Excel для Mac или вы не в ту тему запостили?
[moder]тему перенес[/moder]

Автор - китин
Дата добавления - 02.09.2021 в 14:29
Gopronotmore Дата: Четверг, 02.09.2021, 14:51 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
А подскажите, что-то я не понимаю, почему если менять диапазон даных, то формула перестает работать
К сообщению приложен файл: 8739865-1-.xlsx(9.8 Kb)
 
Ответить
СообщениеА подскажите, что-то я не понимаю, почему если менять диапазон даных, то формула перестает работать

Автор - Gopronotmore
Дата добавления - 02.09.2021 в 14:51
Serge_007 Дата: Четверг, 02.09.2021, 14:55 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 14486
Репутация: 2390 ±
Замечаний: ±

Excel 2010
Код
=ИНДЕКС(A$5:A$17;НАИМЕНЬШИЙ(ЕСЛИ(L$7=E$5:E$17;СТРОКА($1:$13));СТРОКА(A1)))


О том как работает эта формула:
Извлечение уникальных значений формулами
К сообщению приложен файл: 20210902_Gopron.xls(66.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=ИНДЕКС(A$5:A$17;НАИМЕНЬШИЙ(ЕСЛИ(L$7=E$5:E$17;СТРОКА($1:$13));СТРОКА(A1)))


О том как работает эта формула:
Извлечение уникальных значений формулами

Автор - Serge_007
Дата добавления - 02.09.2021 в 14:55
Nic70y Дата: Четверг, 02.09.2021, 14:56 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7034
Репутация: 1627 ±
Замечаний: 0% ±

Excel 2010
через формулу массива
а чего так?
немассивная
Код
=ИНДЕКС(B$1:B$18000;ПОИСКПОЗ(H$4;ИНДЕКС(A$1:A$18000;ПОИСКПОЗ(I3;B$1:B$18000;)+1):A$18000;)+ПОИСКПОЗ(I3;B$1:B$18000;))
К сообщению приложен файл: 37.xlsx(9.7 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
через формулу массива
а чего так?
немассивная
Код
=ИНДЕКС(B$1:B$18000;ПОИСКПОЗ(H$4;ИНДЕКС(A$1:A$18000;ПОИСКПОЗ(I3;B$1:B$18000;)+1):A$18000;)+ПОИСКПОЗ(I3;B$1:B$18000;))

Автор - Nic70y
Дата добавления - 02.09.2021 в 14:56
Gopronotmore Дата: Четверг, 02.09.2021, 14:59 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Serge_007, получается что бы массив правильно построить он должен начинаться с 1 строки, и количество строк в нем это количество заполненных ячеек, я правильно понимаю?
 
Ответить
СообщениеSerge_007, получается что бы массив правильно построить он должен начинаться с 1 строки, и количество строк в нем это количество заполненных ячеек, я правильно понимаю?

Автор - Gopronotmore
Дата добавления - 02.09.2021 в 14:59
jakim Дата: Четверг, 02.09.2021, 15:06 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1037
Репутация: 278 ±
Замечаний: 0% ±

Excel 2010
Попробуйте использовать умную таблицу с формулой массива

Код
=IFERROR(INDEX(Table1[Договор];SMALL(IF($H$4=Table1[Дата];ROW($A$2:$A$50)-1);ROW(A1)));"")
К сообщению приложен файл: 6994929.xlsx(11.2 Kb)
 
Ответить
Сообщение
Попробуйте использовать умную таблицу с формулой массива

Код
=IFERROR(INDEX(Table1[Договор];SMALL(IF($H$4=Table1[Дата];ROW($A$2:$A$50)-1);ROW(A1)));"")

Автор - jakim
Дата добавления - 02.09.2021 в 15:06
Serge_007 Дата: Четверг, 02.09.2021, 15:25 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 14486
Репутация: 2390 ±
Замечаний: ±

Excel 2010
что бы массив правильно построить он должен начинаться с 1 строки, и количество строк в нем это количество заполненных ячеек
В общем случае - да


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
что бы массив правильно построить он должен начинаться с 1 строки, и количество строк в нем это количество заполненных ячеек
В общем случае - да

Автор - Serge_007
Дата добавления - 02.09.2021 в 15:25
Gopronotmore Дата: Четверг, 02.09.2021, 15:40 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Nic70y, Спасибо!
 
Ответить
СообщениеNic70y, Спасибо!

Автор - Gopronotmore
Дата добавления - 02.09.2021 в 15:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений по дате
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!