Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Извлечь из 10 колонок повторяющиеся более 3 раз значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечь из 10 колонок повторяющиеся более 3 раз значения (Формулы/Formulas)
Извлечь из 10 колонок повторяющиеся более 3 раз значения
Sergey3705 Дата: Пятница, 03.09.2021, 17:58 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Коллеги, всех приветствую!
Нужна помощь в следующем - есть таблица, в которой, к примеру, 10 колонок в каждой из которых в одной строке находятся разные значения.
Необходимо в 11 колонку записать значение, которое повторяется в первых десяти колонках более 3 раз.
И чтобы количество повторений можно было легко менять самому.
Файл с примером прилагаю.
Заранее большое спасибо за помощь!
К сообщению приложен файл: _--.xlsx(11.5 Kb)
 
Ответить
СообщениеКоллеги, всех приветствую!
Нужна помощь в следующем - есть таблица, в которой, к примеру, 10 колонок в каждой из которых в одной строке находятся разные значения.
Необходимо в 11 колонку записать значение, которое повторяется в первых десяти колонках более 3 раз.
И чтобы количество повторений можно было легко менять самому.
Файл с примером прилагаю.
Заранее большое спасибо за помощь!

Автор - Sergey3705
Дата добавления - 03.09.2021 в 17:58
Pelena Дата: Пятница, 03.09.2021, 18:29 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17873
Репутация: 4019 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=ИНДЕКС(A2:J2;ПОИСКПОЗ(ИСТИНА;(СЧЁТЕСЛИ(A2:J2;A2:J2)>3);0))

А если таких значений несколько?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ИНДЕКС(A2:J2;ПОИСКПОЗ(ИСТИНА;(СЧЁТЕСЛИ(A2:J2;A2:J2)>3);0))

А если таких значений несколько?

Автор - Pelena
Дата добавления - 03.09.2021 в 18:29
Светлый Дата: Пятница, 03.09.2021, 19:02 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1676
Репутация: 447 ±
Замечаний: 0% ±

Excel 2013, 2016
Формула массива:
Код
=--ПРАВБ(МИН(-ТЕКСТ(СЧЁТЕСЛИ(A2:J2;A2:J2)*10^6+A2:J2;"["&L$1&"E6]0;;\0"));6)
только для натуральных положительных чисел до миллиона.
К сообщению приложен файл: S3705.xlsx(11.5 Kb)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 03.09.2021, 19:04
 
Ответить
СообщениеФормула массива:
Код
=--ПРАВБ(МИН(-ТЕКСТ(СЧЁТЕСЛИ(A2:J2;A2:J2)*10^6+A2:J2;"["&L$1&"E6]0;;\0"));6)
только для натуральных положительных чисел до миллиона.

Автор - Светлый
Дата добавления - 03.09.2021 в 19:02
jakim Дата: Воскресенье, 05.09.2021, 08:12 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1035
Репутация: 278 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=AGGREGATE(15;6;A2:J2/(COUNTIF(A2:J2;A2:J2)>L$1);1)

В ячейку L1 впишите число нужных повторений.
К сообщению приложен файл: of-.xlsx(11.5 Kb)
 
Ответить
Сообщение
Формула

Код
=AGGREGATE(15;6;A2:J2/(COUNTIF(A2:J2;A2:J2)>L$1);1)

В ячейку L1 впишите число нужных повторений.

Автор - jakim
Дата добавления - 05.09.2021 в 08:12
Sergey3705 Дата: Понедельник, 06.09.2021, 11:34 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

А если таких значений несколько?

Хорогий вопрос:) то, набор значений с минимальной величиной.
тут только цифры.
 
Ответить
Сообщение
А если таких значений несколько?

Хорогий вопрос:) то, набор значений с минимальной величиной.
тут только цифры.

Автор - Sergey3705
Дата добавления - 06.09.2021 в 11:34
Sergey3705 Дата: Понедельник, 06.09.2021, 11:39 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

В ячейку L1 впишите число нужных повторений.

спасибо, так работает)
коллега выше хороший вопрос обозначил, а что если таких вариантов будет 2 и более?
можно ли как-то учесть такой вариант и для такого сценария выбирать совпадения с наименьшей величиной?

т.е. к примеру минимальное число повторений - 3
и есть варианта:
- 111
- 333
Соответственно выбираем "111"
 
Ответить
Сообщение
В ячейку L1 впишите число нужных повторений.

спасибо, так работает)
коллега выше хороший вопрос обозначил, а что если таких вариантов будет 2 и более?
можно ли как-то учесть такой вариант и для такого сценария выбирать совпадения с наименьшей величиной?

т.е. к примеру минимальное число повторений - 3
и есть варианта:
- 111
- 333
Соответственно выбираем "111"

Автор - Sergey3705
Дата добавления - 06.09.2021 в 11:39
Egyptian Дата: Понедельник, 06.09.2021, 16:18 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 163
Репутация: 53 ±
Замечаний: 0% ±

Excel 2013/2016
Sergey3705, В представленном варианте от jakim будет выбираться наименьшая величина.


Сообщение отредактировал Egyptian - Понедельник, 06.09.2021, 16:24
 
Ответить
СообщениеSergey3705, В представленном варианте от jakim будет выбираться наименьшая величина.

Автор - Egyptian
Дата добавления - 06.09.2021 в 16:18
jakim Дата: Вторник, 07.09.2021, 13:33 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1035
Репутация: 278 ±
Замечаний: 0% ±

Excel 2010
Вариант с выводом повторений от найбольшего к меньшему.

Код
=IFERROR(AGGREGATE(14;6;$A2:$J2/(COUNTIF($A2:$J2;$A2:$J2)>=$M$1)/(COUNTIF($K2:K2;$A2:$J2)=0);COLUMNS($L:L));"")
К сообщению приложен файл: 5276762.xlsx(11.9 Kb)
 
Ответить
Сообщение
Вариант с выводом повторений от найбольшего к меньшему.

Код
=IFERROR(AGGREGATE(14;6;$A2:$J2/(COUNTIF($A2:$J2;$A2:$J2)>=$M$1)/(COUNTIF($K2:K2;$A2:$J2)=0);COLUMNS($L:L));"")

Автор - jakim
Дата добавления - 07.09.2021 в 13:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечь из 10 колонок повторяющиеся более 3 раз значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!