Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула убрать дубликаты - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула убрать дубликаты (Формулы/Formulas)
Формула убрать дубликаты
DAUR Дата: Вторник, 14.09.2021, 14:49 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 24
Репутация: 0 ±
Замечаний: 0% ±

Всем привет
Помогите найти формулу которая бы сама убирала дубликаты из списка оставив только уникальные номера и в следующем столбце показывала бы сколько раз номер повторяется
заранее благодарю
К сообщению приложен файл: 3553000.xlsx(8.9 Kb)
 
Ответить
СообщениеВсем привет
Помогите найти формулу которая бы сама убирала дубликаты из списка оставив только уникальные номера и в следующем столбце показывала бы сколько раз номер повторяется
заранее благодарю

Автор - DAUR
Дата добавления - 14.09.2021 в 14:49
китин Дата: Вторник, 14.09.2021, 14:57 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$32;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($A$2:$A$32;$A$2:$A$32;0)=СТРОКА($A$2:$A$32)-1;СТРОКА($A$2:$A$32)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: DAUR.xlsx(10.1 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$32;НАИМЕНЬШИЙ(ЕСЛИ(ПОИСКПОЗ($A$2:$A$32;$A$2:$A$32;0)=СТРОКА($A$2:$A$32)-1;СТРОКА($A$2:$A$32)-1);СТРОКА(A1)));"")

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 14.09.2021 в 14:57
jakim Дата: Вторник, 14.09.2021, 16:01 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1115
Репутация: 295 ±
Замечаний: 0% ±

Excel 2010
Номер

Код
=IFERROR(INDEX(A$2:A$1111;MATCH(1;INDEX((COUNTIF(B$1:B1;A$2:A$1111)=0)*(COUNTIF($A$2:$A$1111;$A$2:$A$1111)>=2);0);0));"")

кол-во

Код
=IF(B2<>"";COUNTIF(A$2:A$32;B2);"")
К сообщению приложен файл: 3553000-2.xlsx(9.4 Kb)


Сообщение отредактировал jakim - Вторник, 14.09.2021, 16:44
 
Ответить
Сообщение
Номер

Код
=IFERROR(INDEX(A$2:A$1111;MATCH(1;INDEX((COUNTIF(B$1:B1;A$2:A$1111)=0)*(COUNTIF($A$2:$A$1111;$A$2:$A$1111)>=2);0);0));"")

кол-во

Код
=IF(B2<>"";COUNTIF(A$2:A$32;B2);"")

Автор - jakim
Дата добавления - 14.09.2021 в 16:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула убрать дубликаты (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!