Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Множественное условие - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Множественное условие (Формулы/Formulas)
Множественное условие
Юрий_Ф Дата: Суббота, 18.09.2021, 23:53 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 430
Репутация: -1 ±
Замечаний: 20% ±

Excel 2010
Уважаемые специалисты, гуру!

В приложенном файле значения столбцов А и F зависят от ячеек столбца В:
если ячейка года пустая, то и ячейки курса и самолёта пустые;
если год 1972, то курс - Второй, а самолёт - Л-29;
если год 1973, то соответственно - Третий и УТИ МиГ-15;
если 1974 - Четвёртый и МиГ-21у(ус).
Что-то мозгов не хватает всё перечислить в одной формуле несколько значений.
Как всегда прошу помощи!
К сообщению приложен файл: 2378262.xlsx(9.4 Kb)


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеУважаемые специалисты, гуру!

В приложенном файле значения столбцов А и F зависят от ячеек столбца В:
если ячейка года пустая, то и ячейки курса и самолёта пустые;
если год 1972, то курс - Второй, а самолёт - Л-29;
если год 1973, то соответственно - Третий и УТИ МиГ-15;
если 1974 - Четвёртый и МиГ-21у(ус).
Что-то мозгов не хватает всё перечислить в одной формуле несколько значений.
Как всегда прошу помощи!

Автор - Юрий_Ф
Дата добавления - 18.09.2021 в 23:53
DrMini Дата: Воскресенье, 19.09.2021, 06:36 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 24 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
Доброго времени суток.
перечислить в одной формуле несколько значений.

Может через ВПР подойдёт?
К сообщению приложен файл: 2378262-1.xlsx(13.3 Kb)


Сообщение отредактировал DrMini - Воскресенье, 19.09.2021, 06:42
 
Ответить
СообщениеДоброго времени суток.
перечислить в одной формуле несколько значений.

Может через ВПР подойдёт?

Автор - DrMini
Дата добавления - 19.09.2021 в 06:36
Юрий_Ф Дата: Воскресенье, 19.09.2021, 22:32 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 430
Репутация: -1 ±
Замечаний: 20% ±

Excel 2010
DrMini

Простое и интересное решение!
Но я понял так, что нужен дополнительный лист, в котором год должен стоять в самом левом столбце?


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеDrMini

Простое и интересное решение!
Но я понял так, что нужен дополнительный лист, в котором год должен стоять в самом левом столбце?

Автор - Юрий_Ф
Дата добавления - 19.09.2021 в 22:32
bmv98rus Дата: Воскресенье, 19.09.2021, 23:07 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3667
Репутация: 650 ±
Замечаний: 0% ±

Excel 2013/2016
что нужен дополнительный лист

Код
=IFERROR(VLOOKUP(B3;{1972\"Второй"\"Л-29";1973\"Третий"\"УТИ МиГ-15";1974\"Четвёртый"\"МиГ-21у(ус)"};3;);"")


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
что нужен дополнительный лист

Код
=IFERROR(VLOOKUP(B3;{1972\"Второй"\"Л-29";1973\"Третий"\"УТИ МиГ-15";1974\"Четвёртый"\"МиГ-21у(ус)"};3;);"")

Автор - bmv98rus
Дата добавления - 19.09.2021 в 23:07
Юрий_Ф Дата: Воскресенье, 19.09.2021, 23:29 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 430
Репутация: -1 ±
Замечаний: 20% ±

Excel 2010
bmv98rus

Пишет: Ошибка в формуле!
(Пытался подставить вашу формулу в ячейки и с курсом, и с самолётом. Везде пишет: Ошибка в формуле...)


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!


Сообщение отредактировал Юрий_Ф - Воскресенье, 19.09.2021, 23:29
 
Ответить
Сообщениеbmv98rus

Пишет: Ошибка в формуле!
(Пытался подставить вашу формулу в ячейки и с курсом, и с самолётом. Везде пишет: Ошибка в формуле...)

Автор - Юрий_Ф
Дата добавления - 19.09.2021 в 23:29
nikitan95 Дата: Понедельник, 20.09.2021, 01:19 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 410
Репутация: 0 ±
Замечаний: 0% ±

2016
Код
=ЕСЛИОШИБКА(ВПР(C3;{1972;"Второй";"Л-29":1973;"Третий";"УТИ МиГ-15":1974;"Четвёртый";"МиГ-21у(ус)"};3;);"")

или можно через дополнительный столбец. Оба варианта в файле.
К сообщению приложен файл: 4910386.xlsx(10.3 Kb)
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР(C3;{1972;"Второй";"Л-29":1973;"Третий";"УТИ МиГ-15":1974;"Четвёртый";"МиГ-21у(ус)"};3;);"")

или можно через дополнительный столбец. Оба варианта в файле.

Автор - nikitan95
Дата добавления - 20.09.2021 в 01:19
DrMini Дата: Понедельник, 20.09.2021, 05:34 | Сообщение № 7
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 24 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
я понял так, что нужен дополнительный лист

Да. Но лист можно скрыть и внешне смотреться будет, как было.
 
Ответить
Сообщение
я понял так, что нужен дополнительный лист

Да. Но лист можно скрыть и внешне смотреться будет, как было.

Автор - DrMini
Дата добавления - 20.09.2021 в 05:34
Юрий_Ф Дата: Понедельник, 20.09.2021, 23:30 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 430
Репутация: -1 ±
Замечаний: 20% ±

Excel 2010
DrMini

Дополнительный лист есть - не проблема. Скрывать не от кого. Всё для своего удобства. Спасибо.


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!


Сообщение отредактировал Юрий_Ф - Понедельник, 20.09.2021, 23:42
 
Ответить
СообщениеDrMini

Дополнительный лист есть - не проблема. Скрывать не от кого. Всё для своего удобства. Спасибо.

Автор - Юрий_Ф
Дата добавления - 20.09.2021 в 23:30
Юрий_Ф Дата: Понедельник, 20.09.2021, 23:43 | Сообщение № 9
Группа: Проверенные
Ранг: Обитатель
Сообщений: 430
Репутация: -1 ±
Замечаний: 20% ±

Excel 2010
nikitan95

Что-то не работает ни один из вариантов!
Спасибо. С дополнительным листом, по-видимому, самый простой вариант!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
Сообщениеnikitan95

Что-то не работает ни один из вариантов!
Спасибо. С дополнительным листом, по-видимому, самый простой вариант!

Автор - Юрий_Ф
Дата добавления - 20.09.2021 в 23:43
DrMini Дата: Вторник, 21.09.2021, 05:19 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 24 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
Если "перефразировать" формулу nikitan95, то можно предложить вот такой вариант без дополнительных столбцов и листов:
для A3:
Код
=ЕСЛИОШИБКА(ВПР(C3;{1972;"Л-29";"Второй":1973;"УТИ МиГ-15";"Третий":1974;"МиГ-21у(ус)";"Четвёртый"};3;);"")

Так будет правильнее (по совету Михаила):
Код
=ЕСЛИОШИБКА(ВПР(C3;{1972;"Л-29";"Второй":1973;"УТИ МиГ-15";"Третий":1974;"МиГ-21у(ус)";"Четвёртый"};2;);"")

для F3 без изменений:
Код
=ЕСЛИОШИБКА(ВПР(C3;{1972;"Второй";"Л-29":1973;"Третий";"УТИ МиГ-15":1974;"Четвёртый";"МиГ-21у(ус)"};3;);"")

и протянуть.
К сообщению приложен файл: 2378262-3.xlsx(10.7 Kb)


Сообщение отредактировал DrMini - Вторник, 21.09.2021, 09:33
 
Ответить
СообщениеЕсли "перефразировать" формулу nikitan95, то можно предложить вот такой вариант без дополнительных столбцов и листов:
для A3:
Код
=ЕСЛИОШИБКА(ВПР(C3;{1972;"Л-29";"Второй":1973;"УТИ МиГ-15";"Третий":1974;"МиГ-21у(ус)";"Четвёртый"};3;);"")

Так будет правильнее (по совету Михаила):
Код
=ЕСЛИОШИБКА(ВПР(C3;{1972;"Л-29";"Второй":1973;"УТИ МиГ-15";"Третий":1974;"МиГ-21у(ус)";"Четвёртый"};2;);"")

для F3 без изменений:
Код
=ЕСЛИОШИБКА(ВПР(C3;{1972;"Второй";"Л-29":1973;"Третий";"УТИ МиГ-15":1974;"Четвёртый";"МиГ-21у(ус)"};3;);"")

и протянуть.

Автор - DrMini
Дата добавления - 21.09.2021 в 05:19
bmv98rus Дата: Вторник, 21.09.2021, 07:50 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3667
Репутация: 650 ±
Замечаний: 0% ±

Excel 2013/2016
DrMini, зачем местами менять в массиве если можно выбрать индекс 2, а не 3?


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеDrMini, зачем местами менять в массиве если можно выбрать индекс 2, а не 3?

Автор - bmv98rus
Дата добавления - 21.09.2021 в 07:50
DrMini Дата: Вторник, 21.09.2021, 09:24 | Сообщение № 12
Группа: Проверенные
Ранг: Ветеран
Сообщений: 641
Репутация: 24 ±
Замечаний: 0% ±

Excel 2010, 2013, 2019 RUS
зачем местами менять в массиве

Я просто посмотрел на формулу и подумал: Что будет если поменять местами? Ну и получилось. Про то, что даёт цифра 3 - узнал от Вас.
Большое спасибо.
Как раз на прошлой неделе попросили сделать график дежурств и я переделаю свой (который с доп. листом) на вот такой вариант. Просто так я ещё никогда не делал.


Сообщение отредактировал DrMini - Вторник, 21.09.2021, 09:34
 
Ответить
Сообщение
зачем местами менять в массиве

Я просто посмотрел на формулу и подумал: Что будет если поменять местами? Ну и получилось. Про то, что даёт цифра 3 - узнал от Вас.
Большое спасибо.
Как раз на прошлой неделе попросили сделать график дежурств и я переделаю свой (который с доп. листом) на вот такой вариант. Просто так я ещё никогда не делал.

Автор - DrMini
Дата добавления - 21.09.2021 в 09:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Множественное условие (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!